uboot-sunxi: add support for LinkSprite pcDuino v3 (a20)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 40605
This commit is contained in:
parent
ef9f0fa232
commit
9ee3edb4ca
3 changed files with 62 additions and 1 deletions
|
@ -56,7 +56,11 @@ define uboot/pcDuino
|
|||
TITLE:=U-Boot 2014.01-rc1 for pcDuino
|
||||
endef
|
||||
|
||||
UBOOTS:=A10-OLinuXino-Lime A13-OLinuXino A20-OLinuXino_MICRO Cubieboard Cubieboard2 Cubietruck Hackberry pcDuino
|
||||
define uboot/pcDuino3
|
||||
TITLE:=U-Boot 2014.01-rc1 for pcDuino3
|
||||
endef
|
||||
|
||||
UBOOTS:=A10-OLinuXino-Lime A13-OLinuXino A20-OLinuXino_MICRO Cubieboard Cubieboard2 Cubietruck Hackberry pcDuino pcDuino3
|
||||
|
||||
define Package/uboot/template
|
||||
define Package/uboot-sunxi-$(1)
|
||||
|
|
57
package/boot/uboot-sunxi/patches/002-pcduino3.patch
Normal file
57
package/boot/uboot-sunxi/patches/002-pcduino3.patch
Normal file
|
@ -0,0 +1,57 @@
|
|||
diff -ruN u-boot-2014.01-rc1.old/board/sunxi/dram_pcduino3.c u-boot-2014.01-rc1/board/sunxi/dram_pcduino3.c
|
||||
--- u-boot-2014.01-rc1.old/board/sunxi/dram_pcduino3.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ u-boot-2014.01-rc1/board/sunxi/dram_pcduino3.c 2014-04-23 20:04:00.919994615 +0200
|
||||
@@ -0,0 +1,31 @@
|
||||
+/* this file is generated, don't edit it yourself */
|
||||
+
|
||||
+#include <common.h>
|
||||
+#include <asm/arch/dram.h>
|
||||
+
|
||||
+static struct dram_para dram_para = {
|
||||
+ .clock = 408,
|
||||
+ .type = 3,
|
||||
+ .rank_num = 1,
|
||||
+ .density = 4096,
|
||||
+ .io_width = 16,
|
||||
+ .bus_width = 32,
|
||||
+ .cas = 9,
|
||||
+ .zq = 0x7a,
|
||||
+ .odt_en = 0,
|
||||
+ .size = 1024,
|
||||
+ .tpr0 = 0x42d899b7,
|
||||
+ .tpr1 = 0xa090,
|
||||
+ .tpr2 = 0x22a00,
|
||||
+ .tpr3 = 0,
|
||||
+ .tpr4 = 0x1,
|
||||
+ .tpr5 = 0,
|
||||
+ .emr1 = 0x4,
|
||||
+ .emr2 = 0x10,
|
||||
+ .emr3 = 0x0,
|
||||
+};
|
||||
+
|
||||
+unsigned long sunxi_dram_init(void)
|
||||
+{
|
||||
+ return dramc_init(&dram_para);
|
||||
+}
|
||||
diff -ruN u-boot-2014.01-rc1.old/board/sunxi/Makefile u-boot-2014.01-rc1/board/sunxi/Makefile
|
||||
--- u-boot-2014.01-rc1.old/board/sunxi/Makefile 2014-04-12 18:51:34.000000000 +0200
|
||||
+++ u-boot-2014.01-rc1/board/sunxi/Makefile 2014-04-23 20:02:51.828839920 +0200
|
||||
@@ -73,6 +73,7 @@
|
||||
obj-$(CONFIG_MK802II) += dram_sun4i_408_1024_iow8.o
|
||||
obj-$(CONFIG_MK802II_A20) += dram_mk802ii_a20.o
|
||||
obj-$(CONFIG_PCDUINO) += dram_sun4i_408_1024_iow8.o
|
||||
+obj-$(CONFIG_PCDUINO3) += dram_pcduino3.o
|
||||
obj-$(CONFIG_PENGPOD700) += dram_sun4i_384_1024_iow8.o
|
||||
obj-$(CONFIG_PENGPOD1000) += dram_sun4i_408_1024_iow16.o
|
||||
obj-$(CONFIG_POV_PROTAB2) += dram_pov_protab2.o
|
||||
diff -ruN u-boot-2014.01-rc1.old/boards.cfg u-boot-2014.01-rc1/boards.cfg
|
||||
--- u-boot-2014.01-rc1.old/boards.cfg 2014-04-12 18:51:34.000000000 +0200
|
||||
+++ u-boot-2014.01-rc1/boards.cfg 2014-04-23 20:02:27.897132713 +0200
|
||||
@@ -404,6 +404,7 @@
|
||||
Active arm armv7 sunxi - sunxi mk802ii_A20 sun7i:MK802II_A20,SPL -
|
||||
Active arm armv7 sunxi - sunxi mk802ii sun4i:MK802II,SPL -
|
||||
Active arm armv7 sunxi - sunxi pcDuino sun4i:PCDUINO,SPL,SUNXI_EMAC -
|
||||
+Active arm armv7 sunxi - sunxi pcDuino3 sun7i:PCDUINO3,SPL,SUNXI_GMAC,FAST_MBUS -
|
||||
Active arm armv7 sunxi - sunxi pengpod1000 sun4i:PENGPOD1000,SPL -
|
||||
Active arm armv7 sunxi - sunxi pengpod700 sun4i:PENGPOD700,SPL -
|
||||
Active arm armv7 sunxi - sunxi PoV_ProTab2_IPS9 sun4i:POV_PROTAB2,SPL -
|
Loading…
Reference in a new issue