Add acx package
SVN-Revision: 6605
This commit is contained in:
parent
259c114526
commit
9eb91471ce
3 changed files with 95 additions and 0 deletions
56
package/acx/Makefile
Normal file
56
package/acx/Makefile
Normal file
|
@ -0,0 +1,56 @@
|
|||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=acx
|
||||
PKG_VERSION:=20070101
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://lisas.de/~andi/acx100/
|
||||
PKG_MD5SUM:=ec6322b9c82781897a9433ef0cefda6f
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
#PKG_CAT:=bzcat
|
||||
PKG_UNPACK:=bzcat $(DL_DIR)/$(PKG_SOURCE) | \
|
||||
$(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS); \
|
||||
chmod -R u+w $(PKG_BUILD_DIR)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define KernelPackage/acx
|
||||
TITLE:=Driver for TI ACX1xx chipset
|
||||
DEPENDS:=@LINUX_2_6 +wireless-tools
|
||||
DESCRIPTION:=\
|
||||
This package contains a driver for TI ACX1xx 802.11a/b/g chipsets.
|
||||
URL:=http://acx100.sourceforge.net/
|
||||
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
||||
SUBMENU:=Wireless Drivers
|
||||
FILES:= \
|
||||
$(PKG_BUILD_DIR)/acx.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,50,acx)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(LINUX_DIR) \
|
||||
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
CC="$(TARGET_CC)" \
|
||||
CPP="$(TARGET_CC)" \
|
||||
LD="$(TARGET_CROSS)ld" \
|
||||
KERNELVERSION="$(KERNEL)" \
|
||||
KERNEL_SOURCE="$(LINUX_DIR)" \
|
||||
KDIR="$(LINUX_DIR)" \
|
||||
CONFIG_ACX=m \
|
||||
CONFIG_ACX_PCI=m \
|
||||
modules
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,acx))
|
18
package/acx/patches/001-no-reset.diff
Normal file
18
package/acx/patches/001-no-reset.diff
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- acx-20060521.orig/pci.c 2007-01-25 15:43:48.000000000 +0700
|
||||
+++ acx-20060521/pci.c 2007-01-25 15:43:48.000000000 +0700
|
||||
@@ -906,10 +906,13 @@
|
||||
|
||||
acx_lock(adev, flags);
|
||||
|
||||
- acxpci_l_reset_mac(adev);
|
||||
-
|
||||
ecpu_ctrl = read_reg16(adev, IO_ACX_ECPU_CTRL) & 1;
|
||||
if (!ecpu_ctrl) {
|
||||
+ acxpci_l_reset_mac(adev);
|
||||
+ ecpu_ctrl = read_reg16(adev, IO_ACX_ECPU_CTRL) & 1;
|
||||
+ }
|
||||
+
|
||||
+ if (!ecpu_ctrl) {
|
||||
msg = "eCPU is already running. ";
|
||||
goto end_unlock;
|
||||
}
|
21
package/acx/patches/002-disable-usb.diff
Normal file
21
package/acx/patches/002-disable-usb.diff
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- acx-20070101.orig/Makefile 2007-01-25 17:09:24.000000000 +0700
|
||||
+++ acx-20070101/Makefile 2007-01-25 17:09:41.000000000 +0700
|
||||
@@ -1,7 +1,7 @@
|
||||
obj-m += acx.o
|
||||
|
||||
acx-obj-y += pci.o
|
||||
-acx-obj-y += usb.o
|
||||
+#acx-obj-y += usb.o
|
||||
|
||||
acx-objs := wlan.o conv.o ioctl.o common.o $(acx-obj-y)
|
||||
|
||||
--- acx-20070101.orig/acx_config.h 2007-01-25 17:21:05.000000000 +0700
|
||||
+++ acx-20070101/acx_config.h 2007-01-25 17:21:08.000000000 +0700
|
||||
@@ -1,6 +1,6 @@
|
||||
/* temporary hack until proper Kconfig integration */
|
||||
#define CONFIG_ACX_PCI 1
|
||||
-#define CONFIG_ACX_USB 1
|
||||
+/*#define CONFIG_ACX_USB 1*/
|
||||
|
||||
#define ACX_RELEASE "v0.3.36"
|
||||
|
Loading…
Reference in a new issue