kernel: add a workaround to rebuild vdso.so.dbg after genvdso
Currently the build fails with 'arch/mips/vdso/vdso.so.dbg' already contains a '.MIPS.abiflags' section if the file already exists from a prior build. Add a makefile rule to force the rebuild of vdso.so.dbg if genvdso has has been changed to workaround the failure. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
d9a0a8c78f
commit
9eb155353a
1 changed files with 11 additions and 0 deletions
|
@ -0,0 +1,11 @@
|
|||
--- a/arch/mips/vdso/Makefile
|
||||
+++ b/arch/mips/vdso/Makefile
|
||||
@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
|
||||
|
||||
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
|
||||
|
||||
-$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) FORCE
|
||||
+$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) $(obj)/genvdso FORCE
|
||||
$(call if_changed,vdsold)
|
||||
|
||||
$(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE
|
Loading…
Reference in a new issue