iw: update to 3.10, sync with nl80211.h changes in compat-wireless
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36569
This commit is contained in:
parent
bd6e12d904
commit
9d8e3e03df
6 changed files with 72 additions and 512 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iw
|
||||
PKG_VERSION:=3.6
|
||||
PKG_VERSION:=3.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://wireless.kernel.org/download/iw/
|
||||
PKG_MD5SUM:=1c18bfbbc8773629e5e8ac733a39540c
|
||||
PKG_SOURCE_URL:=https://www.kernel.org/pub/software/network/iw
|
||||
PKG_MD5SUM:=0dc736963455937278b10fe8a2157e47
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
|
||||
|
||||
|
|
|
@ -1,416 +1,32 @@
|
|||
--- a/nl80211.h
|
||||
+++ b/nl80211.h
|
||||
@@ -118,8 +118,9 @@
|
||||
* to get a list of all present wiphys.
|
||||
* @NL80211_CMD_SET_WIPHY: set wiphy parameters, needs %NL80211_ATTR_WIPHY or
|
||||
* %NL80211_ATTR_IFINDEX; can be used to set %NL80211_ATTR_WIPHY_NAME,
|
||||
- * %NL80211_ATTR_WIPHY_TXQ_PARAMS, %NL80211_ATTR_WIPHY_FREQ,
|
||||
- * %NL80211_ATTR_WIPHY_CHANNEL_TYPE, %NL80211_ATTR_WIPHY_RETRY_SHORT,
|
||||
+ * %NL80211_ATTR_WIPHY_TXQ_PARAMS, %NL80211_ATTR_WIPHY_FREQ (and the
|
||||
+ * attributes determining the channel width; this is used for setting
|
||||
+ * monitor mode channel), %NL80211_ATTR_WIPHY_RETRY_SHORT,
|
||||
* %NL80211_ATTR_WIPHY_RETRY_LONG, %NL80211_ATTR_WIPHY_FRAG_THRESHOLD,
|
||||
* and/or %NL80211_ATTR_WIPHY_RTS_THRESHOLD.
|
||||
* However, for setting the channel, see %NL80211_CMD_SET_CHANNEL
|
||||
@@ -171,7 +172,7 @@
|
||||
* %NL80211_ATTR_AKM_SUITES, %NL80211_ATTR_PRIVACY,
|
||||
* %NL80211_ATTR_AUTH_TYPE and %NL80211_ATTR_INACTIVITY_TIMEOUT.
|
||||
* The channel to use can be set on the interface or be given using the
|
||||
- * %NL80211_ATTR_WIPHY_FREQ and %NL80211_ATTR_WIPHY_CHANNEL_TYPE attrs.
|
||||
+ * %NL80211_ATTR_WIPHY_FREQ and the attributes determining channel width.
|
||||
* @NL80211_CMD_NEW_BEACON: old alias for %NL80211_CMD_START_AP
|
||||
* @NL80211_CMD_STOP_AP: Stop AP operation on the given interface
|
||||
* @NL80211_CMD_DEL_BEACON: old alias for %NL80211_CMD_STOP_AP
|
||||
@@ -401,8 +402,7 @@
|
||||
* a response while being associated to an AP on another channel.
|
||||
* %NL80211_ATTR_IFINDEX is used to specify which interface (and thus
|
||||
* radio) is used. %NL80211_ATTR_WIPHY_FREQ is used to specify the
|
||||
- * frequency for the operation and %NL80211_ATTR_WIPHY_CHANNEL_TYPE may be
|
||||
- * optionally used to specify additional channel parameters.
|
||||
+ * frequency for the operation.
|
||||
* %NL80211_ATTR_DURATION is used to specify the duration in milliseconds
|
||||
* to remain on the channel. This command is also used as an event to
|
||||
* notify when the requested duration starts (it may take a while for the
|
||||
@@ -440,12 +440,11 @@
|
||||
* as an event indicating reception of a frame that was not processed in
|
||||
* kernel code, but is for us (i.e., which may need to be processed in a
|
||||
* user space application). %NL80211_ATTR_FRAME is used to specify the
|
||||
- * frame contents (including header). %NL80211_ATTR_WIPHY_FREQ (and
|
||||
- * optionally %NL80211_ATTR_WIPHY_CHANNEL_TYPE) is used to indicate on
|
||||
- * which channel the frame is to be transmitted or was received. If this
|
||||
- * channel is not the current channel (remain-on-channel or the
|
||||
- * operational channel) the device will switch to the given channel and
|
||||
- * transmit the frame, optionally waiting for a response for the time
|
||||
+ * frame contents (including header). %NL80211_ATTR_WIPHY_FREQ is used
|
||||
+ * to indicate on which channel the frame is to be transmitted or was
|
||||
+ * received. If this channel is not the current channel (remain-on-channel
|
||||
+ * or the operational channel) the device will switch to the given channel
|
||||
+ * and transmit the frame, optionally waiting for a response for the time
|
||||
* specified using %NL80211_ATTR_DURATION. When called, this operation
|
||||
* returns a cookie (%NL80211_ATTR_COOKIE) that will be included with the
|
||||
* TX status event pertaining to the TX request.
|
||||
@@ -473,8 +472,8 @@
|
||||
* command is used as an event to indicate the that a trigger level was
|
||||
* reached.
|
||||
* @NL80211_CMD_SET_CHANNEL: Set the channel (using %NL80211_ATTR_WIPHY_FREQ
|
||||
- * and %NL80211_ATTR_WIPHY_CHANNEL_TYPE) the given interface (identifed
|
||||
- * by %NL80211_ATTR_IFINDEX) shall operate on.
|
||||
+ * and the attributes determining channel width) the given interface
|
||||
+ * (identifed by %NL80211_ATTR_IFINDEX) shall operate on.
|
||||
* In case multiple channels are supported by the device, the mechanism
|
||||
* with which it switches channels is implementation-defined.
|
||||
* When a monitor interface is given, it can only switch channel while
|
||||
@@ -526,6 +525,12 @@
|
||||
* of PMKSA caching dandidates.
|
||||
*
|
||||
* @NL80211_CMD_TDLS_OPER: Perform a high-level TDLS command (e.g. link setup).
|
||||
+ * In addition, this can be used as an event to request userspace to take
|
||||
+ * actions on TDLS links (set up a new link or tear down an existing one).
|
||||
+ * In such events, %NL80211_ATTR_TDLS_OPERATION indicates the requested
|
||||
+ * operation, %NL80211_ATTR_MAC contains the peer MAC address, and
|
||||
+ * %NL80211_ATTR_REASON_CODE the reason code to be used (only with
|
||||
+ * %NL80211_TDLS_TEARDOWN).
|
||||
* @NL80211_CMD_TDLS_MGMT: Send a TDLS management frame.
|
||||
*
|
||||
* @NL80211_CMD_UNEXPECTED_FRAME: Used by an application controlling an AP
|
||||
@@ -562,8 +567,24 @@
|
||||
*
|
||||
* @NL80211_CMD_CH_SWITCH_NOTIFY: An AP or GO may decide to switch channels
|
||||
* independently of the userspace SME, send this event indicating
|
||||
- * %NL80211_ATTR_IFINDEX is now on %NL80211_ATTR_WIPHY_FREQ with
|
||||
- * %NL80211_ATTR_WIPHY_CHANNEL_TYPE.
|
||||
+ * %NL80211_ATTR_IFINDEX is now on %NL80211_ATTR_WIPHY_FREQ and the
|
||||
+ * attributes determining channel width.
|
||||
+ *
|
||||
+ * @NL80211_CMD_START_P2P_DEVICE: Start the given P2P Device, identified by
|
||||
+ * its %NL80211_ATTR_WDEV identifier. It must have been created with
|
||||
+ * %NL80211_CMD_NEW_INTERFACE previously. After it has been started, the
|
||||
+ * P2P Device can be used for P2P operations, e.g. remain-on-channel and
|
||||
+ * public action frame TX.
|
||||
+ * @NL80211_CMD_STOP_P2P_DEVICE: Stop the given P2P Device, identified by
|
||||
+ * its %NL80211_ATTR_WDEV identifier.
|
||||
+ *
|
||||
+ * @NL80211_CMD_CONN_FAILED: connection request to an AP failed; used to
|
||||
+ * notify userspace that AP has rejected the connection request from a
|
||||
+ * station, due to particular reason. %NL80211_ATTR_CONN_FAILED_REASON
|
||||
+ * is used for this.
|
||||
+ *
|
||||
+ * @NL80211_CMD_SET_MCAST_RATE: Change the rate used to send multicast frames
|
||||
+ * for IBSS or MESH vif.
|
||||
*
|
||||
* @NL80211_CMD_MAX: highest used command number
|
||||
* @__NL80211_CMD_AFTER_LAST: internal use
|
||||
@@ -708,6 +729,13 @@ enum nl80211_commands {
|
||||
@@ -1724,8 +1724,7 @@ enum nl80211_attrs {
|
||||
NL80211_ATTR_MDID,
|
||||
NL80211_ATTR_IE_RIC,
|
||||
|
||||
NL80211_CMD_CH_SWITCH_NOTIFY,
|
||||
|
||||
+ NL80211_CMD_START_P2P_DEVICE,
|
||||
+ NL80211_CMD_STOP_P2P_DEVICE,
|
||||
+
|
||||
+ NL80211_CMD_CONN_FAILED,
|
||||
+
|
||||
+ NL80211_CMD_SET_MCAST_RATE,
|
||||
+
|
||||
/* add new commands above here */
|
||||
|
||||
/* used to define NL80211_CMD_MAX below */
|
||||
@@ -744,14 +772,26 @@ enum nl80211_commands {
|
||||
* /sys/class/ieee80211/<phyname>/index
|
||||
* @NL80211_ATTR_WIPHY_NAME: wiphy name (used for renaming)
|
||||
* @NL80211_ATTR_WIPHY_TXQ_PARAMS: a nested array of TX queue parameters
|
||||
- * @NL80211_ATTR_WIPHY_FREQ: frequency of the selected channel in MHz
|
||||
+ * @NL80211_ATTR_WIPHY_FREQ: frequency of the selected channel in MHz,
|
||||
+ * defines the channel together with the (deprecated)
|
||||
+ * %NL80211_ATTR_WIPHY_CHANNEL_TYPE attribute or the attributes
|
||||
+ * %NL80211_ATTR_CHANNEL_WIDTH and if needed %NL80211_ATTR_CENTER_FREQ1
|
||||
+ * and %NL80211_ATTR_CENTER_FREQ2
|
||||
+ * @NL80211_ATTR_CHANNEL_WIDTH: u32 attribute containing one of the values
|
||||
+ * of &enum nl80211_chan_width, describing the channel width. See the
|
||||
+ * documentation of the enum for more information.
|
||||
+ * @NL80211_ATTR_CENTER_FREQ1: Center frequency of the first part of the
|
||||
+ * channel, used for anything but 20 MHz bandwidth
|
||||
+ * @NL80211_ATTR_CENTER_FREQ2: Center frequency of the second part of the
|
||||
+ * channel, used only for 80+80 MHz bandwidth
|
||||
* @NL80211_ATTR_WIPHY_CHANNEL_TYPE: included with NL80211_ATTR_WIPHY_FREQ
|
||||
- * if HT20 or HT40 are allowed (i.e., 802.11n disabled if not included):
|
||||
+ * if HT20 or HT40 are to be used (i.e., HT disabled if not included):
|
||||
* NL80211_CHAN_NO_HT = HT not allowed (i.e., same as not including
|
||||
* this attribute)
|
||||
* NL80211_CHAN_HT20 = HT20 only
|
||||
* NL80211_CHAN_HT40MINUS = secondary channel is below the primary channel
|
||||
* NL80211_CHAN_HT40PLUS = secondary channel is above the primary channel
|
||||
+ * This attribute is now deprecated.
|
||||
* @NL80211_ATTR_WIPHY_RETRY_SHORT: TX retry limit for frames whose length is
|
||||
* less than or equal to the RTS threshold; allowed range: 1..255;
|
||||
* dot11ShortRetryLimit; u8
|
||||
@@ -1251,6 +1291,25 @@ enum nl80211_commands {
|
||||
* was used to provide the hint. For the different types of
|
||||
* allowed user regulatory hints see nl80211_user_reg_hint_type.
|
||||
*
|
||||
+ * @NL80211_ATTR_CONN_FAILED_REASON: The reason for which AP has rejected
|
||||
+ * the connection request from a station. nl80211_connect_failed_reason
|
||||
+ * enum has different reasons of connection failure.
|
||||
+ *
|
||||
+ * @NL80211_ATTR_SAE_DATA: SAE elements in Authentication frames. This starts
|
||||
+ * with the Authentication transaction sequence number field.
|
||||
+ *
|
||||
+ * @NL80211_ATTR_VHT_CAPABILITY: VHT Capability information element (from
|
||||
+ * association request when used with NL80211_CMD_NEW_STATION)
|
||||
+ *
|
||||
+ * @NL80211_ATTR_SCAN_FLAGS: scan request control flags (u32)
|
||||
+ *
|
||||
+ * @NL80211_ATTR_P2P_CTWINDOW: P2P GO Client Traffic Window (u8), used with
|
||||
+ * the START_AP and SET_BSS commands
|
||||
+ * @NL80211_ATTR_P2P_OPPPS: P2P GO opportunistic PS (u8), used with the
|
||||
+ * START_AP and SET_BSS commands. This can have the values 0 or 1;
|
||||
+ * if not given in START_AP 0 is assumed, if not given in SET_BSS
|
||||
+ * no change is made.
|
||||
+ *
|
||||
* @NL80211_ATTR_MAX: highest attribute number currently defined
|
||||
* @__NL80211_ATTR_AFTER_LAST: internal use
|
||||
*/
|
||||
@@ -1506,6 +1565,23 @@ enum nl80211_attrs {
|
||||
|
||||
NL80211_ATTR_USER_REG_HINT_TYPE,
|
||||
|
||||
+ NL80211_ATTR_CONN_FAILED_REASON,
|
||||
+
|
||||
+ NL80211_ATTR_SAE_DATA,
|
||||
+
|
||||
+ NL80211_ATTR_VHT_CAPABILITY,
|
||||
+
|
||||
+ NL80211_ATTR_SCAN_FLAGS,
|
||||
+
|
||||
+ NL80211_ATTR_CHANNEL_WIDTH,
|
||||
+ NL80211_ATTR_CENTER_FREQ1,
|
||||
+ NL80211_ATTR_CENTER_FREQ2,
|
||||
+
|
||||
+ NL80211_ATTR_P2P_CTWINDOW,
|
||||
+ NL80211_ATTR_P2P_OPPPS,
|
||||
+
|
||||
- NL80211_ATTR_CRIT_PROT_ID,
|
||||
- NL80211_ATTR_MAX_CRIT_PROT_DURATION,
|
||||
+ NL80211_ATTR_WIPHY_ANTENNA_GAIN,
|
||||
+
|
||||
|
||||
/* add attributes here, update the policy in nl80211.c */
|
||||
|
||||
__NL80211_ATTR_AFTER_LAST,
|
||||
@@ -1549,6 +1625,7 @@ enum nl80211_attrs {
|
||||
#define NL80211_TKIP_DATA_OFFSET_TX_MIC_KEY 16
|
||||
#define NL80211_TKIP_DATA_OFFSET_RX_MIC_KEY 24
|
||||
#define NL80211_HT_CAPABILITY_LEN 26
|
||||
+#define NL80211_VHT_CAPABILITY_LEN 12
|
||||
|
||||
#define NL80211_MAX_NR_CIPHER_SUITES 5
|
||||
#define NL80211_MAX_NR_AKM_SUITES 2
|
||||
@@ -1575,6 +1652,10 @@ enum nl80211_attrs {
|
||||
* @NL80211_IFTYPE_MESH_POINT: mesh point
|
||||
* @NL80211_IFTYPE_P2P_CLIENT: P2P client
|
||||
* @NL80211_IFTYPE_P2P_GO: P2P group owner
|
||||
+ * @NL80211_IFTYPE_P2P_DEVICE: P2P device interface type, this is not a netdev
|
||||
+ * and therefore can't be created in the normal ways, use the
|
||||
+ * %NL80211_CMD_START_P2P_DEVICE and %NL80211_CMD_STOP_P2P_DEVICE
|
||||
+ * commands to create and destroy one
|
||||
* @NL80211_IFTYPE_MAX: highest interface type number currently defined
|
||||
* @NUM_NL80211_IFTYPES: number of defined interface types
|
||||
*
|
||||
@@ -1593,6 +1674,7 @@ enum nl80211_iftype {
|
||||
NL80211_IFTYPE_MESH_POINT,
|
||||
NL80211_IFTYPE_P2P_CLIENT,
|
||||
NL80211_IFTYPE_P2P_GO,
|
||||
+ NL80211_IFTYPE_P2P_DEVICE,
|
||||
|
||||
/* keep last */
|
||||
NUM_NL80211_IFTYPES,
|
||||
@@ -1664,10 +1746,15 @@ struct nl80211_sta_flag_update {
|
||||
* @__NL80211_RATE_INFO_INVALID: attribute number 0 is reserved
|
||||
* @NL80211_RATE_INFO_BITRATE: total bitrate (u16, 100kbit/s)
|
||||
* @NL80211_RATE_INFO_MCS: mcs index for 802.11n (u8)
|
||||
- * @NL80211_RATE_INFO_40_MHZ_WIDTH: 40 Mhz dualchannel bitrate
|
||||
+ * @NL80211_RATE_INFO_40_MHZ_WIDTH: 40 MHz dualchannel bitrate
|
||||
* @NL80211_RATE_INFO_SHORT_GI: 400ns guard interval
|
||||
* @NL80211_RATE_INFO_BITRATE32: total bitrate (u32, 100kbit/s)
|
||||
* @NL80211_RATE_INFO_MAX: highest rate_info number currently defined
|
||||
+ * @NL80211_RATE_INFO_VHT_MCS: MCS index for VHT (u8)
|
||||
+ * @NL80211_RATE_INFO_VHT_NSS: number of streams in VHT (u8)
|
||||
+ * @NL80211_RATE_INFO_80_MHZ_WIDTH: 80 MHz VHT rate
|
||||
+ * @NL80211_RATE_INFO_80P80_MHZ_WIDTH: 80+80 MHz VHT rate
|
||||
+ * @NL80211_RATE_INFO_160_MHZ_WIDTH: 160 MHz VHT rate
|
||||
* @__NL80211_RATE_INFO_AFTER_LAST: internal use
|
||||
*/
|
||||
enum nl80211_rate_info {
|
||||
@@ -1677,6 +1764,11 @@ enum nl80211_rate_info {
|
||||
NL80211_RATE_INFO_40_MHZ_WIDTH,
|
||||
NL80211_RATE_INFO_SHORT_GI,
|
||||
NL80211_RATE_INFO_BITRATE32,
|
||||
+ NL80211_RATE_INFO_VHT_MCS,
|
||||
+ NL80211_RATE_INFO_VHT_NSS,
|
||||
+ NL80211_RATE_INFO_80_MHZ_WIDTH,
|
||||
+ NL80211_RATE_INFO_80P80_MHZ_WIDTH,
|
||||
+ NL80211_RATE_INFO_160_MHZ_WIDTH,
|
||||
|
||||
/* keep last */
|
||||
__NL80211_RATE_INFO_AFTER_LAST,
|
||||
@@ -1744,6 +1836,8 @@ enum nl80211_sta_bss_param {
|
||||
* @NL80211_STA_INFO_STA_FLAGS: Contains a struct nl80211_sta_flag_update.
|
||||
* @NL80211_STA_INFO_BEACON_LOSS: count of times beacon loss was detected (u32)
|
||||
* @NL80211_STA_INFO_T_OFFSET: timing offset with respect to this STA (s64)
|
||||
@@ -1991,6 +1990,10 @@ enum nl80211_sta_bss_param {
|
||||
* @NL80211_STA_INFO_PEER_PM: peer mesh STA link-specific power mode
|
||||
* @NL80211_STA_INFO_NONPEER_PM: neighbor mesh STA power save mode towards
|
||||
* non-peer STA
|
||||
+ * @NL80211_STA_INFO_CHAIN_SIGNAL: per-chain signal strength of last PPDU
|
||||
+ * Contains a nested array of signal strength attributes (u8, dBm)
|
||||
+ * @NL80211_STA_INFO_CHAIN_SIGNAL_AVG: per-chain signal strength average
|
||||
+ * Same format as NL80211_STA_INFO_CHAIN_SIGNAL.
|
||||
* @__NL80211_STA_INFO_AFTER_LAST: internal
|
||||
* @NL80211_STA_INFO_MAX: highest possible station info attribute
|
||||
*/
|
||||
@@ -1768,6 +1862,8 @@ enum nl80211_sta_info {
|
||||
NL80211_STA_INFO_STA_FLAGS,
|
||||
NL80211_STA_INFO_BEACON_LOSS,
|
||||
NL80211_STA_INFO_T_OFFSET,
|
||||
@@ -2020,6 +2023,8 @@ enum nl80211_sta_info {
|
||||
NL80211_STA_INFO_NONPEER_PM,
|
||||
NL80211_STA_INFO_RX_BYTES64,
|
||||
NL80211_STA_INFO_TX_BYTES64,
|
||||
+ NL80211_STA_INFO_CHAIN_SIGNAL,
|
||||
+ NL80211_STA_INFO_CHAIN_SIGNAL_AVG,
|
||||
|
||||
/* keep last */
|
||||
__NL80211_STA_INFO_AFTER_LAST,
|
||||
@@ -2385,6 +2481,15 @@ enum nl80211_ac {
|
||||
#define NL80211_TXQ_Q_BE NL80211_AC_BE
|
||||
#define NL80211_TXQ_Q_BK NL80211_AC_BK
|
||||
|
||||
+/**
|
||||
+ * enum nl80211_channel_type - channel type
|
||||
+ * @NL80211_CHAN_NO_HT: 20 MHz, non-HT channel
|
||||
+ * @NL80211_CHAN_HT20: 20 MHz HT channel
|
||||
+ * @NL80211_CHAN_HT40MINUS: HT40 channel, secondary channel
|
||||
+ * below the control channel
|
||||
+ * @NL80211_CHAN_HT40PLUS: HT40 channel, secondary channel
|
||||
+ * above the control channel
|
||||
+ */
|
||||
enum nl80211_channel_type {
|
||||
NL80211_CHAN_NO_HT,
|
||||
NL80211_CHAN_HT20,
|
||||
@@ -2393,6 +2498,32 @@ enum nl80211_channel_type {
|
||||
};
|
||||
|
||||
/**
|
||||
+ * enum nl80211_chan_width - channel width definitions
|
||||
+ *
|
||||
+ * These values are used with the %NL80211_ATTR_CHANNEL_WIDTH
|
||||
+ * attribute.
|
||||
+ *
|
||||
+ * @NL80211_CHAN_WIDTH_20_NOHT: 20 MHz, non-HT channel
|
||||
+ * @NL80211_CHAN_WIDTH_20: 20 MHz HT channel
|
||||
+ * @NL80211_CHAN_WIDTH_40: 40 MHz channel, the %NL80211_ATTR_CENTER_FREQ1
|
||||
+ * attribute must be provided as well
|
||||
+ * @NL80211_CHAN_WIDTH_80: 80 MHz channel, the %NL80211_ATTR_CENTER_FREQ1
|
||||
+ * attribute must be provided as well
|
||||
+ * @NL80211_CHAN_WIDTH_80P80: 80+80 MHz channel, the %NL80211_ATTR_CENTER_FREQ1
|
||||
+ * and %NL80211_ATTR_CENTER_FREQ2 attributes must be provided as well
|
||||
+ * @NL80211_CHAN_WIDTH_160: 160 MHz channel, the %NL80211_ATTR_CENTER_FREQ1
|
||||
+ * attribute must be provided as well
|
||||
+ */
|
||||
+enum nl80211_chan_width {
|
||||
+ NL80211_CHAN_WIDTH_20_NOHT,
|
||||
+ NL80211_CHAN_WIDTH_20,
|
||||
+ NL80211_CHAN_WIDTH_40,
|
||||
+ NL80211_CHAN_WIDTH_80,
|
||||
+ NL80211_CHAN_WIDTH_80P80,
|
||||
+ NL80211_CHAN_WIDTH_160,
|
||||
+};
|
||||
+
|
||||
+/**
|
||||
* enum nl80211_bss - netlink attributes for a BSS
|
||||
*
|
||||
* @__NL80211_BSS_INVALID: invalid
|
||||
@@ -2460,6 +2591,7 @@ enum nl80211_bss_status {
|
||||
* @NL80211_AUTHTYPE_SHARED_KEY: Shared Key authentication (WEP only)
|
||||
* @NL80211_AUTHTYPE_FT: Fast BSS Transition (IEEE 802.11r)
|
||||
* @NL80211_AUTHTYPE_NETWORK_EAP: Network EAP (some Cisco APs and mainly LEAP)
|
||||
+ * @NL80211_AUTHTYPE_SAE: Simultaneous authentication of equals
|
||||
* @__NL80211_AUTHTYPE_NUM: internal
|
||||
* @NL80211_AUTHTYPE_MAX: maximum valid auth algorithm
|
||||
* @NL80211_AUTHTYPE_AUTOMATIC: determine automatically (if necessary by
|
||||
@@ -2471,6 +2603,7 @@ enum nl80211_auth_type {
|
||||
NL80211_AUTHTYPE_SHARED_KEY,
|
||||
NL80211_AUTHTYPE_FT,
|
||||
NL80211_AUTHTYPE_NETWORK_EAP,
|
||||
+ NL80211_AUTHTYPE_SAE,
|
||||
|
||||
/* keep last */
|
||||
__NL80211_AUTHTYPE_NUM,
|
||||
@@ -2994,12 +3127,40 @@ enum nl80211_ap_sme_features {
|
||||
* @NL80211_FEATURE_CELL_BASE_REG_HINTS: This driver has been tested
|
||||
* to work properly to suppport receiving regulatory hints from
|
||||
* cellular base stations.
|
||||
+ * @NL80211_FEATURE_P2P_DEVICE_NEEDS_CHANNEL: If this is set, an active
|
||||
+ * P2P Device (%NL80211_IFTYPE_P2P_DEVICE) requires its own channel
|
||||
+ * in the interface combinations, even when it's only used for scan
|
||||
+ * and remain-on-channel. This could be due to, for example, the
|
||||
+ * remain-on-channel implementation requiring a channel context.
|
||||
+ * @NL80211_FEATURE_SAE: This driver supports simultaneous authentication of
|
||||
+ * equals (SAE) with user space SME (NL80211_CMD_AUTHENTICATE) in station
|
||||
+ * mode
|
||||
+ * @NL80211_FEATURE_LOW_PRIORITY_SCAN: This driver supports low priority scan
|
||||
+ * @NL80211_FEATURE_SCAN_FLUSH: Scan flush is supported
|
||||
+ * @NL80211_FEATURE_AP_SCAN: Support scanning using an AP vif
|
||||
+ * @NL80211_FEATURE_VIF_TXPOWER: The driver supports per-vif TX power setting
|
||||
+ * @NL80211_FEATURE_NEED_OBSS_SCAN: The driver expects userspace to perform
|
||||
+ * OBSS scans and generate 20/40 BSS coex reports. This flag is used only
|
||||
+ * for drivers implementing the CONNECT API, for AUTH/ASSOC it is implied.
|
||||
+ * @NL80211_FEATURE_P2P_GO_CTWIN: P2P GO implementation supports CT Window
|
||||
+ * setting
|
||||
+ * @NL80211_FEATURE_P2P_GO_OPPPS: P2P GO implementation supports opportunistic
|
||||
+ * powersave
|
||||
*/
|
||||
enum nl80211_feature_flags {
|
||||
- NL80211_FEATURE_SK_TX_STATUS = 1 << 0,
|
||||
- NL80211_FEATURE_HT_IBSS = 1 << 1,
|
||||
- NL80211_FEATURE_INACTIVITY_TIMER = 1 << 2,
|
||||
- NL80211_FEATURE_CELL_BASE_REG_HINTS = 1 << 3,
|
||||
+ NL80211_FEATURE_SK_TX_STATUS = 1 << 0,
|
||||
+ NL80211_FEATURE_HT_IBSS = 1 << 1,
|
||||
+ NL80211_FEATURE_INACTIVITY_TIMER = 1 << 2,
|
||||
+ NL80211_FEATURE_CELL_BASE_REG_HINTS = 1 << 3,
|
||||
+ NL80211_FEATURE_P2P_DEVICE_NEEDS_CHANNEL = 1 << 4,
|
||||
+ NL80211_FEATURE_SAE = 1 << 5,
|
||||
+ NL80211_FEATURE_LOW_PRIORITY_SCAN = 1 << 6,
|
||||
+ NL80211_FEATURE_SCAN_FLUSH = 1 << 7,
|
||||
+ NL80211_FEATURE_AP_SCAN = 1 << 8,
|
||||
+ NL80211_FEATURE_VIF_TXPOWER = 1 << 9,
|
||||
+ NL80211_FEATURE_NEED_OBSS_SCAN = 1 << 10,
|
||||
+ NL80211_FEATURE_P2P_GO_CTWIN = 1 << 11,
|
||||
+ NL80211_FEATURE_P2P_GO_OPPPS = 1 << 12,
|
||||
};
|
||||
|
||||
/**
|
||||
@@ -3023,4 +3184,36 @@ enum nl80211_probe_resp_offload_support_
|
||||
NL80211_PROBE_RESP_OFFLOAD_SUPPORT_80211U = 1<<3,
|
||||
};
|
||||
|
||||
+/**
|
||||
+ * enum nl80211_connect_failed_reason - connection request failed reasons
|
||||
+ * @NL80211_CONN_FAIL_MAX_CLIENTS: Maximum number of clients that can be
|
||||
+ * handled by the AP is reached.
|
||||
+ * @NL80211_CONN_FAIL_BLOCKED_CLIENT: Client's MAC is in the AP's blocklist.
|
||||
+ */
|
||||
+enum nl80211_connect_failed_reason {
|
||||
+ NL80211_CONN_FAIL_MAX_CLIENTS,
|
||||
+ NL80211_CONN_FAIL_BLOCKED_CLIENT,
|
||||
+};
|
||||
+
|
||||
+/**
|
||||
+ * enum nl80211_scan_flags - scan request control flags
|
||||
+ *
|
||||
+ * Scan request control flags are used to control the handling
|
||||
+ * of NL80211_CMD_TRIGGER_SCAN and NL80211_CMD_START_SCHED_SCAN
|
||||
+ * requests.
|
||||
+ *
|
||||
+ * @NL80211_SCAN_FLAG_LOW_PRIORITY: scan request has low priority
|
||||
+ * @NL80211_SCAN_FLAG_FLUSH: flush cache before scanning
|
||||
+ * @NL80211_SCAN_FLAG_AP: force a scan even if the interface is configured
|
||||
+ * as AP and the beaconing has already been configured. This attribute is
|
||||
+ * dangerous because will destroy stations performance as a lot of frames
|
||||
+ * will be lost while scanning off-channel, therefore it must be used only
|
||||
+ * when really needed
|
||||
+ */
|
||||
+enum nl80211_scan_flags {
|
||||
+ NL80211_SCAN_FLAG_LOW_PRIORITY = 1<<0,
|
||||
+ NL80211_SCAN_FLAG_FLUSH = 1<<1,
|
||||
+ NL80211_SCAN_FLAG_AP = 1<<2,
|
||||
+};
|
||||
+
|
||||
#endif /* __LINUX_NL80211_H */
|
||||
|
|
|
@ -1,55 +1,15 @@
|
|||
--- a/station.c
|
||||
+++ b/station.c
|
||||
@@ -29,13 +29,47 @@ enum plink_actions {
|
||||
PLINK_ACTION_BLOCK,
|
||||
};
|
||||
@@ -43,7 +43,7 @@ static void print_power_mode(struct nlat
|
||||
}
|
||||
}
|
||||
|
||||
+static void print_sta_bitrate(struct nlattr *nla, const char *name)
|
||||
+{
|
||||
+ struct nlattr *rinfo[NL80211_RATE_INFO_MAX + 1];
|
||||
+
|
||||
+ static struct nla_policy rate_policy[NL80211_RATE_INFO_MAX + 1] = {
|
||||
+ [NL80211_RATE_INFO_BITRATE] = { .type = NLA_U16 },
|
||||
+ [NL80211_RATE_INFO_BITRATE32] = { .type = NLA_U32 },
|
||||
+ [NL80211_RATE_INFO_MCS] = { .type = NLA_U8 },
|
||||
+ [NL80211_RATE_INFO_40_MHZ_WIDTH] = { .type = NLA_FLAG },
|
||||
+ [NL80211_RATE_INFO_SHORT_GI] = { .type = NLA_FLAG },
|
||||
+ };
|
||||
+
|
||||
+ if (!nla)
|
||||
+ return;
|
||||
+
|
||||
+ if (nla_parse_nested(rinfo, NL80211_RATE_INFO_MAX, nla, rate_policy)) {
|
||||
+ fprintf(stderr, "failed to parse nested rate attributes!\n");
|
||||
+ } else {
|
||||
+ int rate = 0;
|
||||
+ printf("\n\t%s:\t", name);
|
||||
+ if (rinfo[NL80211_RATE_INFO_BITRATE32])
|
||||
+ rate = nla_get_u32(rinfo[NL80211_RATE_INFO_BITRATE32]);
|
||||
+ else if (rinfo[NL80211_RATE_INFO_BITRATE])
|
||||
+ rate = nla_get_u16(rinfo[NL80211_RATE_INFO_BITRATE]);
|
||||
+ if (rate > 0)
|
||||
+ printf("%d.%d MBit/s", rate / 10, rate % 10);
|
||||
+
|
||||
+ if (rinfo[NL80211_RATE_INFO_MCS])
|
||||
+ printf(" MCS %d", nla_get_u8(rinfo[NL80211_RATE_INFO_MCS]));
|
||||
+ if (rinfo[NL80211_RATE_INFO_40_MHZ_WIDTH])
|
||||
+ printf(" 40Mhz");
|
||||
+ if (rinfo[NL80211_RATE_INFO_SHORT_GI])
|
||||
+ printf(" short GI");
|
||||
+ }
|
||||
+}
|
||||
|
||||
static int print_sta_handler(struct nl_msg *msg, void *arg)
|
||||
-void parse_tx_bitrate(struct nlattr *bitrate_attr, char *buf, int buflen)
|
||||
+void parse_bitrate(struct nlattr *bitrate_attr, char *buf, int buflen)
|
||||
{
|
||||
struct nlattr *tb[NL80211_ATTR_MAX + 1];
|
||||
struct genlmsghdr *gnlh = nlmsg_data(nlmsg_hdr(msg));
|
||||
struct nlattr *sinfo[NL80211_STA_INFO_MAX + 1];
|
||||
- struct nlattr *rinfo[NL80211_RATE_INFO_MAX + 1];
|
||||
char mac_addr[20], state_name[10], dev[20];
|
||||
struct nl80211_sta_flag_update *sta_flags;
|
||||
static struct nla_policy stats_policy[NL80211_STA_INFO_MAX + 1] = {
|
||||
@@ -47,6 +81,7 @@ static int print_sta_handler(struct nl_m
|
||||
int rate = 0;
|
||||
char *pos = buf;
|
||||
@@ -107,6 +107,7 @@ static int print_sta_handler(struct nl_m
|
||||
[NL80211_STA_INFO_SIGNAL] = { .type = NLA_U8 },
|
||||
[NL80211_STA_INFO_T_OFFSET] = { .type = NLA_U64 },
|
||||
[NL80211_STA_INFO_TX_BITRATE] = { .type = NLA_NESTED },
|
||||
|
@ -57,49 +17,44 @@
|
|||
[NL80211_STA_INFO_LLID] = { .type = NLA_U16 },
|
||||
[NL80211_STA_INFO_PLID] = { .type = NLA_U16 },
|
||||
[NL80211_STA_INFO_PLINK_STATE] = { .type = NLA_U8 },
|
||||
@@ -56,14 +91,6 @@ static int print_sta_handler(struct nl_m
|
||||
{ .minlen = sizeof(struct nl80211_sta_flag_update) },
|
||||
};
|
||||
@@ -177,10 +178,17 @@ static int print_sta_handler(struct nl_m
|
||||
if (sinfo[NL80211_STA_INFO_TX_BITRATE]) {
|
||||
char buf[100];
|
||||
|
||||
- static struct nla_policy rate_policy[NL80211_RATE_INFO_MAX + 1] = {
|
||||
- [NL80211_RATE_INFO_BITRATE] = { .type = NLA_U16 },
|
||||
- [NL80211_RATE_INFO_BITRATE32] = { .type = NLA_U32 },
|
||||
- [NL80211_RATE_INFO_MCS] = { .type = NLA_U8 },
|
||||
- [NL80211_RATE_INFO_40_MHZ_WIDTH] = { .type = NLA_FLAG },
|
||||
- [NL80211_RATE_INFO_SHORT_GI] = { .type = NLA_FLAG },
|
||||
- };
|
||||
-
|
||||
nla_parse(tb, NL80211_ATTR_MAX, genlmsg_attrdata(gnlh, 0),
|
||||
genlmsg_attrlen(gnlh, 0), NULL);
|
||||
|
||||
@@ -119,28 +146,8 @@ static int print_sta_handler(struct nl_m
|
||||
printf("\n\tToffset:\t%lld us",
|
||||
(unsigned long long)nla_get_u64(sinfo[NL80211_STA_INFO_T_OFFSET]));
|
||||
|
||||
- if (sinfo[NL80211_STA_INFO_TX_BITRATE]) {
|
||||
- if (nla_parse_nested(rinfo, NL80211_RATE_INFO_MAX,
|
||||
- sinfo[NL80211_STA_INFO_TX_BITRATE], rate_policy)) {
|
||||
- fprintf(stderr, "failed to parse nested rate attributes!\n");
|
||||
- } else {
|
||||
- int rate = 0;
|
||||
- printf("\n\ttx bitrate:\t");
|
||||
- if (rinfo[NL80211_RATE_INFO_BITRATE32])
|
||||
- rate = nla_get_u32(rinfo[NL80211_RATE_INFO_BITRATE32]);
|
||||
- else if (rinfo[NL80211_RATE_INFO_BITRATE])
|
||||
- rate = nla_get_u16(rinfo[NL80211_RATE_INFO_BITRATE]);
|
||||
- if (rate > 0)
|
||||
- printf("%d.%d MBit/s", rate / 10, rate % 10);
|
||||
-
|
||||
- if (rinfo[NL80211_RATE_INFO_MCS])
|
||||
- printf(" MCS %d", nla_get_u8(rinfo[NL80211_RATE_INFO_MCS]));
|
||||
- if (rinfo[NL80211_RATE_INFO_40_MHZ_WIDTH])
|
||||
- printf(" 40Mhz");
|
||||
- if (rinfo[NL80211_RATE_INFO_SHORT_GI])
|
||||
- printf(" short GI");
|
||||
- }
|
||||
- }
|
||||
+ print_sta_bitrate(sinfo[NL80211_STA_INFO_TX_BITRATE], "tx bitrate");
|
||||
+ print_sta_bitrate(sinfo[NL80211_STA_INFO_RX_BITRATE], "rx bitrate");
|
||||
- parse_tx_bitrate(sinfo[NL80211_STA_INFO_TX_BITRATE], buf, sizeof(buf));
|
||||
+ parse_bitrate(sinfo[NL80211_STA_INFO_TX_BITRATE], buf, sizeof(buf));
|
||||
printf("\n\ttx bitrate:\t%s", buf);
|
||||
}
|
||||
|
||||
+ if (sinfo[NL80211_STA_INFO_RX_BITRATE]) {
|
||||
+ char buf[100];
|
||||
+
|
||||
+ parse_bitrate(sinfo[NL80211_STA_INFO_RX_BITRATE], buf, sizeof(buf));
|
||||
+ printf("\n\trx bitrate:\t%s", buf);
|
||||
+ }
|
||||
+
|
||||
if (sinfo[NL80211_STA_INFO_LLID])
|
||||
printf("\n\tmesh llid:\t%d",
|
||||
nla_get_u16(sinfo[NL80211_STA_INFO_LLID]));
|
||||
--- a/iw.h
|
||||
+++ b/iw.h
|
||||
@@ -170,7 +170,7 @@ enum print_ie_type {
|
||||
void print_ies(unsigned char *ie, int ielen, bool unknown,
|
||||
enum print_ie_type ptype);
|
||||
|
||||
-void parse_tx_bitrate(struct nlattr *bitrate_attr, char *buf, int buflen);
|
||||
+void parse_bitrate(struct nlattr *bitrate_attr, char *buf, int buflen);
|
||||
|
||||
DECLARE_SECTION(set);
|
||||
DECLARE_SECTION(get);
|
||||
--- a/link.c
|
||||
+++ b/link.c
|
||||
@@ -165,7 +165,7 @@ static int print_link_sta(struct nl_msg
|
||||
if (sinfo[NL80211_STA_INFO_TX_BITRATE]) {
|
||||
char buf[100];
|
||||
|
||||
- parse_tx_bitrate(sinfo[NL80211_STA_INFO_TX_BITRATE], buf, sizeof(buf));
|
||||
+ parse_bitrate(sinfo[NL80211_STA_INFO_TX_BITRATE], buf, sizeof(buf));
|
||||
printf("\ttx bitrate: %s\n", buf);
|
||||
}
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- a/station.c
|
||||
+++ b/station.c
|
||||
@@ -65,6 +65,33 @@ static void print_sta_bitrate(struct nla
|
||||
}
|
||||
@@ -91,6 +91,33 @@ void parse_bitrate(struct nlattr *bitrat
|
||||
" VHT-NSS %d", nla_get_u8(rinfo[NL80211_RATE_INFO_VHT_NSS]));
|
||||
}
|
||||
|
||||
+static char *get_chain_signal(struct nlattr *attr_list)
|
||||
|
@ -34,10 +34,10 @@
|
|||
static int print_sta_handler(struct nl_msg *msg, void *arg)
|
||||
{
|
||||
struct nlattr *tb[NL80211_ATTR_MAX + 1];
|
||||
@@ -89,7 +116,10 @@ static int print_sta_handler(struct nl_m
|
||||
[NL80211_STA_INFO_TX_FAILED] = { .type = NLA_U32 },
|
||||
[NL80211_STA_INFO_STA_FLAGS] =
|
||||
{ .minlen = sizeof(struct nl80211_sta_flag_update) },
|
||||
@@ -118,7 +145,10 @@ static int print_sta_handler(struct nl_m
|
||||
[NL80211_STA_INFO_LOCAL_PM] = { .type = NLA_U32},
|
||||
[NL80211_STA_INFO_PEER_PM] = { .type = NLA_U32},
|
||||
[NL80211_STA_INFO_NONPEER_PM] = { .type = NLA_U32},
|
||||
+ [NL80211_STA_INFO_CHAIN_SIGNAL] = { .type = NLA_NESTED },
|
||||
+ [NL80211_STA_INFO_CHAIN_SIGNAL_AVG] = { .type = NLA_NESTED },
|
||||
};
|
||||
|
@ -45,7 +45,7 @@
|
|||
|
||||
nla_parse(tb, NL80211_ATTR_MAX, genlmsg_attrdata(gnlh, 0),
|
||||
genlmsg_attrlen(gnlh, 0), NULL);
|
||||
@@ -136,12 +166,19 @@ static int print_sta_handler(struct nl_m
|
||||
@@ -165,12 +195,19 @@ static int print_sta_handler(struct nl_m
|
||||
if (sinfo[NL80211_STA_INFO_TX_FAILED])
|
||||
printf("\n\ttx failed:\t%u",
|
||||
nla_get_u32(sinfo[NL80211_STA_INFO_TX_FAILED]));
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/phy.c
|
||||
+++ b/phy.c
|
||||
@@ -359,3 +359,31 @@ COMMAND(set, antenna, "<bitmap> | all |
|
||||
@@ -421,3 +421,31 @@ COMMAND(set, antenna, "<bitmap> | all |
|
||||
NL80211_CMD_SET_WIPHY, 0, CIB_PHY, handle_antenna,
|
||||
"Set a bitmap of allowed antennas to use for TX and RX.\n"
|
||||
"The driver may reject antenna configurations it cannot support.");
|
|
@ -1,11 +0,0 @@
|
|||
--- a/station.c
|
||||
+++ b/station.c
|
||||
@@ -267,7 +267,7 @@ static int print_sta_handler(struct nl_m
|
||||
}
|
||||
|
||||
if (sta_flags->mask & BIT(NL80211_STA_FLAG_TDLS_PEER)) {
|
||||
- printf("\n\tTDLS peer:\t\t");
|
||||
+ printf("\n\tTDLS peer:\t");
|
||||
if (sta_flags->set & BIT(NL80211_STA_FLAG_TDLS_PEER))
|
||||
printf("yes");
|
||||
else
|
Loading…
Reference in a new issue