kernel: update 3.10.36->3.10.44
205-fix-headers_install.patch is obseleted by upstream commit 3246a0352e3d58380b9386570f1db1faf7edf8a8 Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 41351
This commit is contained in:
parent
23a9bfc655
commit
994e5ce2f9
29 changed files with 29 additions and 73 deletions
|
@ -14,8 +14,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.9.11)
|
||||
LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.10.36)
|
||||
LINUX_KERNEL_MD5SUM:=721f76050755ec8ec88876ee350a2726
|
||||
ifeq ($(LINUX_VERSION),3.10.44)
|
||||
LINUX_KERNEL_MD5SUM:=8a4006eff3bbd8aff58fe4b443223e7a
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.12.10)
|
||||
LINUX_KERNEL_MD5SUM:=93325074b7b1d7bb76fb7d4348f0aa7a
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs atm
|
|||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
SUBTARGETS:=generic ac49x
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=mips16
|
|||
CPU_TYPE=34kc
|
||||
SUBTARGETS:=generic nand mikrotik
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
|
|||
FEATURES:=squashfs targz ext2 usb
|
||||
CPU_TYPE:=arm926ej-s
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
|
|||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
CPU_TYPE:=cortex-a9
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
|||
CPU_TYPE:=arm1176jzf-s
|
||||
CPU_SUBTYPE:=vfp
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb
|
|||
SUBTARGETS:=generic mips74k legacy
|
||||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm63xx
|
|||
BOARDNAME:=Broadcom BCM63xx
|
||||
SUBTARGETS:=generic smp
|
||||
FEATURES:=squashfs usb atm pci pcmcia usbgadget
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
|||
FEATURES:=squashfs
|
||||
CPU_TYPE:=fa526
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
From e60cc1b011bf0f1acdb7e5168b7bed4ebb78c91f Mon Sep 17 00:00:00 2001
|
||||
From: Bruce Ashfield <bruce.ashfield@windriver.com>
|
||||
Date: Wed, 9 Jan 2013 16:24:39 -0500
|
||||
Subject: [PATCH] scripts/Makefile.headersinst: install headers from scratch file
|
||||
|
||||
If headers_install is executed from a deep/long directory structure, the
|
||||
shell's maximum argument length can be execeeded, which breaks the operation
|
||||
with:
|
||||
|
||||
| make[2]: execvp: /bin/sh: Argument list too long
|
||||
| make[2]: ***
|
||||
|
||||
By dumping the input files to a scratch file and using xargs to read the
|
||||
input list from the scratch file, we can avoid blowing out the maximum
|
||||
argument size and install headers in a long path name environment.
|
||||
|
||||
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
|
||||
[jow@openwrt.org: adapt to Linux 3.10]
|
||||
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
|
||||
---
|
||||
scripts/Makefile.headersinst | 4 +++-
|
||||
1 files changed, 3 insertions(+), 1 deletions(-)
|
||||
|
||||
--- a/scripts/Makefile.headersinst
|
||||
+++ b/scripts/Makefile.headersinst
|
||||
@@ -72,7 +72,7 @@ printdir = $(patsubst $(INSTALL_HDR_PATH
|
||||
quiet_cmd_install = INSTALL $(printdir) ($(words $(all-files))\
|
||||
file$(if $(word 2, $(all-files)),s))
|
||||
cmd_install = \
|
||||
- $(CONFIG_SHELL) $< $(installdir) $(input-files); \
|
||||
+ xargs $(CONFIG_SHELL) $< $(installdir) < $(INSTALL_HDR_PATH)/.input-files; \
|
||||
for F in $(wrapper-files); do \
|
||||
echo "\#include <asm-generic/$$F>" > $(installdir)/$$F; \
|
||||
done; \
|
||||
@@ -101,7 +101,9 @@ targets += $(install-file)
|
||||
$(install-file): scripts/headers_install.sh $(input-files) FORCE
|
||||
$(if $(unwanted),$(call cmd,remove),)
|
||||
$(if $(wildcard $(dir $@)),,$(shell mkdir -p $(dir $@)))
|
||||
+ @echo $(input-files) > $(INSTALL_HDR_PATH)/.input-files
|
||||
$(call if_changed,install)
|
||||
+ @rm $(INSTALL_HDR_PATH)/.input-files
|
||||
|
||||
else
|
||||
__headerscheck: $(subdirs) $(check-file)
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
|
|||
CPU_SUBTYPE:=neon
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand nand ubifs
|
|||
CPU_TYPE:=xscale
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq
|
|||
FEATURES:=squashfs
|
||||
SUBTARGETS=xway xrx200
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
CPU_TYPE:=mips32r2
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic p1020
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
|
|||
CPU_SUBTYPE:=vfpv3
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=octeon
|
|||
CPU_CFLAGS_octeon:=-march=octeon -mabi=64
|
||||
MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CPU_TYPE:=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
|||
CPU_TYPE:=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
|
|||
SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
|
||||
FEATURES:=squashfs gpio
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += \
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=pci targz broken
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
|
|||
CPU_SUBTYPE:=vfp
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
|||
BOARDNAME:=Sun UltraSPARC
|
||||
FEATURES+=fpu tgz ext4 squashfs broken
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
|
|||
SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
|
||||
rdc
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
KERNELNAME:=bzImage
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
|||
FEATURES:=targz nand ubifs audio
|
||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||
|
||||
LINUX_VERSION:=3.10.36
|
||||
LINUX_VERSION:=3.10.44
|
||||
|
||||
DEVICE_TYPE=other
|
||||
|
||||
|
|
Loading…
Reference in a new issue