valgrind: bump to 3.13.0
Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
This commit is contained in:
parent
7d7356df64
commit
991899cc54
3 changed files with 4 additions and 49 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=valgrind
|
||||
PKG_VERSION:=3.12.0
|
||||
PKG_VERSION:=3.13.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://valgrind.org/downloads/
|
||||
PKG_HASH:=67ca4395b2527247780f36148b084f5743a68ab0c850cb43e4a5b4b012cf76a1
|
||||
PKG_SOURCE_URL:=http://sourceware.org/pub/valgrind/
|
||||
PKG_HASH:=d76680ef03f00cd5e970bbdcd4e57fb1f6df7d2e2c071635ef2be74790190c3b
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -328,7 +328,7 @@ case "${host_os}" in
|
||||
@@ -323,7 +323,7 @@ case "${host_os}" in
|
||||
# Ok, this is linux. Check the kernel version
|
||||
AC_MSG_CHECKING([for the kernel version])
|
||||
|
||||
|
|
|
@ -1,45 +0,0 @@
|
|||
--- a/coregrind/vg_preloaded.c
|
||||
+++ b/coregrind/vg_preloaded.c
|
||||
@@ -57,7 +57,7 @@
|
||||
void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run);
|
||||
void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run)
|
||||
{
|
||||
-# if !defined(__UCLIBC__) \
|
||||
+# if !defined(__UCLIBC__) && defined(__GLIBC__) \
|
||||
&& !defined(VGPV_arm_linux_android) \
|
||||
&& !defined(VGPV_x86_linux_android) \
|
||||
&& !defined(VGPV_mips32_linux_android) \
|
||||
--- a/include/pub_tool_redir.h
|
||||
+++ b/include/pub_tool_redir.h
|
||||
@@ -243,7 +243,7 @@
|
||||
/* --- Soname of the standard C library. --- */
|
||||
|
||||
#if defined(VGO_linux) || defined(VGO_solaris)
|
||||
-# define VG_Z_LIBC_SONAME libcZdsoZa // libc.so*
|
||||
+# define VG_Z_LIBC_SONAME libcZdZa // libc.*
|
||||
|
||||
#elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
|
||||
# define VG_Z_LIBC_SONAME libSystemZdZaZddylib // libSystem.*.dylib
|
||||
@@ -275,7 +275,11 @@
|
||||
/* --- Soname of the pthreads library. --- */
|
||||
|
||||
#if defined(VGO_linux)
|
||||
+# if defined(__GLIBC__) || defined(__UCLIBC__)
|
||||
# define VG_Z_LIBPTHREAD_SONAME libpthreadZdsoZd0 // libpthread.so.0
|
||||
+# else
|
||||
+# define VG_Z_LIBPTHREAD_SONAME libcZdZa // libc.*
|
||||
+# endif
|
||||
#elif defined(VGO_darwin)
|
||||
# define VG_Z_LIBPTHREAD_SONAME libSystemZdZaZddylib // libSystem.*.dylib
|
||||
#elif defined(VGO_solaris)
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1047,8 +1047,6 @@ case "${GLIBC_VERSION}" in
|
||||
;;
|
||||
2.0|2.1|*)
|
||||
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
|
||||
- AC_MSG_ERROR([Valgrind requires glibc version 2.2 or later,])
|
||||
- AC_MSG_ERROR([Darwin libc, Bionic libc or Solaris libc])
|
||||
;;
|
||||
esac
|
||||
|
Loading…
Reference in a new issue