musl: update musl to version 1.1.15
The removed patch is already integrated in upstream musl. Add one additional patch which fixes a regression on mips. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
2d3917d5b5
commit
9816d2f5f5
6 changed files with 72 additions and 3741 deletions
|
@ -3,6 +3,6 @@ if USE_MUSL
|
|||
config MUSL_VERSION
|
||||
string
|
||||
depends on USE_MUSL
|
||||
default "1.1.14"
|
||||
default "1.1.15"
|
||||
|
||||
endif
|
||||
|
|
|
@ -11,7 +11,7 @@ PKG_NAME:=musl
|
|||
PKG_VERSION:=$(call qstrip,$(CONFIG_MUSL_VERSION))
|
||||
PKG_RELEASE=1
|
||||
|
||||
PKG_MD5SUM:=d529ce4a2f7f79d8c3fd4b8329417b57
|
||||
PKG_MD5SUM:=9590a9d47ee64f220b3c12f7afb864ca
|
||||
|
||||
PKG_SOURCE_URL:=http://www.musl-libc.org/releases
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1,67 @@
|
|||
From cff5747c74c41b22f1ce1340978b1c226a8cdf32 Mon Sep 17 00:00:00 2001
|
||||
From: Rich Felker <dalias@aerifal.cx>
|
||||
Date: Wed, 13 Jul 2016 15:04:30 -0400
|
||||
Subject: [PATCH] fix regression in tcsetattr on all mips archs
|
||||
|
||||
revert commit 8c316e9e49d37ad92c2e7493e16166a2afca419f. it was wrong
|
||||
and does not match how the kernel API works.
|
||||
---
|
||||
arch/mips/bits/termios.h | 6 +++---
|
||||
arch/mips64/bits/termios.h | 6 +++---
|
||||
arch/mipsn32/bits/termios.h | 6 +++---
|
||||
4 files changed, 10 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/arch/mips/bits/termios.h b/arch/mips/bits/termios.h
|
||||
index f559f76..6a1205d 100644
|
||||
--- a/arch/mips/bits/termios.h
|
||||
+++ b/arch/mips/bits/termios.h
|
||||
@@ -141,9 +141,9 @@ struct termios {
|
||||
#define TCOFLUSH 1
|
||||
#define TCIOFLUSH 2
|
||||
|
||||
-#define TCSANOW 0x540e
|
||||
-#define TCSADRAIN 0x540f
|
||||
-#define TCSAFLUSH 0x5410
|
||||
+#define TCSANOW 0
|
||||
+#define TCSADRAIN 1
|
||||
+#define TCSAFLUSH 2
|
||||
|
||||
#if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
|
||||
#define EXTA 0000016
|
||||
diff --git a/arch/mips64/bits/termios.h b/arch/mips64/bits/termios.h
|
||||
index f559f76..6a1205d 100644
|
||||
--- a/arch/mips64/bits/termios.h
|
||||
+++ b/arch/mips64/bits/termios.h
|
||||
@@ -141,9 +141,9 @@ struct termios {
|
||||
#define TCOFLUSH 1
|
||||
#define TCIOFLUSH 2
|
||||
|
||||
-#define TCSANOW 0x540e
|
||||
-#define TCSADRAIN 0x540f
|
||||
-#define TCSAFLUSH 0x5410
|
||||
+#define TCSANOW 0
|
||||
+#define TCSADRAIN 1
|
||||
+#define TCSAFLUSH 2
|
||||
|
||||
#if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
|
||||
#define EXTA 0000016
|
||||
diff --git a/arch/mipsn32/bits/termios.h b/arch/mipsn32/bits/termios.h
|
||||
index f559f76..6a1205d 100644
|
||||
--- a/arch/mipsn32/bits/termios.h
|
||||
+++ b/arch/mipsn32/bits/termios.h
|
||||
@@ -141,9 +141,9 @@ struct termios {
|
||||
#define TCOFLUSH 1
|
||||
#define TCIOFLUSH 2
|
||||
|
||||
-#define TCSANOW 0x540e
|
||||
-#define TCSADRAIN 0x540f
|
||||
-#define TCSAFLUSH 0x5410
|
||||
+#define TCSANOW 0
|
||||
+#define TCSADRAIN 1
|
||||
+#define TCSAFLUSH 2
|
||||
|
||||
#if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
|
||||
#define EXTA 0000016
|
||||
--
|
||||
2.8.1
|
||||
|
|
@ -21,7 +21,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||
ALL_TOOLS = obj/musl-gcc
|
||||
|
||||
WRAPCC_GCC = gcc
|
||||
@@ -125,7 +125,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
|
||||
@@ -129,7 +129,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
|
||||
src/thread/__set_thread_area.c src/thread/$(ARCH)/__set_thread_area.c \
|
||||
src/string/memset.c src/string/$(ARCH)/memset.c \
|
||||
src/string/memcpy.c src/string/$(ARCH)/memcpy.c \
|
||||
|
@ -31,7 +31,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||
$(NOSSP_SRCS:%.c=obj/%.o) $(NOSSP_SRCS:%.c=obj/%.lo): CFLAGS_ALL += $(CFLAGS_NOSSP)
|
||||
|
||||
$(CRT_OBJS): CFLAGS_ALL += -DCRT
|
||||
@@ -168,6 +169,11 @@ lib/libc.a: $(AOBJS)
|
||||
@@ -172,6 +173,11 @@ lib/libc.a: $(AOBJS)
|
||||
$(AR) rc $@ $(AOBJS)
|
||||
$(RANLIB) $@
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -217,7 +217,7 @@ $(DESTDIR)$(includedir)/%: $(srcdir)/inc
|
||||
@@ -215,7 +215,7 @@ $(DESTDIR)$(includedir)/%: $(srcdir)/inc
|
||||
$(INSTALL) -D -m 644 $< $@
|
||||
|
||||
$(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so
|
||||
|
|
Loading…
Reference in a new issue