kernel: update linux 3.2 to 3.2.9
SVN-Revision: 30767
This commit is contained in:
parent
b12229935d
commit
9698a499b6
16 changed files with 20 additions and 114 deletions
|
@ -35,8 +35,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.1.10)
|
||||
LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.2.5)
|
||||
LINUX_KERNEL_MD5SUM:=17c180eaa524101ca1c675bd675eca37
|
||||
ifeq ($(LINUX_VERSION),3.2.9)
|
||||
LINUX_KERNEL_MD5SUM:=f6c2ede7c6df0f62c8fbf7932ccf63b6
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
|
|||
SUBTARGETS=au1500 au1550
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
|||
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||
FEATURES:=squashfs usb pcmcia
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||
|
|
|
@ -2071,7 +2071,7 @@
|
|||
/**
|
||||
--- a/drivers/pci/probe.c
|
||||
+++ b/drivers/pci/probe.c
|
||||
@@ -1522,12 +1522,14 @@ unsigned int __devinit pci_scan_child_bu
|
||||
@@ -1527,12 +1527,14 @@ unsigned int __devinit pci_scan_child_bu
|
||||
return max;
|
||||
}
|
||||
|
||||
|
@ -2089,7 +2089,7 @@
|
|||
|
||||
b = pci_alloc_bus();
|
||||
if (!b)
|
||||
@@ -1577,8 +1579,20 @@ struct pci_bus * pci_create_bus(struct d
|
||||
@@ -1582,8 +1584,20 @@ struct pci_bus * pci_create_bus(struct d
|
||||
pci_create_legacy_files(b);
|
||||
|
||||
b->number = b->secondary = bus;
|
||||
|
@ -2112,7 +2112,7 @@
|
|||
|
||||
return b;
|
||||
|
||||
@@ -1594,18 +1608,58 @@ err_out:
|
||||
@@ -1599,18 +1613,58 @@ err_out:
|
||||
return NULL;
|
||||
}
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
|
|||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -1726,6 +1726,7 @@ CONFIG_NET_VENDOR_STMICRO=y
|
|||
CONFIG_NET_VENDOR_SUN=y
|
||||
CONFIG_NET_VENDOR_TEHUTI=y
|
||||
CONFIG_NET_VENDOR_TI=y
|
||||
CONFIG_NET_VENDOR_TOSHIBA=y
|
||||
CONFIG_NET_VENDOR_VIA=y
|
||||
CONFIG_NET_VENDOR_XIRCOM=y
|
||||
CONFIG_NEW_LEDS=y
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
From df754e6af2f237a6c020c0daff55a1a609338e31 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Zijlstra <a.p.zijlstra@chello.nl>
|
||||
Date: Mon, 14 Nov 2011 13:13:49 +0100
|
||||
Subject: [PATCH 1/2] lockdep, bug: Exclude TAINT_FIRMWARE_WORKAROUND from disabling lockdep
|
||||
|
||||
It's unlikely that TAINT_FIRMWARE_WORKAROUND causes false
|
||||
lockdep messages, so do not disable lockdep in that case.
|
||||
We still want to keep lockdep disabled in the
|
||||
TAINT_OOT_MODULE case:
|
||||
|
||||
- bin-only modules can cause various instabilities in
|
||||
their and in unrelated kernel code
|
||||
|
||||
- they are impossible to debug for kernel developers
|
||||
|
||||
- they also typically do not have the copyright license
|
||||
permission to link to the GPL-ed lockdep code.
|
||||
|
||||
Suggested-by: Ben Hutchings <ben@decadent.org.uk>
|
||||
Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
|
||||
Link: http://lkml.kernel.org/n/tip-xopopjjens57r0i13qnyh2yo@git.kernel.org
|
||||
Signed-off-by: Ingo Molnar <mingo@elte.hu>
|
||||
---
|
||||
kernel/panic.c | 12 ++++++++++--
|
||||
1 files changed, 10 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/kernel/panic.c
|
||||
+++ b/kernel/panic.c
|
||||
@@ -240,8 +240,16 @@ void add_taint(unsigned flag)
|
||||
* Also we want to keep up lockdep for staging development and
|
||||
* post-warning case.
|
||||
*/
|
||||
- if (flag != TAINT_CRAP && flag != TAINT_WARN && __debug_locks_off())
|
||||
- printk(KERN_WARNING "Disabling lock debugging due to kernel taint\n");
|
||||
+ switch (flag) {
|
||||
+ case TAINT_CRAP:
|
||||
+ case TAINT_WARN:
|
||||
+ case TAINT_FIRMWARE_WORKAROUND:
|
||||
+ break;
|
||||
+
|
||||
+ default:
|
||||
+ if (__debug_locks_off())
|
||||
+ printk(KERN_WARNING "Disabling lock debugging due to kernel taint\n");
|
||||
+ }
|
||||
|
||||
set_bit(flag, &tainted_mask);
|
||||
}
|
|
@ -1,48 +0,0 @@
|
|||
From 9ec84acee1e221d99dc33237bff5e82839d10cc0 Mon Sep 17 00:00:00 2001
|
||||
From: Ben Hutchings <ben@decadent.org.uk>
|
||||
Date: Wed, 7 Dec 2011 14:30:58 +0000
|
||||
Subject: [PATCH 2/2] lockdep, bug: Exclude TAINT_OOT_MODULE from disabling lock debugging
|
||||
|
||||
We do want to allow lock debugging for GPL-compatible modules
|
||||
that are not (yet) built in-tree. This was disabled as a
|
||||
side-effect of commit 2449b8ba0745327c5fa49a8d9acffe03b2eded69
|
||||
('module,bug: Add TAINT_OOT_MODULE flag for modules not built
|
||||
in-tree'). Lock debug warnings now include taint flags, so
|
||||
kernel developers should still be able to deflect warnings
|
||||
caused by out-of-tree modules.
|
||||
|
||||
The TAINT_PROPRIETARY_MODULE flag for non-GPL-compatible modules
|
||||
will still disable lock debugging.
|
||||
|
||||
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
|
||||
Cc: Nick Bowler <nbowler@elliptictech.com>
|
||||
Cc: Greg KH <greg@kroah.com>
|
||||
Cc: Dave Jones <davej@redhat.com>
|
||||
Cc: Rusty Russell <rusty@rustcorp.com.au>
|
||||
Cc: Randy Dunlap <rdunlap@xenotime.net>
|
||||
Cc: Debian kernel maintainers <debian-kernel@lists.debian.org>
|
||||
Cc: Peter Zijlstra <peterz@infradead.org>
|
||||
Cc: Alan Cox <alan@linux.intel.com>
|
||||
Link: http://lkml.kernel.org/r/1323268258.18450.11.camel@deadeye
|
||||
Signed-off-by: Ingo Molnar <mingo@elte.hu>
|
||||
---
|
||||
kernel/panic.c | 5 +++--
|
||||
1 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/kernel/panic.c
|
||||
+++ b/kernel/panic.c
|
||||
@@ -237,11 +237,12 @@ void add_taint(unsigned flag)
|
||||
* Can't trust the integrity of the kernel anymore.
|
||||
* We don't call directly debug_locks_off() because the issue
|
||||
* is not necessarily serious enough to set oops_in_progress to 1
|
||||
- * Also we want to keep up lockdep for staging development and
|
||||
- * post-warning case.
|
||||
+ * Also we want to keep up lockdep for staging/out-of-tree
|
||||
+ * development and post-warning case.
|
||||
*/
|
||||
switch (flag) {
|
||||
case TAINT_CRAP:
|
||||
+ case TAINT_OOT_MODULE:
|
||||
case TAINT_WARN:
|
||||
case TAINT_FIRMWARE_WORKAROUND:
|
||||
break;
|
|
@ -3134,7 +3134,7 @@
|
|||
/**
|
||||
* enum positive_aop_returns - aop return codes with specific semantics
|
||||
*
|
||||
@@ -1481,6 +1487,11 @@ struct super_block {
|
||||
@@ -1482,6 +1488,11 @@ struct super_block {
|
||||
int cleancache_poolid;
|
||||
|
||||
struct shrinker s_shrink; /* per-sb shrinker handle */
|
||||
|
@ -3146,7 +3146,7 @@
|
|||
};
|
||||
|
||||
/* superblock cache pruning functions */
|
||||
@@ -1638,6 +1649,7 @@ struct inode_operations {
|
||||
@@ -1639,6 +1650,7 @@ struct inode_operations {
|
||||
void (*truncate_range)(struct inode *, loff_t, loff_t);
|
||||
int (*fiemap)(struct inode *, struct fiemap_extent_info *, u64 start,
|
||||
u64 len);
|
||||
|
@ -3154,7 +3154,7 @@
|
|||
} ____cacheline_aligned;
|
||||
|
||||
struct seq_file;
|
||||
@@ -2058,6 +2070,7 @@ extern long do_sys_open(int dfd, const c
|
||||
@@ -2059,6 +2071,7 @@ extern long do_sys_open(int dfd, const c
|
||||
extern struct file *filp_open(const char *, int, int);
|
||||
extern struct file *file_open_root(struct dentry *, struct vfsmount *,
|
||||
const char *, int);
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -374,7 +374,7 @@
|
||||
@@ -374,7 +374,7 @@ KBUILD_CFLAGS_KERNEL :=
|
||||
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||
|
|
|
@ -10,8 +10,8 @@
|
|||
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
||||
{
|
||||
u16 cmd;
|
||||
@@ -877,3 +879,5 @@ static void __devinit quirk_usb_early_ha
|
||||
quirk_usb_handoff_xhci(pdev);
|
||||
@@ -894,3 +896,5 @@ static void __devinit quirk_usb_early_ha
|
||||
pci_disable_device(pdev);
|
||||
}
|
||||
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
||||
+
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=omap4
|
|||
BOARDNAME:=TI OMAP4
|
||||
FEATURES:=usb targz audio display
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.2.5
|
||||
LINUX_VERSION:=3.2.9
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
Loading…
Reference in a new issue