tools/pkg-config: Update to 0.29.2
* Update pkg-config to 0.29.2 * Remove patch as it's upstreamed Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
1a5b7cc151
commit
965df21fd1
2 changed files with 2 additions and 20 deletions
|
@ -7,11 +7,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pkg-config
|
PKG_NAME:=pkg-config
|
||||||
PKG_VERSION:=0.29.1
|
PKG_VERSION:=0.29.2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://pkgconfig.freedesktop.org/releases/
|
PKG_SOURCE_URL:=https://pkgconfig.freedesktop.org/releases/
|
||||||
PKG_HASH:=beb43c9e064555469bd4390dcfd8030b1536e0aa103f08d7abf7ae8cac0cb001
|
PKG_HASH:=6fc69c01688c9458a57eb9a1664c9aba372ccda420a02bf4429fe610e7e7d591
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- a/glib/glib/gdate.c
|
|
||||||
+++ b/glib/glib/gdate.c
|
|
||||||
@@ -2439,6 +2439,9 @@ win32_strftime_helper (const GDate *d,
|
|
||||||
*
|
|
||||||
* Returns: number of characters written to the buffer, or 0 the buffer was too small
|
|
||||||
*/
|
|
||||||
+#pragma GCC diagnostic push
|
|
||||||
+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
|
|
||||||
+
|
|
||||||
gsize
|
|
||||||
g_date_strftime (gchar *s,
|
|
||||||
gsize slen,
|
|
||||||
@@ -2549,3 +2552,5 @@ g_date_strftime (gchar *s,
|
|
||||||
return retval;
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+#pragma GCC diagnostic pop
|
|
Loading…
Reference in a new issue