mac80211: fix reversed WARN_ON() condition which causes a stray stacktrace on boot
SVN-Revision: 29284
This commit is contained in:
parent
9990523a0f
commit
95f0a41bf5
2 changed files with 13 additions and 0 deletions
|
@ -40,6 +40,8 @@ PKG_CONFIG_DEPENDS:= \
|
||||||
|
|
||||||
CARL9170_FW_VERSION:=1.9.4
|
CARL9170_FW_VERSION:=1.9.4
|
||||||
|
|
||||||
|
#QUILT_PATCH_DIR:=patches-openwrt
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
WMENU:=Wireless Drivers
|
WMENU:=Wireless Drivers
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/compat/compat-2.6.36.c
|
||||||
|
+++ b/compat/compat-2.6.36.c
|
||||||
|
@@ -101,7 +101,7 @@ EXPORT_SYMBOL_GPL(system_nrt_wq);
|
||||||
|
void compat_system_workqueue_create()
|
||||||
|
{
|
||||||
|
system_nrt_wq = create_singlethread_workqueue("events_nrt");
|
||||||
|
- WARN_ON(system_nrt_wq);
|
||||||
|
+ WARN_ON(!system_nrt_wq);
|
||||||
|
}
|
||||||
|
|
||||||
|
void compat_system_workqueue_destroy()
|
Loading…
Reference in a new issue