toolchain/binutils: Add binutils 2.27
Add binutils 2.27 to toolchain Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net> Signed-off-by: Felix Fietkau <nbd@nbd.name> [refresh patches]
This commit is contained in:
parent
1341b88732
commit
95a2e2c8fe
7 changed files with 110 additions and 0 deletions
|
@ -22,6 +22,11 @@ choice
|
||||||
bool "Binutils 2.26.1"
|
bool "Binutils 2.26.1"
|
||||||
select BINUTILS_VERSION_2_26_1
|
select BINUTILS_VERSION_2_26_1
|
||||||
|
|
||||||
|
config BINUTILS_USE_VERSION_2_27
|
||||||
|
depends on !arc
|
||||||
|
bool "Binutils 2.27"
|
||||||
|
select BINUTILS_VERSION_2_27
|
||||||
|
|
||||||
config BINUTILS_USE_VERSION_2_26_ARC
|
config BINUTILS_USE_VERSION_2_26_ARC
|
||||||
depends on arc
|
depends on arc
|
||||||
bool "ARC binutils 2.26"
|
bool "ARC binutils 2.26"
|
||||||
|
|
|
@ -8,6 +8,9 @@ config BINUTILS_VERSION_2_25_1
|
||||||
config BINUTILS_VERSION_2_26_1
|
config BINUTILS_VERSION_2_26_1
|
||||||
bool
|
bool
|
||||||
|
|
||||||
|
config BINUTILS_VERSION_2_27
|
||||||
|
bool
|
||||||
|
|
||||||
config BINUTILS_VERSION_2_26_ARC
|
config BINUTILS_VERSION_2_26_ARC
|
||||||
default y if (!TOOLCHAINOPTS && arc)
|
default y if (!TOOLCHAINOPTS && arc)
|
||||||
bool
|
bool
|
||||||
|
@ -17,5 +20,6 @@ config BINUTILS_VERSION
|
||||||
default "2.24-linaro" if BINUTILS_VERSION_2_24_LINARO
|
default "2.24-linaro" if BINUTILS_VERSION_2_24_LINARO
|
||||||
default "2.25.1" if BINUTILS_VERSION_2_25_1
|
default "2.25.1" if BINUTILS_VERSION_2_25_1
|
||||||
default "2.26.1" if BINUTILS_VERSION_2_26_1
|
default "2.26.1" if BINUTILS_VERSION_2_26_1
|
||||||
|
default "2.27" if BINUTILS_VERSION_2_27
|
||||||
default "arc-2016.03" if BINUTILS_VERSION_2_26_ARC
|
default "arc-2016.03" if BINUTILS_VERSION_2_26_ARC
|
||||||
|
|
||||||
|
|
|
@ -21,6 +21,10 @@ ifeq ($(PKG_VERSION),2.26.1)
|
||||||
PKG_MD5SUM:=d2b24e5b5301b7ff0207414c34c3e0fb
|
PKG_MD5SUM:=d2b24e5b5301b7ff0207414c34c3e0fb
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
ifeq ($(PKG_VERSION),2.27)
|
||||||
|
PKG_MD5SUM:=2869c9bf3e60ee97c74ac2a6bf4e9d68
|
||||||
|
endif
|
||||||
|
|
||||||
ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
|
ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
|
||||||
PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
|
PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
|
||||||
PKG_REV:=2.24.0-2014.09
|
PKG_REV:=2.24.0-2014.09
|
||||||
|
|
|
@ -0,0 +1,22 @@
|
||||||
|
--- a/ld/Makefile.am
|
||||||
|
+++ b/ld/Makefile.am
|
||||||
|
@@ -57,7 +57,7 @@ endif
|
||||||
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||||
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||||
|
# directives need to be different for native and cross linkers.
|
||||||
|
-scriptdir = $(tooldir)/lib
|
||||||
|
+scriptdir = $(libdir)
|
||||||
|
|
||||||
|
EMUL = @EMUL@
|
||||||
|
EMULATION_OFILES = @EMULATION_OFILES@
|
||||||
|
--- a/ld/Makefile.in
|
||||||
|
+++ b/ld/Makefile.in
|
||||||
|
@@ -451,7 +451,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
|
||||||
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||||
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||||
|
# directives need to be different for native and cross linkers.
|
||||||
|
-scriptdir = $(tooldir)/lib
|
||||||
|
+scriptdir = $(libdir)
|
||||||
|
BASEDIR = $(srcdir)/..
|
||||||
|
BFDDIR = $(BASEDIR)/bfd
|
||||||
|
INCDIR = $(BASEDIR)/include
|
|
@ -0,0 +1,20 @@
|
||||||
|
--- a/ld/emultempl/elf32.em
|
||||||
|
+++ b/ld/emultempl/elf32.em
|
||||||
|
@@ -1244,6 +1244,8 @@ fragment <<EOF
|
||||||
|
&& command_line.rpath == NULL)
|
||||||
|
{
|
||||||
|
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
||||||
|
+ if ((lib_path) && (strlen (lib_path) == 0))
|
||||||
|
+ lib_path = NULL;
|
||||||
|
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
||||||
|
force))
|
||||||
|
break;
|
||||||
|
@@ -1525,6 +1527,8 @@ gld${EMULATION_NAME}_before_allocation (
|
||||||
|
rpath = command_line.rpath;
|
||||||
|
if (rpath == NULL)
|
||||||
|
rpath = (const char *) getenv ("LD_RUN_PATH");
|
||||||
|
+ if ((rpath) && (strlen (rpath) == 0))
|
||||||
|
+ rpath = NULL;
|
||||||
|
|
||||||
|
for (abfd = link_info.input_bfds; abfd; abfd = abfd->link.next)
|
||||||
|
if (bfd_get_flavour (abfd) == bfd_target_elf_flavour)
|
|
@ -0,0 +1,18 @@
|
||||||
|
--- a/bfd/elfxx-mips.c
|
||||||
|
+++ b/bfd/elfxx-mips.c
|
||||||
|
@@ -7713,6 +7713,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
||||||
|
|
||||||
|
name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
|
||||||
|
bh = NULL;
|
||||||
|
+ if (0) {
|
||||||
|
if (!(_bfd_generic_link_add_one_symbol
|
||||||
|
(info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
|
||||||
|
NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
|
||||||
|
@@ -7725,6 +7726,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
||||||
|
|
||||||
|
if (! bfd_elf_link_record_dynamic_symbol (info, h))
|
||||||
|
return FALSE;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
if (! mips_elf_hash_table (info)->use_rld_obj_head)
|
||||||
|
{
|
|
@ -0,0 +1,37 @@
|
||||||
|
--- a/bfd/config.bfd
|
||||||
|
+++ b/bfd/config.bfd
|
||||||
|
@@ -1101,12 +1101,12 @@ case "${targ}" in
|
||||||
|
targ_selvecs="mips_elf32_le_vec mips_elf64_be_vec mips_elf64_le_vec mips_ecoff_be_vec mips_ecoff_le_vec"
|
||||||
|
;;
|
||||||
|
mips64*el-*-linux*)
|
||||||
|
- targ_defvec=mips_elf32_ntrad_le_vec
|
||||||
|
- targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
|
||||||
|
+ targ_defvec=mips_elf64_trad_le_vec
|
||||||
|
+ targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
|
||||||
|
;;
|
||||||
|
mips64*-*-linux*)
|
||||||
|
- targ_defvec=mips_elf32_ntrad_be_vec
|
||||||
|
- targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
|
||||||
|
+ targ_defvec=mips_elf64_trad_be_vec
|
||||||
|
+ targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
|
||||||
|
;;
|
||||||
|
mips*el-*-linux*)
|
||||||
|
targ_defvec=mips_elf32_trad_le_vec
|
||||||
|
--- a/ld/configure.tgt
|
||||||
|
+++ b/ld/configure.tgt
|
||||||
|
@@ -513,11 +513,11 @@ mips*el-*-vxworks*) targ_emul=elf32elmip
|
||||||
|
mips*-*-vxworks*) targ_emul=elf32ebmipvxworks
|
||||||
|
targ_extra_emuls="elf32elmipvxworks" ;;
|
||||||
|
mips*-*-windiss) targ_emul=elf32mipswindiss ;;
|
||||||
|
-mips64*el-*-linux-*) targ_emul=elf32ltsmipn32
|
||||||
|
- targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
|
||||||
|
+mips64*el-*-linux-*) targ_emul=elf64ltsmip
|
||||||
|
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls ;;
|
||||||
|
-mips64*-*-linux-*) targ_emul=elf32btsmipn32
|
||||||
|
- targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
|
||||||
|
+mips64*-*-linux-*) targ_emul=elf64btsmip
|
||||||
|
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls ;;
|
||||||
|
mips*el-*-linux-*) targ_emul=elf32ltsmip
|
||||||
|
targ_extra_emuls="elf32btsmip elf32ltsmipn32 elf64ltsmip elf32btsmipn32 elf64btsmip"
|
Loading…
Reference in a new issue