brcm63xx: add DT support for CPVA642
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43570
This commit is contained in:
parent
712f6ec52a
commit
929ade0648
7 changed files with 66 additions and 5 deletions
30
target/linux/brcm63xx/dts/cpva642.dts
Normal file
30
target/linux/brcm63xx/dts/cpva642.dts
Normal file
|
@ -0,0 +1,30 @@
|
|||
/dts-v1/;
|
||||
|
||||
/include/ "bcm6358.dtsi"
|
||||
|
||||
/ {
|
||||
model = "Telsey CPVA642-type (CPA-ZNTE60T)";
|
||||
compatible = "telsey,cpva642", "brcm,bcm6358";
|
||||
};
|
||||
|
||||
&pflash {
|
||||
status = "ok";
|
||||
|
||||
linux,part-probe = "bcm63xxpart";
|
||||
|
||||
cfe@0 {
|
||||
label = "CFE";
|
||||
reg = <0x000000 0x010000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
linux@10000 {
|
||||
label = "linux";
|
||||
reg = <0x010000 0x7e0000>;
|
||||
};
|
||||
|
||||
nvram@7f0000 {
|
||||
label = "nvram";
|
||||
reg = <0x7f0000 0x010000>;
|
||||
};
|
||||
};
|
|
@ -215,9 +215,6 @@ define Image/Build
|
|||
# Inventel Livebox
|
||||
$(call Image/Build/RedBoot,livebox)
|
||||
|
||||
# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
|
||||
$(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
|
||||
|
||||
# Netgear CVG834G
|
||||
$(call Image/Build/HCS,$(1),cvg834g,a020,0001,0022,$(KDIR)/vmlinux)
|
||||
|
||||
|
@ -330,6 +327,8 @@ $(eval $(call ImageDTB,CFEDTB,SPW500V,spw500v,96348GW,6348,SPW500V))
|
|||
$(eval $(call ImageDTB,CFEDTB,GW6000,gw6000,96348GW,6348,GW6000))
|
||||
# Tecom GW6200
|
||||
$(eval $(call ImageDTB,CFEDTB,GW6200,gw6200,96348GW,6348,GW6200,--rsa-signature "$(shell printf '\x99')"))
|
||||
# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
|
||||
$(eval $(call ImageDTB,CFEDTB,CPVA642,cpva642,CPVA642,6358,CPA-ZNTE60T,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0" --pad 4))
|
||||
# SFR Neufbox 4
|
||||
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-ser-r0,96358VW,6358,NEUFBOX4-SER,--rsa-signature "OpenWRT-$(REVISION)"))
|
||||
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-fxc-r1,96358VW,6358,NEUFBOX4-FXC,--rsa-signature "OpenWRT-$(REVISION)"))
|
||||
|
|
|
@ -107,3 +107,11 @@
|
|||
&board_DWVS0,
|
||||
&board_nb4_ser_r0,
|
||||
&board_nb4_fxc_r1,
|
||||
@@ -1132,6 +1225,7 @@ static struct of_device_id const bcm963x
|
||||
{ .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
|
||||
{ .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
|
||||
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
|
||||
+ { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
|
||||
#endif
|
||||
#ifdef CONFIG_BCM63XX_CPU_6368
|
||||
#endif
|
||||
|
|
|
@ -86,6 +86,6 @@
|
|||
{ .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
|
||||
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
|
||||
+ { .compatible = "t-com,spw303v", .data = &board_spw303v, },
|
||||
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
|
||||
#endif
|
||||
#ifdef CONFIG_BCM63XX_CPU_6368
|
||||
#endif
|
||||
|
|
|
@ -107,3 +107,11 @@
|
|||
&board_DWVS0,
|
||||
&board_nb4_ser_r0,
|
||||
&board_nb4_fxc_r1,
|
||||
@@ -1132,6 +1225,7 @@ static struct of_device_id const bcm963x
|
||||
{ .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
|
||||
{ .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
|
||||
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
|
||||
+ { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
|
||||
#endif
|
||||
#ifdef CONFIG_BCM63XX_CPU_6368
|
||||
#endif
|
||||
|
|
|
@ -86,6 +86,6 @@
|
|||
{ .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
|
||||
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
|
||||
+ { .compatible = "t-com,spw303v", .data = &board_spw303v, },
|
||||
{ .compatible = "telsey,cpva642", .data = &board_CPVA642, },
|
||||
#endif
|
||||
#ifdef CONFIG_BCM63XX_CPU_6368
|
||||
#endif
|
||||
|
|
16
target/linux/brcm63xx/profiles/telsey.mk
Normal file
16
target/linux/brcm63xx/profiles/telsey.mk
Normal file
|
@ -0,0 +1,16 @@
|
|||
#
|
||||
# Copyright (C) 2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
define Profile/CPVA642
|
||||
NAME:=Telsey CPVA642-type (CPA-ZNTE60T)
|
||||
PACKAGES:=kmod-rt61-pci wpad-mini\
|
||||
kmod-usb2 kmod-usb-ohci
|
||||
endef
|
||||
define Profile/CPVA642/Description
|
||||
Package set optimized for CPVA642-type.
|
||||
endef
|
||||
$(eval $(call Profile,CPVA642))
|
Loading…
Reference in a new issue