mac80211: update to 2009-11-03
SVN-Revision: 18294
This commit is contained in:
parent
875d957512
commit
91c0fbb06c
10 changed files with 6 additions and 5577 deletions
|
@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=mac80211
|
||||
|
||||
PKG_VERSION:=2009-10-09
|
||||
PKG_VERSION:=2009-11-03
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_URL:= \
|
||||
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/10 \
|
||||
http://wireless.kernel.org/download/compat-wireless-2.6
|
||||
PKG_MD5SUM:=15c310560765cbc35ed930fb0e815284
|
||||
PKG_MD5SUM:=f8434790c9552abb9c98926d7ae616fe
|
||||
|
||||
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
From 9b1ce526eb917c8b5c8497c327768130ee683392 Mon Sep 17 00:00:00 2001
|
||||
From: =?utf8?q?Bj=C3=B6rn=20Smedman?= <bjorn.smedman@venatech.se>
|
||||
Date: Sat, 24 Oct 2009 20:55:09 +0200
|
||||
Subject: [PATCH] mac80211: fix for incorrect sequence number on hostapd injected frames
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=utf8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
When hostapd injects a frame, e.g. an authentication or association
|
||||
response, mac80211 looks for a suitable access point virtual interface
|
||||
to associate the frame with based on its source address. This makes it
|
||||
possible e.g. to correctly assign sequence numbers to the frames.
|
||||
|
||||
A small typo in the ethernet address comparison statement caused a
|
||||
failure to find a suitable ap interface. Sequence numbers on such
|
||||
frames where therefore left unassigned causing some clients
|
||||
(especially windows-based 11b/g clients) to reject them and fail to
|
||||
authenticate or associate with the access point. This patch fixes the
|
||||
typo in the address comparison statement.
|
||||
|
||||
Signed-off-by: Björn Smedman <bjorn.smedman@venatech.se>
|
||||
Reviewed-by: Johannes Berg <johannes@sipsolutions.net>
|
||||
Cc: stable@kernel.org
|
||||
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
||||
---
|
||||
net/mac80211/tx.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c
|
||||
index db4bda6..eaa4118 100644
|
||||
--- a/net/mac80211/tx.c
|
||||
+++ b/net/mac80211/tx.c
|
||||
@@ -1445,7 +1445,7 @@ static void ieee80211_xmit(struct ieee80211_sub_if_data *sdata,
|
||||
if (tmp_sdata->vif.type != NL80211_IFTYPE_AP)
|
||||
continue;
|
||||
if (compare_ether_addr(tmp_sdata->dev->dev_addr,
|
||||
- hdr->addr2)) {
|
||||
+ hdr->addr2) == 0) {
|
||||
dev_hold(tmp_sdata->dev);
|
||||
dev_put(sdata->dev);
|
||||
sdata = tmp_sdata;
|
||||
--
|
||||
1.6.5.1
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/wireless/ath/ath5k/reset.c
|
||||
+++ b/drivers/net/wireless/ath/ath5k/reset.c
|
||||
@@ -1372,10 +1372,18 @@ int ath5k_hw_reset(struct ath5k_hw *ah,
|
||||
@@ -1357,10 +1357,18 @@ int ath5k_hw_reset(struct ath5k_hw *ah,
|
||||
* guess we can tweak it and see how it goes ;-)
|
||||
*/
|
||||
if (ah->ah_version != AR5K_AR5210) {
|
||||
|
|
|
@ -1,249 +0,0 @@
|
|||
From 671e062837669b6d4a5e75d7d08ff485a7510e80 Mon Sep 17 00:00:00 2001
|
||||
From: Ivo van Doorn <IvDoorn@gmail.com>
|
||||
Date: Sat, 8 Aug 2009 23:42:51 +0200
|
||||
Subject: [PATCH 1/3] rt2x00: Add rt2x00soc bus module
|
||||
|
||||
Add new library module for SoC drivers.
|
||||
This is needed to fully support the platform
|
||||
driver part of rt2800pci.
|
||||
|
||||
Based on original patch from Felix.
|
||||
|
||||
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||
Signed-off-by: Ivo van Doorn <IvDoorn@gmail.com>
|
||||
---
|
||||
drivers/net/wireless/rt2x00/Kconfig | 4 +
|
||||
drivers/net/wireless/rt2x00/Makefile | 1 +
|
||||
drivers/net/wireless/rt2x00/rt2x00soc.c | 159 +++++++++++++++++++++++++++++++
|
||||
drivers/net/wireless/rt2x00/rt2x00soc.h | 52 ++++++++++
|
||||
4 files changed, 216 insertions(+), 0 deletions(-)
|
||||
create mode 100644 drivers/net/wireless/rt2x00/rt2x00soc.c
|
||||
create mode 100644 drivers/net/wireless/rt2x00/rt2x00soc.h
|
||||
|
||||
--- a/drivers/net/wireless/rt2x00/Makefile
|
||||
+++ b/drivers/net/wireless/rt2x00/Makefile
|
||||
@@ -11,6 +11,7 @@ rt2x00lib-$(CONFIG_RT2X00_LIB_HT) += rt2
|
||||
|
||||
obj-$(CONFIG_RT2X00_LIB) += rt2x00lib.o
|
||||
obj-$(CONFIG_RT2X00_LIB_PCI) += rt2x00pci.o
|
||||
+obj-$(CONFIG_RT2X00_LIB_SOC) += rt2x00soc.o
|
||||
obj-$(CONFIG_RT2X00_LIB_USB) += rt2x00usb.o
|
||||
obj-$(CONFIG_RT2400PCI) += rt2400pci.o
|
||||
obj-$(CONFIG_RT2500PCI) += rt2500pci.o
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2x00soc.c
|
||||
@@ -0,0 +1,159 @@
|
||||
+/*
|
||||
+ Copyright (C) 2004 - 2009 rt2x00 SourceForge Project
|
||||
+ <http://rt2x00.serialmonkey.com>
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 2 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the
|
||||
+ Free Software Foundation, Inc.,
|
||||
+ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+ */
|
||||
+
|
||||
+/*
|
||||
+ Module: rt2x00soc
|
||||
+ Abstract: rt2x00 generic soc device routines.
|
||||
+ */
|
||||
+
|
||||
+#include <linux/bug.h>
|
||||
+#include <linux/kernel.h>
|
||||
+#include <linux/module.h>
|
||||
+#include <linux/platform_device.h>
|
||||
+
|
||||
+#include "rt2x00.h"
|
||||
+#include "rt2x00soc.h"
|
||||
+
|
||||
+static void rt2x00soc_free_reg(struct rt2x00_dev *rt2x00dev)
|
||||
+{
|
||||
+ kfree(rt2x00dev->rf);
|
||||
+ rt2x00dev->rf = NULL;
|
||||
+
|
||||
+ kfree(rt2x00dev->eeprom);
|
||||
+ rt2x00dev->eeprom = NULL;
|
||||
+}
|
||||
+
|
||||
+static int rt2x00soc_alloc_reg(struct rt2x00_dev *rt2x00dev)
|
||||
+{
|
||||
+ struct platform_device *pdev = to_platform_device(rt2x00dev->dev);
|
||||
+ struct resource *res;
|
||||
+
|
||||
+ res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
|
||||
+ if (!res)
|
||||
+ return -ENODEV;
|
||||
+
|
||||
+ rt2x00dev->csr.base = (void __iomem *)KSEG1ADDR(res->start);
|
||||
+ if (!rt2x00dev->csr.base)
|
||||
+ goto exit;
|
||||
+
|
||||
+ rt2x00dev->eeprom = kzalloc(rt2x00dev->ops->eeprom_size, GFP_KERNEL);
|
||||
+ if (!rt2x00dev->eeprom)
|
||||
+ goto exit;
|
||||
+
|
||||
+ rt2x00dev->rf = kzalloc(rt2x00dev->ops->rf_size, GFP_KERNEL);
|
||||
+ if (!rt2x00dev->rf)
|
||||
+ goto exit;
|
||||
+
|
||||
+ return 0;
|
||||
+
|
||||
+exit:
|
||||
+ ERROR_PROBE("Failed to allocate registers.\n");
|
||||
+ rt2x00soc_free_reg(rt2x00dev);
|
||||
+
|
||||
+ return -ENOMEM;
|
||||
+}
|
||||
+
|
||||
+int rt2x00soc_probe(struct platform_device *pdev,
|
||||
+ const unsigned short chipset,
|
||||
+ const struct rt2x00_ops *ops)
|
||||
+{
|
||||
+ struct ieee80211_hw *hw;
|
||||
+ struct rt2x00_dev *rt2x00dev;
|
||||
+ int retval;
|
||||
+
|
||||
+ hw = ieee80211_alloc_hw(sizeof(struct rt2x00_dev), ops->hw);
|
||||
+ if (!hw) {
|
||||
+ ERROR_PROBE("Failed to allocate hardware.\n");
|
||||
+ return -ENOMEM;
|
||||
+ }
|
||||
+
|
||||
+ platform_set_drvdata(pdev, hw);
|
||||
+
|
||||
+ rt2x00dev = hw->priv;
|
||||
+ rt2x00dev->dev = &pdev->dev;
|
||||
+ rt2x00dev->ops = ops;
|
||||
+ rt2x00dev->hw = hw;
|
||||
+ rt2x00dev->irq = platform_get_irq(pdev, 0);
|
||||
+ rt2x00dev->name = pdev->dev.driver->name;
|
||||
+
|
||||
+ rt2x00_set_chip_rt(rt2x00dev, chipset);
|
||||
+
|
||||
+ retval = rt2x00soc_alloc_reg(rt2x00dev);
|
||||
+ if (retval)
|
||||
+ goto exit_free_device;
|
||||
+
|
||||
+ retval = rt2x00lib_probe_dev(rt2x00dev);
|
||||
+ if (retval)
|
||||
+ goto exit_free_reg;
|
||||
+
|
||||
+ return 0;
|
||||
+
|
||||
+exit_free_reg:
|
||||
+ rt2x00soc_free_reg(rt2x00dev);
|
||||
+
|
||||
+exit_free_device:
|
||||
+ ieee80211_free_hw(hw);
|
||||
+
|
||||
+ return retval;
|
||||
+}
|
||||
+
|
||||
+int rt2x00soc_remove(struct platform_device *pdev)
|
||||
+{
|
||||
+ struct ieee80211_hw *hw = platform_get_drvdata(pdev);
|
||||
+ struct rt2x00_dev *rt2x00dev = hw->priv;
|
||||
+
|
||||
+ /*
|
||||
+ * Free all allocated data.
|
||||
+ */
|
||||
+ rt2x00lib_remove_dev(rt2x00dev);
|
||||
+ rt2x00soc_free_reg(rt2x00dev);
|
||||
+ ieee80211_free_hw(hw);
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
+EXPORT_SYMBOL_GPL(rt2x00soc_remove);
|
||||
+
|
||||
+#ifdef CONFIG_PM
|
||||
+int rt2x00soc_suspend(struct platform_device *pdev, pm_message_t state)
|
||||
+{
|
||||
+ struct ieee80211_hw *hw = platform_get_drvdata(pdev);
|
||||
+ struct rt2x00_dev *rt2x00dev = hw->priv;
|
||||
+
|
||||
+ return rt2x00lib_suspend(rt2x00dev, state);
|
||||
+}
|
||||
+EXPORT_SYMBOL_GPL(rt2x00soc_suspend);
|
||||
+
|
||||
+int rt2x00soc_resume(struct platform_device *pdev)
|
||||
+{
|
||||
+ struct ieee80211_hw *hw = platform_get_drvdata(pdev);
|
||||
+ struct rt2x00_dev *rt2x00dev = hw->priv;
|
||||
+
|
||||
+ return rt2x00lib_resume(rt2x00dev);
|
||||
+}
|
||||
+EXPORT_SYMBOL_GPL(rt2x00soc_resume);
|
||||
+#endif /* CONFIG_PM */
|
||||
+
|
||||
+/*
|
||||
+ * rt2x00soc module information.
|
||||
+ */
|
||||
+MODULE_AUTHOR(DRV_PROJECT);
|
||||
+MODULE_VERSION(DRV_VERSION);
|
||||
+MODULE_DESCRIPTION("rt2x00 soc library");
|
||||
+MODULE_LICENSE("GPL");
|
||||
--- /dev/null
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2x00soc.h
|
||||
@@ -0,0 +1,52 @@
|
||||
+/*
|
||||
+ Copyright (C) 2004 - 2009 rt2x00 SourceForge Project
|
||||
+ <http://rt2x00.serialmonkey.com>
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 2 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the
|
||||
+ Free Software Foundation, Inc.,
|
||||
+ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+ */
|
||||
+
|
||||
+/*
|
||||
+ Module: rt2x00soc
|
||||
+ Abstract: Data structures for the rt2x00soc module.
|
||||
+ */
|
||||
+
|
||||
+#ifndef RT2X00SOC_H
|
||||
+#define RT2X00SOC_H
|
||||
+
|
||||
+#define KSEG1ADDR(__ptr) __ptr
|
||||
+
|
||||
+#define __rt2x00soc_probe(__chipset, __ops) \
|
||||
+static int __rt2x00soc_probe(struct platform_device *pdev) \
|
||||
+{ \
|
||||
+ return rt2x00soc_probe(pdev, (__chipset), (__ops)); \
|
||||
+}
|
||||
+
|
||||
+/*
|
||||
+ * SoC driver handlers.
|
||||
+ */
|
||||
+int rt2x00soc_probe(struct platform_device *pdev,
|
||||
+ const unsigned short chipset,
|
||||
+ const struct rt2x00_ops *ops);
|
||||
+int rt2x00soc_remove(struct platform_device *pdev);
|
||||
+#ifdef CONFIG_PM
|
||||
+int rt2x00soc_suspend(struct platform_device *pdev, pm_message_t state);
|
||||
+int rt2x00soc_resume(struct platform_device *pdev);
|
||||
+#else
|
||||
+#define rt2x00soc_suspend NULL
|
||||
+#define rt2x00soc_resume NULL
|
||||
+#endif /* CONFIG_PM */
|
||||
+
|
||||
+#endif /* RT2X00SOC_H */
|
File diff suppressed because it is too large
Load diff
|
@ -8,7 +8,7 @@
|
|||
#include <asm/unaligned.h>
|
||||
|
||||
#include "hw.h"
|
||||
@@ -511,8 +512,18 @@ static int ath9k_hw_init_macaddr(struct
|
||||
@@ -494,8 +495,18 @@ static int ath9k_hw_init_macaddr(struct
|
||||
common->macaddr[2 * i] = eeval >> 8;
|
||||
common->macaddr[2 * i + 1] = eeval & 0xff;
|
||||
}
|
||||
|
|
|
@ -18,7 +18,7 @@
|
|||
+#endif
|
||||
--- a/drivers/net/wireless/ath/regd.h
|
||||
+++ b/drivers/net/wireless/ath/regd.h
|
||||
@@ -242,6 +242,41 @@ enum CountryCode {
|
||||
@@ -250,6 +250,41 @@ enum CountryCode {
|
||||
CTRY_BELGIUM2 = 5002
|
||||
};
|
||||
|
||||
|
@ -60,7 +60,7 @@
|
|||
bool ath_is_world_regd(struct ath_regulatory *reg);
|
||||
int ath_regd_init(struct ath_regulatory *reg, struct wiphy *wiphy,
|
||||
int (*reg_notifier)(struct wiphy *wiphy,
|
||||
@@ -253,3 +288,5 @@ int ath_reg_notifier_apply(struct wiphy
|
||||
@@ -261,3 +296,5 @@ int ath_reg_notifier_apply(struct wiphy
|
||||
struct ath_regulatory *reg);
|
||||
|
||||
#endif
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- a/drivers/net/wireless/ath/ath9k/ahb.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/ahb.c
|
||||
@@ -29,15 +29,13 @@ static void ath_ahb_read_cachesize(struc
|
||||
|
||||
static void ath_ahb_cleanup(struct ath_common *common)
|
||||
{
|
||||
- struct ath_hw *ah = (struct ath_hw *) common->ah;
|
||||
- struct ath_softc *sc = ah->ah_sc;
|
||||
+ struct ath_softc *sc = (struct ath_softc *) common->priv;
|
||||
iounmap(sc->mem);
|
||||
}
|
||||
|
||||
static bool ath_ahb_eeprom_read(struct ath_common *common, u32 off, u16 *data)
|
||||
{
|
||||
- struct ath_hw *ah = (struct ath_hw *) common->ah;
|
||||
- struct ath_softc *sc = ah->ah_sc;
|
||||
+ struct ath_softc *sc = (struct ath_softc *) common->priv;
|
||||
struct platform_device *pdev = to_platform_device(sc->dev);
|
||||
struct ath9k_platform_data *pdata;
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- a/net/mac80211/ibss.c
|
||||
+++ b/net/mac80211/ibss.c
|
||||
@@ -544,7 +544,7 @@ static void ieee80211_sta_find_ibss(stru
|
||||
"%pM\n", bss->cbss.bssid, ifibss->bssid);
|
||||
#endif /* CONFIG_MAC80211_IBSS_DEBUG */
|
||||
|
||||
- if (bss && memcmp(ifibss->bssid, bss->cbss.bssid, ETH_ALEN)) {
|
||||
+ if (bss && !memcmp(ifibss->bssid, bss->cbss.bssid, ETH_ALEN)) {
|
||||
printk(KERN_DEBUG "%s: Selected IBSS BSSID %pM"
|
||||
" based on configured SSID\n",
|
||||
sdata->dev->name, bss->cbss.bssid);
|
|
@ -1,22 +0,0 @@
|
|||
--- a/drivers/net/wireless/ath/ath5k/base.c
|
||||
+++ b/drivers/net/wireless/ath/ath5k/base.c
|
||||
@@ -238,7 +238,7 @@ static struct pci_driver ath5k_pci_drive
|
||||
.remove = __devexit_p(ath5k_pci_remove),
|
||||
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29))
|
||||
.driver.pm = ATH5K_PM_OPS,
|
||||
-#else
|
||||
+#elif defined(CONFIG_PM)
|
||||
.suspend = ath5k_pci_suspend_compat,
|
||||
.resume = ath5k_pci_resume_compat,
|
||||
#endif
|
||||
--- a/compat/patches/11-dev-pm-ops.patch
|
||||
+++ b/compat/patches/11-dev-pm-ops.patch
|
||||
@@ -49,7 +49,7 @@ calls on compat code with only slight mo
|
||||
.remove = __devexit_p(ath5k_pci_remove),
|
||||
+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29))
|
||||
.driver.pm = ATH5K_PM_OPS,
|
||||
-+#else
|
||||
++#elif defined(CONFIG_PM)
|
||||
+ .suspend = ath5k_pci_suspend_compat,
|
||||
+ .resume = ath5k_pci_resume_compat,
|
||||
+#endif
|
Loading…
Reference in a new issue