kernel: Activate VDSO on MIPS again
The cache coloring problem on MIPS CPUs was fixed with kernel 4.9.129 of the kernel 4.9 branch. Activate VDSO support for MIPS again. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
0214166b31
commit
91a71804f8
1 changed files with 0 additions and 23 deletions
|
@ -1,23 +0,0 @@
|
||||||
From: Felix Fietkau <nbd@nbd.name>
|
|
||||||
Subject: kernel: disable MIPS VDSO by default until the cache issues have been resolved
|
|
||||||
|
|
||||||
lede-commit: 1185e645a773c86aa88cf04d0e2911dc62eb43f5
|
|
||||||
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
||||||
---
|
|
||||||
arch/mips/vdso/Makefile | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/arch/mips/vdso/Makefile
|
|
||||||
+++ b/arch/mips/vdso/Makefile
|
|
||||||
@@ -28,9 +28,9 @@ aflags-vdso := $(ccflags-vdso) \
|
|
||||||
ifndef CONFIG_CPU_MIPSR6
|
|
||||||
ifeq ($(call ld-ifversion, -lt, 225000000, y),y)
|
|
||||||
$(warning MIPS VDSO requires binutils >= 2.25)
|
|
||||||
- obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
||||||
- ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
||||||
endif
|
|
||||||
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
||||||
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
||||||
endif
|
|
||||||
|
|
||||||
# VDSO linker flags.
|
|
Loading…
Reference in a new issue