oops, one file got left out.. also add a profile for the WRTSL54GS - still from noz :)
SVN-Revision: 7338
This commit is contained in:
parent
3237230249
commit
9037e9943b
2 changed files with 47 additions and 0 deletions
30
target/linux/brcm47xx-2.6/patches/180-cpu_fixes2.patch
Normal file
30
target/linux/brcm47xx-2.6/patches/180-cpu_fixes2.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- linux-2.6.21.1/arch/mips/bcm947xx/irq.c.orig 2007-05-18 21:27:17.000000000 +0100
|
||||
+++ linux-2.6.21.1/arch/mips/bcm947xx/irq.c 2007-05-24 23:25:38.000000000 +0100
|
||||
@@ -59,5 +59,5 @@
|
||||
|
||||
void __init arch_init_irq(void)
|
||||
{
|
||||
- mips_cpu_irq_init(0);
|
||||
+ mips_cpu_irq_init();
|
||||
}
|
||||
--- linux-2.6.21.1/arch/mips/bcm947xx/prom.c.orig 2007-05-18 21:27:17.000000000 +0100
|
||||
+++ linux-2.6.21.1/arch/mips/bcm947xx/prom.c 2007-05-24 23:46:06.000000000 +0100
|
||||
@@ -56,7 +56,6 @@
|
||||
add_memory_region(0, mem, BOOT_MEM_RAM);
|
||||
}
|
||||
|
||||
-unsigned long __init prom_free_prom_memory(void)
|
||||
+void __init prom_free_prom_memory(void)
|
||||
{
|
||||
- return 0;
|
||||
}
|
||||
--- linux-2.6.21.1/drivers/mtd/maps/bcm47xx-flash.c.orig 2007-05-18 21:27:17.000000000 +0100
|
||||
+++ linux-2.6.21.1/drivers/mtd/maps/bcm47xx-flash.c 2007-05-25 00:22:18.000000000 +0100
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <linux/module.h>
|
||||
#include <linux/types.h>
|
||||
#include <linux/kernel.h>
|
||||
+#include <linux/sched.h>
|
||||
#include <linux/wait.h>
|
||||
#include <linux/mtd/mtd.h>
|
||||
#include <linux/mtd/map.h>
|
17
target/linux/brcm47xx-2.6/profiles/WRTSL54GS.mk
Normal file
17
target/linux/brcm47xx-2.6/profiles/WRTSL54GS.mk
Normal file
|
@ -0,0 +1,17 @@
|
|||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
define Profile/WRTSL54GS
|
||||
NAME:=Linksys WRTSL54GS
|
||||
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-fs-ext3 e2fsprogs
|
||||
endef
|
||||
|
||||
define Profile/WRTSL54GS/Description
|
||||
Package set compatible with the Linksys WRTSL54GS. Contains USB support
|
||||
endef
|
||||
$(eval $(call Profile,WRTSL54GS))
|
||||
|
Loading…
Reference in a new issue