madwifi: fix x86_64 compilation
SVN-Revision: 12574
This commit is contained in:
parent
52bb4fac97
commit
9029e3d9ef
1 changed files with 16 additions and 0 deletions
16
package/madwifi/patches/106-get_arch.patch
Normal file
16
package/madwifi/patches/106-get_arch.patch
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
--- a/scripts/get_arch.mk
|
||||||
|
+++ b/scripts/get_arch.mk
|
||||||
|
@@ -36,6 +36,13 @@
|
||||||
|
$(Cannot determine ARCH)
|
||||||
|
endif
|
||||||
|
|
||||||
|
+# Allow ARCH to be x86
|
||||||
|
+ifneq (,$(CONFIG_X86))
|
||||||
|
+ifeq (x86,$(ARCH))
|
||||||
|
+ARCH-y = $(ARCH)
|
||||||
|
+endif
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
# Don't allow ARCH to be overridden by a different value.
|
||||||
|
ifeq (,$(ARCH))
|
||||||
|
ARCH = $(ARCH-y)
|
Loading…
Reference in a new issue