ppp: fix building pptp plugin
The pptp.so plugin needs to be built with -fPIC as well in order to be linkable again. Fixes888a15ff83
("ppp: add missing -fPIC to rp-pppoe.so CFLAGS") Fixese7397eef69
("ppp: compile with LTO enabled") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
ac10975cd7
commit
9019323ec1
2 changed files with 12 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=ppp
|
||||
PKG_VERSION:=2.4.7
|
||||
PKG_RELEASE:=12
|
||||
PKG_RELEASE:=13
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://download.samba.org/pub/ppp/
|
||||
|
|
11
package/network/services/ppp/patches/511-pptp_cflags.patch
Normal file
11
package/network/services/ppp/patches/511-pptp_cflags.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/pppd/plugins/pptp/Makefile.linux
|
||||
+++ b/pppd/plugins/pptp/Makefile.linux
|
||||
@@ -20,7 +20,7 @@ all: pptp.so
|
||||
$(CC) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
pptp.so: dirutil.o orckit_quirks.o pptp.o pptp_callmgr.o pptp_ctrl.o pptp_quirks.o util.o vector.o
|
||||
- $(CC) -o pptp.so -shared dirutil.o orckit_quirks.o pptp.o pptp_callmgr.o pptp_ctrl.o pptp_quirks.o util.o vector.o
|
||||
+ $(CC) -fPIC -o pptp.so -shared dirutil.o orckit_quirks.o pptp.o pptp_callmgr.o pptp_ctrl.o pptp_quirks.o util.o vector.o
|
||||
|
||||
install: all
|
||||
$(INSTALL) -d -m 755 $(LIBDIR)
|
Loading…
Reference in a new issue