iproute2: update to 4.18.0
Update to the latest version of iproute2; see https://lwn.net/Articles/762515/ for a full overview of the changes in 4.18. Remove upstream patch 001-rdma-sync-some-IP-headers-with-glibc Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
d9792152fd
commit
8fd8e79143
2 changed files with 3 additions and 40 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=iproute2
|
PKG_NAME:=iproute2
|
||||||
PKG_VERSION:=4.17.0
|
PKG_VERSION:=4.18.0
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||||
PKG_HASH:=6fa991b092315887775b9e47dc6a89af7ae09dd3ad4ccff754d055c566b4be6e
|
PKG_HASH:=a9e6c70c95f513871c5e1f4e452c04fcb3c4d8a05be651bd794cd994a52daa45
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_BUILD_DEPENDS:=iptables
|
PKG_BUILD_DEPENDS:=iptables
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
|
|
|
@ -1,37 +0,0 @@
|
||||||
From 5887ff0922a06d978d3271df9f01fcb04fadc75f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hoang Le <hoang.h.le@dektech.com.au>
|
|
||||||
Date: Wed, 13 Jun 2018 11:09:56 +0700
|
|
||||||
Subject: [PATCH] rdma: sync some IP headers with glibc
|
|
||||||
|
|
||||||
In the commit 9a362cc71a45, new userspace header:
|
|
||||||
(i.e rdma/rdma_user_cm.h -> linux/in6.h)
|
|
||||||
is included before the kernel space header:
|
|
||||||
(i.e utils.h -> resolv.h -> netinet/in.h).
|
|
||||||
|
|
||||||
This leads to unsynchronous some IP headers and compiler got failure
|
|
||||||
with error: redefinition of some structs IP.
|
|
||||||
|
|
||||||
In this commit, just reorder this including to make them in-sync.
|
|
||||||
|
|
||||||
Signed-off-by: Hoang Le <hoang.h.le@dektech.com.au>
|
|
||||||
Acked-by: Leon Romanovsky <leonro@mellanox.com>
|
|
||||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
|
||||||
---
|
|
||||||
rdma/rdma.h | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/rdma/rdma.h b/rdma/rdma.h
|
|
||||||
index fcaf9e69..d4b7ba19 100644
|
|
||||||
--- a/rdma/rdma.h
|
|
||||||
+++ b/rdma/rdma.h
|
|
||||||
@@ -15,6 +15,7 @@
|
|
||||||
#include <string.h>
|
|
||||||
#include <errno.h>
|
|
||||||
#include <getopt.h>
|
|
||||||
+#include <netinet/in.h>
|
|
||||||
#include <libmnl/libmnl.h>
|
|
||||||
#include <rdma/rdma_netlink.h>
|
|
||||||
#include <rdma/rdma_user_cm.h>
|
|
||||||
--
|
|
||||||
2.16.3
|
|
||||||
|
|
Loading…
Reference in a new issue