pkg-config: update to latest version, fix build on Mac OS X 10.9
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 38561
This commit is contained in:
parent
1879c5f8e7
commit
8fb4f34859
2 changed files with 5 additions and 24 deletions
|
@ -7,17 +7,20 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pkg-config
|
||||
PKG_VERSION:=0.25
|
||||
PKG_VERSION:=0.28
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
|
||||
PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
|
||||
PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
HOST_LDFLAGS += $(HOST_STATIC_LINKING)
|
||||
unexport PKG_CONFIG
|
||||
|
||||
HOST_CONFIGURE_ARGS += --with-internal-glib
|
||||
|
||||
define Host/Install
|
||||
$(MAKE) -C $(HOST_BUILD_DIR) install \
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- a/parse.c
|
||||
+++ b/parse.c
|
||||
@@ -1187,15 +1187,12 @@ try_command (const char *command)
|
||||
Package *
|
||||
get_compat_package (const char *name)
|
||||
{
|
||||
-#ifdef G_OS_WIN32
|
||||
- /* There has never been any of these legacy *-config scripts on
|
||||
- * Windows as far as I know. No use trying to execute them, will
|
||||
- * only confuse users to see the "blabla is not recognized as an
|
||||
- * internal or external command, operable program or batch file"
|
||||
- * messages.
|
||||
+ /*
|
||||
+ * We don't need this compatibility stuff on a system
|
||||
+ * that is free of legacy stuff
|
||||
*/
|
||||
return NULL;
|
||||
-#else
|
||||
+#if 0
|
||||
|
||||
Package *pkg;
|
||||
|
Loading…
Reference in a new issue