iw: update to 3.15
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41299
This commit is contained in:
parent
b9019462f3
commit
8db0fcf1f7
4 changed files with 50 additions and 210 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=iw
|
PKG_NAME:=iw
|
||||||
PKG_VERSION:=3.14
|
PKG_VERSION:=3.15
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://www.kernel.org/pub/software/network/iw
|
PKG_SOURCE_URL:=https://www.kernel.org/pub/software/network/iw
|
||||||
PKG_MD5SUM:=66e41053f6fc0781b683b5b688442de6
|
PKG_MD5SUM:=3b77ad7ec44a865a3bb2ab6c1c463bba
|
||||||
|
|
||||||
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
|
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
|
||||||
|
|
||||||
|
|
|
@ -1,39 +1,6 @@
|
||||||
--- a/nl80211.h
|
--- a/nl80211.h
|
||||||
+++ b/nl80211.h
|
+++ b/nl80211.h
|
||||||
@@ -303,8 +303,9 @@
|
@@ -503,6 +503,9 @@
|
||||||
* passed, all channels allowed for the current regulatory domain
|
|
||||||
* are used. Extra IEs can also be passed from the userspace by
|
|
||||||
* using the %NL80211_ATTR_IE attribute.
|
|
||||||
- * @NL80211_CMD_STOP_SCHED_SCAN: stop a scheduled scan. Returns -ENOENT
|
|
||||||
- * if scheduled scan is not running.
|
|
||||||
+ * @NL80211_CMD_STOP_SCHED_SCAN: stop a scheduled scan. Returns -ENOENT if
|
|
||||||
+ * scheduled scan is not running. The caller may assume that as soon
|
|
||||||
+ * as the call returns, it is safe to start a new scheduled scan again.
|
|
||||||
* @NL80211_CMD_SCHED_SCAN_RESULTS: indicates that there are scheduled scan
|
|
||||||
* results available.
|
|
||||||
* @NL80211_CMD_SCHED_SCAN_STOPPED: indicates that the scheduled scan has
|
|
||||||
@@ -418,8 +419,18 @@
|
|
||||||
* %NL80211_ATTR_SSID attribute, and can optionally specify the association
|
|
||||||
* IEs in %NL80211_ATTR_IE, %NL80211_ATTR_AUTH_TYPE, %NL80211_ATTR_USE_MFP,
|
|
||||||
* %NL80211_ATTR_MAC, %NL80211_ATTR_WIPHY_FREQ, %NL80211_ATTR_CONTROL_PORT,
|
|
||||||
- * %NL80211_ATTR_CONTROL_PORT_ETHERTYPE and
|
|
||||||
- * %NL80211_ATTR_CONTROL_PORT_NO_ENCRYPT.
|
|
||||||
+ * %NL80211_ATTR_CONTROL_PORT_ETHERTYPE,
|
|
||||||
+ * %NL80211_ATTR_CONTROL_PORT_NO_ENCRYPT, %NL80211_ATTR_MAC_HINT, and
|
|
||||||
+ * %NL80211_ATTR_WIPHY_FREQ_HINT.
|
|
||||||
+ * If included, %NL80211_ATTR_MAC and %NL80211_ATTR_WIPHY_FREQ are
|
|
||||||
+ * restrictions on BSS selection, i.e., they effectively prevent roaming
|
|
||||||
+ * within the ESS. %NL80211_ATTR_MAC_HINT and %NL80211_ATTR_WIPHY_FREQ_HINT
|
|
||||||
+ * can be included to provide a recommendation of the initial BSS while
|
|
||||||
+ * allowing the driver to roam to other BSSes within the ESS and also to
|
|
||||||
+ * ignore this recommendation if the indicated BSS is not ideal. Only one
|
|
||||||
+ * set of BSSID,frequency parameters is used (i.e., either the enforcing
|
|
||||||
+ * %NL80211_ATTR_MAC,%NL80211_ATTR_WIPHY_FREQ or the less strict
|
|
||||||
+ * %NL80211_ATTR_MAC_HINT and %NL80211_ATTR_WIPHY_FREQ_HINT).
|
|
||||||
* Background scan period can optionally be
|
|
||||||
* specified in %NL80211_ATTR_BG_SCAN_PERIOD,
|
|
||||||
* if not specified default background scan configuration
|
|
||||||
@@ -492,6 +503,9 @@
|
|
||||||
* TX status event pertaining to the TX request.
|
* TX status event pertaining to the TX request.
|
||||||
* %NL80211_ATTR_TX_NO_CCK_RATE is used to decide whether to send the
|
* %NL80211_ATTR_TX_NO_CCK_RATE is used to decide whether to send the
|
||||||
* management frames at CCK rate or not in 2GHz band.
|
* management frames at CCK rate or not in 2GHz band.
|
||||||
|
@ -43,7 +10,7 @@
|
||||||
* @NL80211_CMD_FRAME_WAIT_CANCEL: When an off-channel TX was requested, this
|
* @NL80211_CMD_FRAME_WAIT_CANCEL: When an off-channel TX was requested, this
|
||||||
* command may be used with the corresponding cookie to cancel the wait
|
* command may be used with the corresponding cookie to cancel the wait
|
||||||
* time if it is known that it is no longer necessary.
|
* time if it is known that it is no longer necessary.
|
||||||
@@ -1514,10 +1528,10 @@ enum nl80211_commands {
|
@@ -1525,10 +1528,10 @@ enum nl80211_commands {
|
||||||
* operation).
|
* operation).
|
||||||
* @NL80211_ATTR_CSA_IES: Nested set of attributes containing the IE information
|
* @NL80211_ATTR_CSA_IES: Nested set of attributes containing the IE information
|
||||||
* for the time while performing a channel switch.
|
* for the time while performing a channel switch.
|
||||||
|
@ -58,28 +25,18 @@
|
||||||
*
|
*
|
||||||
* @NL80211_ATTR_RXMGMT_FLAGS: flags for nl80211_send_mgmt(), u32.
|
* @NL80211_ATTR_RXMGMT_FLAGS: flags for nl80211_send_mgmt(), u32.
|
||||||
* As specified in the &enum nl80211_rxmgmt_flags.
|
* As specified in the &enum nl80211_rxmgmt_flags.
|
||||||
@@ -1555,6 +1569,31 @@ enum nl80211_commands {
|
@@ -1576,9 +1579,21 @@ enum nl80211_commands {
|
||||||
* data is in the format defined for the payload of the QoS Map Set element
|
* advertise values that cannot always be met. In such cases, an attempt
|
||||||
* in IEEE Std 802.11-2012, 8.4.2.97.
|
* to add a new station entry with @NL80211_CMD_NEW_STATION may fail.
|
||||||
*
|
*
|
||||||
+ * @NL80211_ATTR_MAC_HINT: MAC address recommendation as initial BSS
|
|
||||||
+ * @NL80211_ATTR_WIPHY_FREQ_HINT: frequency of the recommended initial BSS
|
|
||||||
+ *
|
|
||||||
+ * @NL80211_ATTR_MAX_AP_ASSOC_STA: Device attribute that indicates how many
|
|
||||||
+ * associated stations are supported in AP mode (including P2P GO); u32.
|
|
||||||
+ * Since drivers may not have a fixed limit on the maximum number (e.g.,
|
|
||||||
+ * other concurrent operations may affect this), drivers are allowed to
|
|
||||||
+ * advertise values that cannot always be met. In such cases, an attempt
|
|
||||||
+ * to add a new station entry with @NL80211_CMD_NEW_STATION may fail.
|
|
||||||
+ *
|
|
||||||
+ * @NL80211_ATTR_CSA_C_OFFSETS_TX: An array of csa counter offsets (u16) which
|
+ * @NL80211_ATTR_CSA_C_OFFSETS_TX: An array of csa counter offsets (u16) which
|
||||||
+ * should be updated when the frame is transmitted.
|
+ * should be updated when the frame is transmitted.
|
||||||
+ * @NL80211_ATTR_MAX_CSA_COUNTERS: U8 attribute used to advertise the maximum
|
+ * @NL80211_ATTR_MAX_CSA_COUNTERS: U8 attribute used to advertise the maximum
|
||||||
+ * supported number of csa counters.
|
+ * supported number of csa counters.
|
||||||
+ *
|
+ *
|
||||||
+ * @NL80211_ATTR_TDLS_PEER_CAPABILITY: flags for TDLS peer capabilities, u32.
|
* @NL80211_ATTR_TDLS_PEER_CAPABILITY: flags for TDLS peer capabilities, u32.
|
||||||
+ * As specified in the &enum nl80211_tdls_peer_capability.
|
* As specified in the &enum nl80211_tdls_peer_capability.
|
||||||
+ *
|
*
|
||||||
+ * @NL80211_ATTR_IFACE_SOCKET_OWNER: flag attribute, if set during interface
|
+ * @NL80211_ATTR_IFACE_SOCKET_OWNER: flag attribute, if set during interface
|
||||||
+ * creation then the new interface will be owned by the netlink socket
|
+ * creation then the new interface will be owned by the netlink socket
|
||||||
+ * that created it and will be destroyed when the socket is closed
|
+ * that created it and will be destroyed when the socket is closed
|
||||||
|
@ -90,17 +47,10 @@
|
||||||
* @NL80211_ATTR_MAX: highest attribute number currently defined
|
* @NL80211_ATTR_MAX: highest attribute number currently defined
|
||||||
* @__NL80211_ATTR_AFTER_LAST: internal use
|
* @__NL80211_ATTR_AFTER_LAST: internal use
|
||||||
*/
|
*/
|
||||||
@@ -1883,6 +1922,20 @@ enum nl80211_attrs {
|
@@ -1914,6 +1929,13 @@ enum nl80211_attrs {
|
||||||
|
|
||||||
NL80211_ATTR_QOS_MAP,
|
NL80211_ATTR_TDLS_PEER_CAPABILITY,
|
||||||
|
|
||||||
+ NL80211_ATTR_MAC_HINT,
|
|
||||||
+ NL80211_ATTR_WIPHY_FREQ_HINT,
|
|
||||||
+
|
|
||||||
+ NL80211_ATTR_MAX_AP_ASSOC_STA,
|
|
||||||
+
|
|
||||||
+ NL80211_ATTR_TDLS_PEER_CAPABILITY,
|
|
||||||
+
|
|
||||||
+ NL80211_ATTR_IFACE_SOCKET_OWNER,
|
+ NL80211_ATTR_IFACE_SOCKET_OWNER,
|
||||||
+
|
+
|
||||||
+ NL80211_ATTR_CSA_C_OFFSETS_TX,
|
+ NL80211_ATTR_CSA_C_OFFSETS_TX,
|
||||||
|
@ -111,11 +61,27 @@
|
||||||
/* add attributes here, update the policy in nl80211.c */
|
/* add attributes here, update the policy in nl80211.c */
|
||||||
|
|
||||||
__NL80211_ATTR_AFTER_LAST,
|
__NL80211_ATTR_AFTER_LAST,
|
||||||
@@ -2304,9 +2357,35 @@ enum nl80211_band_attr {
|
@@ -2182,6 +2204,8 @@ enum nl80211_sta_bss_param {
|
||||||
* @NL80211_FREQUENCY_ATTR_NO_160MHZ: any 160 MHz (but not 80+80) channel
|
* Contains a nested array of signal strength attributes (u8, dBm)
|
||||||
|
* @NL80211_STA_INFO_CHAIN_SIGNAL_AVG: per-chain signal strength average
|
||||||
|
* Same format as NL80211_STA_INFO_CHAIN_SIGNAL.
|
||||||
|
+ * @NL80211_STA_EXPECTED_THROUGHPUT: expected throughput considering also the
|
||||||
|
+ * 802.11 header (u32, kbps)
|
||||||
|
* @__NL80211_STA_INFO_AFTER_LAST: internal
|
||||||
|
* @NL80211_STA_INFO_MAX: highest possible station info attribute
|
||||||
|
*/
|
||||||
|
@@ -2213,6 +2237,7 @@ enum nl80211_sta_info {
|
||||||
|
NL80211_STA_INFO_TX_BYTES64,
|
||||||
|
NL80211_STA_INFO_CHAIN_SIGNAL,
|
||||||
|
NL80211_STA_INFO_CHAIN_SIGNAL_AVG,
|
||||||
|
+ NL80211_STA_INFO_EXPECTED_THROUGHPUT,
|
||||||
|
|
||||||
|
/* keep last */
|
||||||
|
__NL80211_STA_INFO_AFTER_LAST,
|
||||||
|
@@ -2336,9 +2361,34 @@ enum nl80211_band_attr {
|
||||||
* using this channel as the primary or any of the secondary channels
|
* using this channel as the primary or any of the secondary channels
|
||||||
* isn't possible
|
* isn't possible
|
||||||
+ * @NL80211_FREQUENCY_ATTR_DFS_CAC_TIME: DFS CAC time in milliseconds.
|
* @NL80211_FREQUENCY_ATTR_DFS_CAC_TIME: DFS CAC time in milliseconds.
|
||||||
+ * @NL80211_FREQUENCY_ATTR_INDOOR_ONLY: Only indoor use is permitted on this
|
+ * @NL80211_FREQUENCY_ATTR_INDOOR_ONLY: Only indoor use is permitted on this
|
||||||
+ * channel. A channel that has the INDOOR_ONLY attribute can only be
|
+ * channel. A channel that has the INDOOR_ONLY attribute can only be
|
||||||
+ * used when there is a clear assessment that the device is operating in
|
+ * used when there is a clear assessment that the device is operating in
|
||||||
|
@ -147,11 +113,10 @@
|
||||||
*/
|
*/
|
||||||
enum nl80211_frequency_attr {
|
enum nl80211_frequency_attr {
|
||||||
__NL80211_FREQUENCY_ATTR_INVALID,
|
__NL80211_FREQUENCY_ATTR_INVALID,
|
||||||
@@ -2322,6 +2401,11 @@ enum nl80211_frequency_attr {
|
@@ -2355,6 +2405,10 @@ enum nl80211_frequency_attr {
|
||||||
NL80211_FREQUENCY_ATTR_NO_HT40_PLUS,
|
|
||||||
NL80211_FREQUENCY_ATTR_NO_80MHZ,
|
NL80211_FREQUENCY_ATTR_NO_80MHZ,
|
||||||
NL80211_FREQUENCY_ATTR_NO_160MHZ,
|
NL80211_FREQUENCY_ATTR_NO_160MHZ,
|
||||||
+ NL80211_FREQUENCY_ATTR_DFS_CAC_TIME,
|
NL80211_FREQUENCY_ATTR_DFS_CAC_TIME,
|
||||||
+ NL80211_FREQUENCY_ATTR_INDOOR_ONLY,
|
+ NL80211_FREQUENCY_ATTR_INDOOR_ONLY,
|
||||||
+ NL80211_FREQUENCY_ATTR_GO_CONCURRENT,
|
+ NL80211_FREQUENCY_ATTR_GO_CONCURRENT,
|
||||||
+ NL80211_FREQUENCY_ATTR_NO_20MHZ,
|
+ NL80211_FREQUENCY_ATTR_NO_20MHZ,
|
||||||
|
@ -159,68 +124,7 @@
|
||||||
|
|
||||||
/* keep last */
|
/* keep last */
|
||||||
__NL80211_FREQUENCY_ATTR_AFTER_LAST,
|
__NL80211_FREQUENCY_ATTR_AFTER_LAST,
|
||||||
@@ -2412,12 +2496,14 @@ enum nl80211_reg_type {
|
@@ -2573,10 +2627,13 @@ enum nl80211_dfs_regions {
|
||||||
* in KHz. This is not a center a frequency but an actual regulatory
|
|
||||||
* band edge.
|
|
||||||
* @NL80211_ATTR_FREQ_RANGE_MAX_BW: maximum allowed bandwidth for this
|
|
||||||
- * frequency range, in KHz.
|
|
||||||
+ * frequency range, in KHz.
|
|
||||||
* @NL80211_ATTR_POWER_RULE_MAX_ANT_GAIN: the maximum allowed antenna gain
|
|
||||||
* for a given frequency range. The value is in mBi (100 * dBi).
|
|
||||||
* If you don't have one then don't send this.
|
|
||||||
* @NL80211_ATTR_POWER_RULE_MAX_EIRP: the maximum allowed EIRP for
|
|
||||||
* a given frequency range. The value is in mBm (100 * dBm).
|
|
||||||
+ * @NL80211_ATTR_DFS_CAC_TIME: DFS CAC time in milliseconds.
|
|
||||||
+ * If not present or 0 default CAC time will be used.
|
|
||||||
* @NL80211_REG_RULE_ATTR_MAX: highest regulatory rule attribute number
|
|
||||||
* currently defined
|
|
||||||
* @__NL80211_REG_RULE_ATTR_AFTER_LAST: internal use
|
|
||||||
@@ -2433,6 +2519,8 @@ enum nl80211_reg_rule_attr {
|
|
||||||
NL80211_ATTR_POWER_RULE_MAX_ANT_GAIN,
|
|
||||||
NL80211_ATTR_POWER_RULE_MAX_EIRP,
|
|
||||||
|
|
||||||
+ NL80211_ATTR_DFS_CAC_TIME,
|
|
||||||
+
|
|
||||||
/* keep last */
|
|
||||||
__NL80211_REG_RULE_ATTR_AFTER_LAST,
|
|
||||||
NL80211_REG_RULE_ATTR_MAX = __NL80211_REG_RULE_ATTR_AFTER_LAST - 1
|
|
||||||
@@ -2442,9 +2530,15 @@ enum nl80211_reg_rule_attr {
|
|
||||||
* enum nl80211_sched_scan_match_attr - scheduled scan match attributes
|
|
||||||
* @__NL80211_SCHED_SCAN_MATCH_ATTR_INVALID: attribute number 0 is reserved
|
|
||||||
* @NL80211_SCHED_SCAN_MATCH_ATTR_SSID: SSID to be used for matching,
|
|
||||||
- * only report BSS with matching SSID.
|
|
||||||
+ * only report BSS with matching SSID.
|
|
||||||
* @NL80211_SCHED_SCAN_MATCH_ATTR_RSSI: RSSI threshold (in dBm) for reporting a
|
|
||||||
- * BSS in scan results. Filtering is turned off if not specified.
|
|
||||||
+ * BSS in scan results. Filtering is turned off if not specified. Note that
|
|
||||||
+ * if this attribute is in a match set of its own, then it is treated as
|
|
||||||
+ * the default value for all matchsets with an SSID, rather than being a
|
|
||||||
+ * matchset of its own without an RSSI filter. This is due to problems with
|
|
||||||
+ * how this API was implemented in the past. Also, due to the same problem,
|
|
||||||
+ * the only way to create a matchset with only an RSSI filter (with this
|
|
||||||
+ * attribute) is if there's only a single matchset with the RSSI attribute.
|
|
||||||
* @NL80211_SCHED_SCAN_MATCH_ATTR_MAX: highest scheduled scan filter
|
|
||||||
* attribute number currently defined
|
|
||||||
* @__NL80211_SCHED_SCAN_MATCH_ATTR_AFTER_LAST: internal use
|
|
||||||
@@ -2477,6 +2571,9 @@ enum nl80211_sched_scan_match_attr {
|
|
||||||
* @NL80211_RRF_NO_IR: no mechanisms that initiate radiation are allowed,
|
|
||||||
* this includes probe requests or modes of operation that require
|
|
||||||
* beaconing.
|
|
||||||
+ * @NL80211_RRF_AUTO_BW: maximum available bandwidth should be calculated
|
|
||||||
+ * base on contiguous rules and wider channels will be allowed to cross
|
|
||||||
+ * multiple contiguous/overlapping frequency ranges.
|
|
||||||
*/
|
|
||||||
enum nl80211_reg_rule_flags {
|
|
||||||
NL80211_RRF_NO_OFDM = 1<<0,
|
|
||||||
@@ -2488,6 +2585,7 @@ enum nl80211_reg_rule_flags {
|
|
||||||
NL80211_RRF_PTMP_ONLY = 1<<6,
|
|
||||||
NL80211_RRF_NO_IR = 1<<7,
|
|
||||||
__NL80211_RRF_NO_IBSS = 1<<8,
|
|
||||||
+ NL80211_RRF_AUTO_BW = 1<<11,
|
|
||||||
};
|
|
||||||
|
|
||||||
#define NL80211_RRF_PASSIVE_SCAN NL80211_RRF_NO_IR
|
|
||||||
@@ -2526,10 +2624,13 @@ enum nl80211_dfs_regions {
|
|
||||||
* present has been registered with the wireless core that
|
* present has been registered with the wireless core that
|
||||||
* has listed NL80211_FEATURE_CELL_BASE_REG_HINTS as a
|
* has listed NL80211_FEATURE_CELL_BASE_REG_HINTS as a
|
||||||
* supported feature.
|
* supported feature.
|
||||||
|
@ -234,36 +138,7 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
/**
|
/**
|
||||||
@@ -3131,6 +3232,7 @@ enum nl80211_key_attributes {
|
@@ -3650,6 +3707,8 @@ enum nl80211_iface_limit_attrs {
|
||||||
* in an array of MCS numbers.
|
|
||||||
* @NL80211_TXRATE_VHT: VHT rates allowed for TX rate selection,
|
|
||||||
* see &struct nl80211_txrate_vht
|
|
||||||
+ * @NL80211_TXRATE_GI: configure GI, see &enum nl80211_txrate_gi
|
|
||||||
* @__NL80211_TXRATE_AFTER_LAST: internal
|
|
||||||
* @NL80211_TXRATE_MAX: highest TX rate attribute
|
|
||||||
*/
|
|
||||||
@@ -3139,6 +3241,7 @@ enum nl80211_tx_rate_attributes {
|
|
||||||
NL80211_TXRATE_LEGACY,
|
|
||||||
NL80211_TXRATE_HT,
|
|
||||||
NL80211_TXRATE_VHT,
|
|
||||||
+ NL80211_TXRATE_GI,
|
|
||||||
|
|
||||||
/* keep last */
|
|
||||||
__NL80211_TXRATE_AFTER_LAST,
|
|
||||||
@@ -3156,6 +3259,12 @@ struct nl80211_txrate_vht {
|
|
||||||
__u16 mcs[NL80211_VHT_NSS_MAX];
|
|
||||||
};
|
|
||||||
|
|
||||||
+enum nl80211_txrate_gi {
|
|
||||||
+ NL80211_TXRATE_DEFAULT_GI,
|
|
||||||
+ NL80211_TXRATE_FORCE_SGI,
|
|
||||||
+ NL80211_TXRATE_FORCE_LGI,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
/**
|
|
||||||
* enum nl80211_band - Frequency band
|
|
||||||
* @NL80211_BAND_2GHZ: 2.4 GHz ISM band
|
|
||||||
@@ -3595,6 +3704,8 @@ enum nl80211_iface_limit_attrs {
|
|
||||||
* different channels may be used within this group.
|
* different channels may be used within this group.
|
||||||
* @NL80211_IFACE_COMB_RADAR_DETECT_WIDTHS: u32 attribute containing the bitmap
|
* @NL80211_IFACE_COMB_RADAR_DETECT_WIDTHS: u32 attribute containing the bitmap
|
||||||
* of supported channel widths for radar detection.
|
* of supported channel widths for radar detection.
|
||||||
|
@ -272,7 +147,7 @@
|
||||||
* @NUM_NL80211_IFACE_COMB: number of attributes
|
* @NUM_NL80211_IFACE_COMB: number of attributes
|
||||||
* @MAX_NL80211_IFACE_COMB: highest attribute number
|
* @MAX_NL80211_IFACE_COMB: highest attribute number
|
||||||
*
|
*
|
||||||
@@ -3628,6 +3739,7 @@ enum nl80211_if_combination_attrs {
|
@@ -3683,6 +3742,7 @@ enum nl80211_if_combination_attrs {
|
||||||
NL80211_IFACE_COMB_STA_AP_BI_MATCH,
|
NL80211_IFACE_COMB_STA_AP_BI_MATCH,
|
||||||
NL80211_IFACE_COMB_NUM_CHANNELS,
|
NL80211_IFACE_COMB_NUM_CHANNELS,
|
||||||
NL80211_IFACE_COMB_RADAR_DETECT_WIDTHS,
|
NL80211_IFACE_COMB_RADAR_DETECT_WIDTHS,
|
||||||
|
@ -280,21 +155,7 @@
|
||||||
|
|
||||||
/* keep last */
|
/* keep last */
|
||||||
NUM_NL80211_IFACE_COMB,
|
NUM_NL80211_IFACE_COMB,
|
||||||
@@ -3801,11 +3913,8 @@ enum nl80211_ap_sme_features {
|
@@ -3893,6 +3953,9 @@ enum nl80211_ap_sme_features {
|
||||||
* @NL80211_FEATURE_CELL_BASE_REG_HINTS: This driver has been tested
|
|
||||||
* to work properly to suppport receiving regulatory hints from
|
|
||||||
* cellular base stations.
|
|
||||||
- * @NL80211_FEATURE_P2P_DEVICE_NEEDS_CHANNEL: If this is set, an active
|
|
||||||
- * P2P Device (%NL80211_IFTYPE_P2P_DEVICE) requires its own channel
|
|
||||||
- * in the interface combinations, even when it's only used for scan
|
|
||||||
- * and remain-on-channel. This could be due to, for example, the
|
|
||||||
- * remain-on-channel implementation requiring a channel context.
|
|
||||||
+ * @NL80211_FEATURE_P2P_DEVICE_NEEDS_CHANNEL: (no longer available, only
|
|
||||||
+ * here to reserve the value for API/ABI compatibility)
|
|
||||||
* @NL80211_FEATURE_SAE: This driver supports simultaneous authentication of
|
|
||||||
* equals (SAE) with user space SME (NL80211_CMD_AUTHENTICATE) in station
|
|
||||||
* mode
|
|
||||||
@@ -3841,6 +3950,9 @@ enum nl80211_ap_sme_features {
|
|
||||||
* interface. An active monitor interface behaves like a normal monitor
|
* interface. An active monitor interface behaves like a normal monitor
|
||||||
* interface, but gets added to the driver. It ensures that incoming
|
* interface, but gets added to the driver. It ensures that incoming
|
||||||
* unicast packets directed at the configured interface address get ACKed.
|
* unicast packets directed at the configured interface address get ACKed.
|
||||||
|
@ -304,7 +165,7 @@
|
||||||
*/
|
*/
|
||||||
enum nl80211_feature_flags {
|
enum nl80211_feature_flags {
|
||||||
NL80211_FEATURE_SK_TX_STATUS = 1 << 0,
|
NL80211_FEATURE_SK_TX_STATUS = 1 << 0,
|
||||||
@@ -3861,6 +3973,7 @@ enum nl80211_feature_flags {
|
@@ -3913,6 +3976,7 @@ enum nl80211_feature_flags {
|
||||||
NL80211_FEATURE_FULL_AP_CLIENT_STATE = 1 << 15,
|
NL80211_FEATURE_FULL_AP_CLIENT_STATE = 1 << 15,
|
||||||
NL80211_FEATURE_USERSPACE_MPM = 1 << 16,
|
NL80211_FEATURE_USERSPACE_MPM = 1 << 16,
|
||||||
NL80211_FEATURE_ACTIVE_MONITOR = 1 << 17,
|
NL80211_FEATURE_ACTIVE_MONITOR = 1 << 17,
|
||||||
|
@ -312,24 +173,3 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
/**
|
/**
|
||||||
@@ -4037,4 +4150,20 @@ struct nl80211_vendor_cmd_info {
|
|
||||||
__u32 subcmd;
|
|
||||||
};
|
|
||||||
|
|
||||||
+/**
|
|
||||||
+ * enum nl80211_tdls_peer_capability - TDLS peer flags.
|
|
||||||
+ *
|
|
||||||
+ * Used by tdls_mgmt() to determine which conditional elements need
|
|
||||||
+ * to be added to TDLS Setup frames.
|
|
||||||
+ *
|
|
||||||
+ * @NL80211_TDLS_PEER_HT: TDLS peer is HT capable.
|
|
||||||
+ * @NL80211_TDLS_PEER_VHT: TDLS peer is VHT capable.
|
|
||||||
+ * @NL80211_TDLS_PEER_WMM: TDLS peer is WMM capable.
|
|
||||||
+ */
|
|
||||||
+enum nl80211_tdls_peer_capability {
|
|
||||||
+ NL80211_TDLS_PEER_HT = 1<<0,
|
|
||||||
+ NL80211_TDLS_PEER_VHT = 1<<1,
|
|
||||||
+ NL80211_TDLS_PEER_WMM = 1<<2,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
#endif /* __LINUX_NL80211_H */
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/phy.c
|
--- a/phy.c
|
||||||
+++ b/phy.c
|
+++ b/phy.c
|
||||||
@@ -424,3 +424,31 @@ COMMAND(set, antenna, "<bitmap> | all |
|
@@ -488,3 +488,31 @@ COMMAND(set, antenna, "<bitmap> | all |
|
||||||
NL80211_CMD_SET_WIPHY, 0, CIB_PHY, handle_antenna,
|
NL80211_CMD_SET_WIPHY, 0, CIB_PHY, handle_antenna,
|
||||||
"Set a bitmap of allowed antennas to use for TX and RX.\n"
|
"Set a bitmap of allowed antennas to use for TX and RX.\n"
|
||||||
"The driver may reject antenna configurations it cannot support.");
|
"The driver may reject antenna configurations it cannot support.");
|
||||||
|
|
|
@ -13,7 +13,7 @@
|
||||||
OBJS-$(HWSIM) += hwsim.o
|
OBJS-$(HWSIM) += hwsim.o
|
||||||
--- a/info.c
|
--- a/info.c
|
||||||
+++ b/info.c
|
+++ b/info.c
|
||||||
@@ -204,6 +204,7 @@ next:
|
@@ -207,6 +207,7 @@ next:
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -21,7 +21,7 @@
|
||||||
if (tb_band[NL80211_BAND_ATTR_RATES]) {
|
if (tb_band[NL80211_BAND_ATTR_RATES]) {
|
||||||
printf("\t\tBitrates (non-HT):\n");
|
printf("\t\tBitrates (non-HT):\n");
|
||||||
nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
|
nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
|
||||||
@@ -220,6 +221,7 @@ next:
|
@@ -223,6 +224,7 @@ next:
|
||||||
printf("\n");
|
printf("\n");
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -29,7 +29,7 @@
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -254,6 +256,7 @@ next:
|
@@ -273,6 +275,7 @@ next:
|
||||||
printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
|
printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -37,7 +37,7 @@
|
||||||
if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
|
if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
|
||||||
int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
|
int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
|
||||||
int i;
|
int i;
|
||||||
@@ -265,6 +268,7 @@ next:
|
@@ -284,6 +287,7 @@ next:
|
||||||
cipher_name(ciphers[i]));
|
cipher_name(ciphers[i]));
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -45,7 +45,7 @@
|
||||||
|
|
||||||
if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
|
if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
|
||||||
tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
|
tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
|
||||||
@@ -284,11 +288,13 @@ next:
|
@@ -303,11 +307,13 @@ next:
|
||||||
printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
|
printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -59,7 +59,7 @@
|
||||||
|
|
||||||
if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
|
if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
|
||||||
struct nlattr *nl_combi;
|
struct nlattr *nl_combi;
|
||||||
@@ -385,6 +391,7 @@ broken_combination:
|
@@ -404,6 +410,7 @@ broken_combination:
|
||||||
printf("\tinterface combinations are not supported\n");
|
printf("\tinterface combinations are not supported\n");
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -67,7 +67,7 @@
|
||||||
if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
|
if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
|
||||||
printf("\tSupported commands:\n");
|
printf("\tSupported commands:\n");
|
||||||
nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
|
nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
|
||||||
@@ -477,6 +484,7 @@ broken_combination:
|
@@ -496,6 +503,7 @@ broken_combination:
|
||||||
printf("\t\t * wake up on TCP connection\n");
|
printf("\t\t * wake up on TCP connection\n");
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -75,7 +75,7 @@
|
||||||
|
|
||||||
if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
|
if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
|
||||||
printf("\tDevice supports roaming.\n");
|
printf("\tDevice supports roaming.\n");
|
||||||
@@ -513,6 +521,7 @@ broken_combination:
|
@@ -532,6 +540,7 @@ broken_combination:
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -83,7 +83,7 @@
|
||||||
if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
|
if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
|
||||||
unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
|
unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
|
||||||
|
|
||||||
@@ -533,6 +542,7 @@ broken_combination:
|
@@ -552,6 +561,7 @@ broken_combination:
|
||||||
if (features & NL80211_FEATURE_AP_SCAN)
|
if (features & NL80211_FEATURE_AP_SCAN)
|
||||||
printf("\tDevice supports AP scan.\n");
|
printf("\tDevice supports AP scan.\n");
|
||||||
}
|
}
|
||||||
|
@ -91,7 +91,7 @@
|
||||||
|
|
||||||
if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
|
if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
|
||||||
printf("\tDevice supports T-DLS.\n");
|
printf("\tDevice supports T-DLS.\n");
|
||||||
@@ -582,6 +592,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
|
@@ -601,6 +611,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
|
||||||
"List all wireless devices and their capabilities.");
|
"List all wireless devices and their capabilities.");
|
||||||
TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
|
TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
|
||||||
|
|
||||||
|
@ -99,7 +99,7 @@
|
||||||
static int handle_commands(struct nl80211_state *state,
|
static int handle_commands(struct nl80211_state *state,
|
||||||
struct nl_cb *cb, struct nl_msg *msg,
|
struct nl_cb *cb, struct nl_msg *msg,
|
||||||
int argc, char **argv, enum id_input id)
|
int argc, char **argv, enum id_input id)
|
||||||
@@ -594,6 +605,7 @@ static int handle_commands(struct nl8021
|
@@ -613,6 +624,7 @@ static int handle_commands(struct nl8021
|
||||||
}
|
}
|
||||||
TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
|
TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
|
||||||
"list all known commands and their decimal & hex value");
|
"list all known commands and their decimal & hex value");
|
||||||
|
|
Loading…
Reference in a new issue