iproute2: q_cake: Add printing of no-split-gso option
When the GSO splitting was turned into dual split-gso/no-split-gso options, the printing of the latter was left out. Add that, so output is consistent with the options passed Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
This commit is contained in:
parent
b3d441c5f7
commit
8cac857289
2 changed files with 4 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=4.18.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||
|
|
|
@ -854,7 +854,7 @@
|
|||
TCMODULES += e_bpf.o
|
||||
--- /dev/null
|
||||
+++ b/tc/q_cake.c
|
||||
@@ -0,0 +1,799 @@
|
||||
@@ -0,0 +1,801 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
|
||||
+
|
||||
+/*
|
||||
|
@ -1381,6 +1381,8 @@
|
|||
+
|
||||
+ if (split_gso)
|
||||
+ print_string(PRINT_FP, NULL, "split-gso ", NULL);
|
||||
+ else
|
||||
+ print_string(PRINT_FP, NULL, "no-split-gso ", NULL);
|
||||
+ print_bool(PRINT_JSON, "split_gso", NULL, split_gso);
|
||||
+
|
||||
+ if (interval)
|
||||
|
|
Loading…
Reference in a new issue