refresh 2.6.37 patches
SVN-Revision: 25483
This commit is contained in:
parent
d0cc86c488
commit
8b16eba876
21 changed files with 61 additions and 61 deletions
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
@@ -446,9 +446,9 @@ struct mtd_info *cfi_cmdset_0002(struct
|
@@ -446,9 +446,9 @@ struct mtd_info *cfi_cmdset_0002(struct
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* Valid primary extension versions are: 1.0, 1.1, 1.2, 1.3, 1.4
|
* Valid primary extension versions are: 1.0, 1.1, 1.2, 1.3, 1.4
|
||||||
|
|
|
@ -176,7 +176,7 @@
|
||||||
|
|
||||||
unsigned int vced_count, vcei_count;
|
unsigned int vced_count, vcei_count;
|
||||||
|
|
||||||
@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
|
@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
|
||||||
/*
|
/*
|
||||||
* For the first processor also print the system type
|
* For the first processor also print the system type
|
||||||
*/
|
*/
|
||||||
|
|
|
@ -63,7 +63,7 @@
|
||||||
htc_excalibur_s620 MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620 2391
|
htc_excalibur_s620 MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620 2391
|
||||||
htc_opal MACH_HTC_OPAL HTC_OPAL 2392
|
htc_opal MACH_HTC_OPAL HTC_OPAL 2392
|
||||||
touchbook MACH_TOUCHBOOK TOUCHBOOK 2393
|
touchbook MACH_TOUCHBOOK TOUCHBOOK 2393
|
||||||
@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
|
@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
|
||||||
siogentoo2 MACH_SIOGENTOO2 SIOGENTOO2 2459
|
siogentoo2 MACH_SIOGENTOO2 SIOGENTOO2 2459
|
||||||
sm3k MACH_SM3K SM3K 2460
|
sm3k MACH_SM3K SM3K 2460
|
||||||
acer_tempo_f900 MACH_ACER_TEMPO_F900 ACER_TEMPO_F900 2461
|
acer_tempo_f900 MACH_ACER_TEMPO_F900 ACER_TEMPO_F900 2461
|
||||||
|
|
|
@ -549,7 +549,7 @@
|
||||||
part->name = dev->mtd.name;
|
part->name = dev->mtd.name;
|
||||||
--- a/drivers/mtd/mtdchar.c
|
--- a/drivers/mtd/mtdchar.c
|
||||||
+++ b/drivers/mtd/mtdchar.c
|
+++ b/drivers/mtd/mtdchar.c
|
||||||
@@ -841,6 +841,13 @@ static int mtd_ioctl(struct file *file,
|
@@ -841,6 +841,13 @@ static int mtd_ioctl(struct file *file,
|
||||||
file->f_pos = 0;
|
file->f_pos = 0;
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||||
@@ -392,9 +392,35 @@ static struct cfi_fixup fixup_table[] =
|
@@ -392,9 +392,35 @@ static struct cfi_fixup fixup_table[] =
|
||||||
static void cfi_fixup_major_minor(struct cfi_private *cfi,
|
static void cfi_fixup_major_minor(struct cfi_private *cfi,
|
||||||
struct cfi_pri_amdstd *extp)
|
struct cfi_pri_amdstd *extp)
|
||||||
{
|
{
|
||||||
|
|
|
@ -30,7 +30,7 @@
|
||||||
depends on NETFILTER_ADVANCED
|
depends on NETFILTER_ADVANCED
|
||||||
--- a/net/netfilter/Makefile
|
--- a/net/netfilter/Makefile
|
||||||
+++ b/net/netfilter/Makefile
|
+++ b/net/netfilter/Makefile
|
||||||
@@ -95,6 +95,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
|
@@ -95,6 +95,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
|
||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
|
||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
|
||||||
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
|
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
|
||||||
|
|
|
@ -1189,7 +1189,7 @@
|
||||||
/* return EBUSY when somebody else is registered, return EEXIST if the
|
/* return EBUSY when somebody else is registered, return EEXIST if the
|
||||||
* same handler is registered, return 0 in case of success. */
|
* same handler is registered, return 0 in case of success. */
|
||||||
int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
|
int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
|
||||||
@@ -82,7 +102,7 @@ void nf_unregister_queue_handlers(const
|
@@ -82,7 +102,7 @@ void nf_unregister_queue_handlers(const
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
|
EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/arch/mips/include/asm/string.h
|
--- a/arch/mips/include/asm/string.h
|
||||||
+++ b/arch/mips/include/asm/string.h
|
+++ b/arch/mips/include/asm/string.h
|
||||||
@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
|
@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
|
||||||
|
|
||||||
#define __HAVE_ARCH_MEMSET
|
#define __HAVE_ARCH_MEMSET
|
||||||
extern void *memset(void *__s, int __c, size_t __count);
|
extern void *memset(void *__s, int __c, size_t __count);
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/include/linux/slab.h
|
--- a/include/linux/slab.h
|
||||||
+++ b/include/linux/slab.h
|
+++ b/include/linux/slab.h
|
||||||
@@ -130,8 +130,8 @@ int kmem_ptr_validate(struct kmem_cache
|
@@ -130,8 +130,8 @@ int kmem_ptr_validate(struct kmem_cache
|
||||||
* to do various tricks to work around compiler limitations in order to
|
* to do various tricks to work around compiler limitations in order to
|
||||||
* ensure proper constant folding.
|
* ensure proper constant folding.
|
||||||
*/
|
*/
|
||||||
|
|
|
@ -61,7 +61,7 @@
|
||||||
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
|
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
|
||||||
extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
|
extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
|
||||||
|
|
||||||
@@ -501,6 +505,29 @@ static inline void double_unlock(struct
|
@@ -501,6 +505,29 @@ static inline void double_unlock(struct
|
||||||
#endif /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
|
#endif /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
|
||||||
#endif /* __KERNEL__ */
|
#endif /* __KERNEL__ */
|
||||||
|
|
||||||
|
@ -127,7 +127,7 @@
|
||||||
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
|
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
|
||||||
--- a/fs/mini_fo/aux.c
|
--- a/fs/mini_fo/aux.c
|
||||||
+++ b/fs/mini_fo/aux.c
|
+++ b/fs/mini_fo/aux.c
|
||||||
@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
|
@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
|
||||||
err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
|
err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
|
||||||
|
|
||||||
/* validate */
|
/* validate */
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/fs/mini_fo/super.c
|
--- a/fs/mini_fo/super.c
|
||||||
+++ b/fs/mini_fo/super.c
|
+++ b/fs/mini_fo/super.c
|
||||||
@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
|
@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
|
||||||
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
|
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
|
||||||
|
|
||||||
|
|
||||||
|
|
|
@ -20,7 +20,7 @@
|
||||||
#else
|
#else
|
||||||
static inline int kobject_uevent(struct kobject *kobj,
|
static inline int kobject_uevent(struct kobject *kobj,
|
||||||
enum kobject_action action)
|
enum kobject_action action)
|
||||||
@@ -231,6 +237,16 @@ static inline int add_uevent_var(struct
|
@@ -231,6 +237,16 @@ static inline int add_uevent_var(struct
|
||||||
static inline int kobject_action_type(const char *buf, size_t count,
|
static inline int kobject_action_type(const char *buf, size_t count,
|
||||||
enum kobject_action *type)
|
enum kobject_action *type)
|
||||||
{ return -EINVAL; }
|
{ return -EINVAL; }
|
||||||
|
|
|
@ -11,7 +11,7 @@
|
||||||
endif # NEW_LEDS
|
endif # NEW_LEDS
|
||||||
--- a/drivers/leds/Makefile
|
--- a/drivers/leds/Makefile
|
||||||
+++ b/drivers/leds/Makefile
|
+++ b/drivers/leds/Makefile
|
||||||
@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
|
@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
|
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
|
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
||||||
|
|
|
@ -14,7 +14,7 @@
|
||||||
endif # NEW_LEDS
|
endif # NEW_LEDS
|
||||||
--- a/drivers/leds/Makefile
|
--- a/drivers/leds/Makefile
|
||||||
+++ b/drivers/leds/Makefile
|
+++ b/drivers/leds/Makefile
|
||||||
@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
|
@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
|
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
||||||
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/char/gpio_dev.c
|
--- a/drivers/char/gpio_dev.c
|
||||||
+++ b/drivers/char/gpio_dev.c
|
+++ b/drivers/char/gpio_dev.c
|
||||||
@@ -114,7 +114,7 @@ gpio_close(struct inode * inode, struct
|
@@ -114,7 +114,7 @@ gpio_close(struct inode * inode, struct
|
||||||
}
|
}
|
||||||
|
|
||||||
struct file_operations gpio_fops = {
|
struct file_operations gpio_fops = {
|
||||||
|
|
|
@ -601,7 +601,7 @@
|
||||||
dev->checkpointBlockList[i] = -1;
|
dev->checkpointBlockList[i] = -1;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
|
@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
|
||||||
|
|
||||||
static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
|
static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
|
||||||
{
|
{
|
||||||
|
@ -926,7 +926,7 @@
|
||||||
{
|
{
|
||||||
unsigned char cDelta; /* column parity delta */
|
unsigned char cDelta; /* column parity delta */
|
||||||
unsigned lDelta; /* line parity delta */
|
unsigned lDelta; /* line parity delta */
|
||||||
@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
||||||
return 0; /* no error */
|
return 0; /* no error */
|
||||||
|
|
||||||
if (lDelta == ~lDeltaPrime &&
|
if (lDelta == ~lDeltaPrime &&
|
||||||
|
@ -936,7 +936,7 @@
|
||||||
/* Single bit (recoverable) error in data */
|
/* Single bit (recoverable) error in data */
|
||||||
|
|
||||||
bit = 0;
|
bit = 0;
|
||||||
@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
||||||
if (cDelta & 0x02)
|
if (cDelta & 0x02)
|
||||||
bit |= 0x01;
|
bit |= 0x01;
|
||||||
|
|
||||||
|
@ -945,7 +945,7 @@
|
||||||
return -1;
|
return -1;
|
||||||
|
|
||||||
data[lDelta] ^= (1 << bit);
|
data[lDelta] ^= (1 << bit);
|
||||||
@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
||||||
}
|
}
|
||||||
|
|
||||||
if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
|
if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
|
||||||
|
@ -954,7 +954,7 @@
|
||||||
/* Reccoverable error in ecc */
|
/* Reccoverable error in ecc */
|
||||||
|
|
||||||
*read_ecc = *test_ecc;
|
*read_ecc = *test_ecc;
|
||||||
@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
|
@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
|
||||||
/* Unrecoverable error */
|
/* Unrecoverable error */
|
||||||
|
|
||||||
return -1;
|
return -1;
|
||||||
|
@ -1398,7 +1398,7 @@
|
||||||
{
|
{
|
||||||
unsigned char *alias;
|
unsigned char *alias;
|
||||||
int ret;
|
int ret;
|
||||||
@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
|
@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
|
||||||
return ret;
|
return ret;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1560,7 +1560,7 @@
|
||||||
static int yaffs_file_flush(struct file *file, fl_owner_t id)
|
static int yaffs_file_flush(struct file *file, fl_owner_t id)
|
||||||
#else
|
#else
|
||||||
static int yaffs_file_flush(struct file *file)
|
static int yaffs_file_flush(struct file *file)
|
||||||
@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
|
@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
|
||||||
yaffs_Device *dev = obj->myDev;
|
yaffs_Device *dev = obj->myDev;
|
||||||
|
|
||||||
T(YAFFS_TRACE_OS,
|
T(YAFFS_TRACE_OS,
|
||||||
|
@ -1571,7 +1571,7 @@
|
||||||
|
|
||||||
yaffs_GrossLock(dev);
|
yaffs_GrossLock(dev);
|
||||||
|
|
||||||
@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
|
@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
|
||||||
|
|
||||||
yaffs_Device *dev;
|
yaffs_Device *dev;
|
||||||
|
|
||||||
|
@ -1591,7 +1591,7 @@
|
||||||
BUG_ON(!PageLocked(pg));
|
BUG_ON(!PageLocked(pg));
|
||||||
#else
|
#else
|
||||||
if (!PageLocked(pg))
|
if (!PageLocked(pg))
|
||||||
@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
|
@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
|
||||||
|
|
||||||
yaffs_GrossLock(dev);
|
yaffs_GrossLock(dev);
|
||||||
|
|
||||||
|
@ -1604,7 +1604,7 @@
|
||||||
|
|
||||||
yaffs_GrossUnlock(dev);
|
yaffs_GrossUnlock(dev);
|
||||||
|
|
||||||
@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
|
@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
|
||||||
flush_dcache_page(pg);
|
flush_dcache_page(pg);
|
||||||
kunmap(pg);
|
kunmap(pg);
|
||||||
|
|
||||||
|
@ -3193,7 +3193,7 @@
|
||||||
if (n < step) {
|
if (n < step) {
|
||||||
n++;
|
n++;
|
||||||
continue;
|
continue;
|
||||||
@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
|
@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
|
||||||
char *end;
|
char *end;
|
||||||
char *mask_name;
|
char *mask_name;
|
||||||
const char *x;
|
const char *x;
|
||||||
|
@ -3202,7 +3202,7 @@
|
||||||
int i;
|
int i;
|
||||||
int done = 0;
|
int done = 0;
|
||||||
int add, len = 0;
|
int add, len = 0;
|
||||||
@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
|
@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
|
||||||
|
|
||||||
while (!done && (pos < count)) {
|
while (!done && (pos < count)) {
|
||||||
done = 1;
|
done = 1;
|
||||||
|
@ -3213,7 +3213,7 @@
|
||||||
|
|
||||||
switch (buf[pos]) {
|
switch (buf[pos]) {
|
||||||
case '+':
|
case '+':
|
||||||
@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
|
@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
|
||||||
mask_name = NULL;
|
mask_name = NULL;
|
||||||
|
|
||||||
mask_bitfield = simple_strtoul(buf + pos, &end, 0);
|
mask_bitfield = simple_strtoul(buf + pos, &end, 0);
|
||||||
|
@ -3240,7 +3240,7 @@
|
||||||
mask_name = mask_flags[i].mask_name;
|
mask_name = mask_flags[i].mask_name;
|
||||||
mask_bitfield = mask_flags[i].mask_bitfield;
|
mask_bitfield = mask_flags[i].mask_bitfield;
|
||||||
done = 0;
|
done = 0;
|
||||||
@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
|
@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
|
||||||
|
|
||||||
if (mask_name != NULL) {
|
if (mask_name != NULL) {
|
||||||
done = 0;
|
done = 0;
|
||||||
|
@ -3249,7 +3249,7 @@
|
||||||
case '-':
|
case '-':
|
||||||
rg &= ~mask_bitfield;
|
rg &= ~mask_bitfield;
|
||||||
break;
|
break;
|
||||||
@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
|
@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
|
||||||
|
|
||||||
yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
|
yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
|
||||||
|
|
||||||
|
@ -5691,7 +5691,7 @@
|
||||||
{
|
{
|
||||||
/* Get the real object in case we were fed a hard link as an equivalent object */
|
/* Get the real object in case we were fed a hard link as an equivalent object */
|
||||||
equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
|
equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
|
||||||
@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
|
@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
|
||||||
|
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -7622,7 +7622,7 @@
|
||||||
int nToCopy;
|
int nToCopy;
|
||||||
int n = nBytes;
|
int n = nBytes;
|
||||||
int nDone = 0;
|
int nDone = 0;
|
||||||
@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
||||||
dev = in->myDev;
|
dev = in->myDev;
|
||||||
|
|
||||||
while (n > 0) {
|
while (n > 0) {
|
||||||
|
@ -7657,7 +7657,7 @@
|
||||||
if (dev->nShortOpCaches > 0) {
|
if (dev->nShortOpCaches > 0) {
|
||||||
|
|
||||||
/* If we can't find the data in the cache, then load it up. */
|
/* If we can't find the data in the cache, then load it up. */
|
||||||
@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
||||||
|
|
||||||
cache->locked = 1;
|
cache->locked = 1;
|
||||||
|
|
||||||
|
@ -7673,7 +7673,7 @@
|
||||||
cache->locked = 0;
|
cache->locked = 0;
|
||||||
} else {
|
} else {
|
||||||
/* Read into the local buffer then copy..*/
|
/* Read into the local buffer then copy..*/
|
||||||
@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
||||||
yaffs_GetTempBuffer(dev, __LINE__);
|
yaffs_GetTempBuffer(dev, __LINE__);
|
||||||
yaffs_ReadChunkDataFromObject(in, chunk,
|
yaffs_ReadChunkDataFromObject(in, chunk,
|
||||||
localBuffer);
|
localBuffer);
|
||||||
|
@ -7718,7 +7718,7 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
n -= nToCopy;
|
n -= nToCopy;
|
||||||
@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
|
||||||
return nDone;
|
return nDone;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -7923,7 +7923,7 @@
|
||||||
int newFullChunks;
|
int newFullChunks;
|
||||||
|
|
||||||
yaffs_Device *dev = in->myDev;
|
yaffs_Device *dev = in->myDev;
|
||||||
@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
|
@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
|
||||||
|
|
||||||
yaffs_CheckGarbageCollection(dev);
|
yaffs_CheckGarbageCollection(dev);
|
||||||
|
|
||||||
|
@ -7941,7 +7941,7 @@
|
||||||
|
|
||||||
if (newSize < oldFileSize) {
|
if (newSize < oldFileSize) {
|
||||||
|
|
||||||
@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
|
@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
|
@ -7968,7 +7968,7 @@
|
||||||
{
|
{
|
||||||
obj = yaffs_GetEquivalentObject(obj);
|
obj = yaffs_GetEquivalentObject(obj);
|
||||||
|
|
||||||
@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
|
@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -9789,7 +9789,7 @@
|
||||||
{
|
{
|
||||||
int init_failed = 0;
|
int init_failed = 0;
|
||||||
unsigned x;
|
unsigned x;
|
||||||
@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
dev->chunkOffset = 0;
|
dev->chunkOffset = 0;
|
||||||
dev->nFreeChunks = 0;
|
dev->nFreeChunks = 0;
|
||||||
|
|
||||||
|
@ -9798,7 +9798,7 @@
|
||||||
if (dev->startBlock == 0) {
|
if (dev->startBlock == 0) {
|
||||||
dev->internalStartBlock = dev->startBlock + 1;
|
dev->internalStartBlock = dev->startBlock + 1;
|
||||||
dev->internalEndBlock = dev->endBlock + 1;
|
dev->internalEndBlock = dev->endBlock + 1;
|
||||||
@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
|
|
||||||
/* Check geometry parameters. */
|
/* Check geometry parameters. */
|
||||||
|
|
||||||
|
@ -9823,7 +9823,7 @@
|
||||||
return YAFFS_FAIL;
|
return YAFFS_FAIL;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
return YAFFS_FAIL;
|
return YAFFS_FAIL;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -9836,7 +9836,7 @@
|
||||||
/* Got the right mix of functions? */
|
/* Got the right mix of functions? */
|
||||||
if (!yaffs_CheckDevFunctions(dev)) {
|
if (!yaffs_CheckDevFunctions(dev)) {
|
||||||
/* Function missing */
|
/* Function missing */
|
||||||
@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
|
|
||||||
dev->isMounted = 1;
|
dev->isMounted = 1;
|
||||||
|
|
||||||
|
@ -9875,7 +9875,7 @@
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* Calculate chunkGroupBits.
|
* Calculate chunkGroupBits.
|
||||||
@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
bits = ShiftsGE(x);
|
bits = ShiftsGE(x);
|
||||||
|
|
||||||
/* Set up tnode width if wide tnodes are enabled. */
|
/* Set up tnode width if wide tnodes are enabled. */
|
||||||
|
@ -9896,7 +9896,7 @@
|
||||||
dev->tnodeWidth = 16;
|
dev->tnodeWidth = 16;
|
||||||
|
|
||||||
dev->tnodeMask = (1<<dev->tnodeWidth)-1;
|
dev->tnodeMask = (1<<dev->tnodeWidth)-1;
|
||||||
@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
|
dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
|
||||||
|
|
||||||
/* Initialise temporary buffers and caches. */
|
/* Initialise temporary buffers and caches. */
|
||||||
|
@ -9905,7 +9905,7 @@
|
||||||
init_failed = 1;
|
init_failed = 1;
|
||||||
|
|
||||||
dev->srCache = NULL;
|
dev->srCache = NULL;
|
||||||
@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
if (!init_failed &&
|
if (!init_failed &&
|
||||||
dev->nShortOpCaches > 0) {
|
dev->nShortOpCaches > 0) {
|
||||||
int i;
|
int i;
|
||||||
|
@ -9940,7 +9940,7 @@
|
||||||
init_failed = 1;
|
init_failed = 1;
|
||||||
|
|
||||||
dev->srLastUse = 0;
|
dev->srLastUse = 0;
|
||||||
@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
|
|
||||||
dev->cacheHits = 0;
|
dev->cacheHits = 0;
|
||||||
|
|
||||||
|
@ -9979,7 +9979,7 @@
|
||||||
T(YAFFS_TRACE_ALWAYS,
|
T(YAFFS_TRACE_ALWAYS,
|
||||||
(TSTR("yaffs: restored from checkpoint" TENDSTR)));
|
(TSTR("yaffs: restored from checkpoint" TENDSTR)));
|
||||||
} else {
|
} else {
|
||||||
@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
dev->nBackgroundDeletions = 0;
|
dev->nBackgroundDeletions = 0;
|
||||||
dev->oldestDirtySequence = 0;
|
dev->oldestDirtySequence = 0;
|
||||||
|
|
||||||
|
@ -10011,7 +10011,7 @@
|
||||||
/* Clean up the mess */
|
/* Clean up the mess */
|
||||||
T(YAFFS_TRACE_TRACING,
|
T(YAFFS_TRACE_TRACING,
|
||||||
(TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
|
(TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
|
||||||
@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
|
@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
|
||||||
|
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -10710,7 +10710,7 @@
|
||||||
{
|
{
|
||||||
if (etags) {
|
if (etags) {
|
||||||
memset(etags, 0, sizeof(*etags));
|
memset(etags, 0, sizeof(*etags));
|
||||||
@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
|
@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
|
||||||
* Returns YAFFS_OK or YAFFS_FAIL.
|
* Returns YAFFS_OK or YAFFS_FAIL.
|
||||||
*/
|
*/
|
||||||
int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
|
int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
|
||||||
|
@ -11038,14 +11038,14 @@
|
||||||
+ yaffs_UnpackTags2(tags, &pt);
|
+ yaffs_UnpackTags2(tags, &pt);
|
||||||
+ }
|
+ }
|
||||||
+ }
|
+ }
|
||||||
|
+
|
||||||
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
|
||||||
- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
|
||||||
+ if (localData)
|
+ if (localData)
|
||||||
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
|
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
|
||||||
|
|
||||||
|
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||||
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||||
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
||||||
|
-
|
||||||
if (retval == 0)
|
if (retval == 0)
|
||||||
return YAFFS_OK;
|
return YAFFS_OK;
|
||||||
else
|
else
|
||||||
|
|
|
@ -316,7 +316,7 @@
|
||||||
chunk/page state. This byte is zeroed when the page is discarded.
|
chunk/page state. This byte is zeroed when the page is discarded.
|
||||||
Choose this option if you have existing on-NAND data in this format
|
Choose this option if you have existing on-NAND data in this format
|
||||||
that you need to continue to support. New data written also uses the
|
that you need to continue to support. New data written also uses the
|
||||||
@@ -57,7 +78,7 @@ adjusted to use the older-style format.
|
@@ -57,7 +78,7 @@ adjusted to use the older-style format.
|
||||||
MTD versions in yaffs_mtdif1.c.
|
MTD versions in yaffs_mtdif1.c.
|
||||||
*/
|
*/
|
||||||
/* Default: Not selected */
|
/* Default: Not selected */
|
||||||
|
@ -1614,7 +1614,7 @@
|
||||||
yaffs_ECCOther *read_ecc,
|
yaffs_ECCOther *read_ecc,
|
||||||
const yaffs_ECCOther *test_ecc)
|
const yaffs_ECCOther *test_ecc)
|
||||||
{
|
{
|
||||||
@@ -304,7 +301,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
@@ -304,7 +301,7 @@ int yaffs_ECCCorrectOther(unsigned char
|
||||||
if (cDelta & 0x02)
|
if (cDelta & 0x02)
|
||||||
bit |= 0x01;
|
bit |= 0x01;
|
||||||
|
|
||||||
|
@ -1623,7 +1623,7 @@
|
||||||
return -1;
|
return -1;
|
||||||
|
|
||||||
data[lDelta] ^= (1 << bit);
|
data[lDelta] ^= (1 << bit);
|
||||||
@@ -312,8 +309,8 @@ int yaffs_ECCCorrectOther(unsigned char
|
@@ -312,8 +309,8 @@ int yaffs_ECCCorrectOther(unsigned char
|
||||||
return 1; /* corrected */
|
return 1; /* corrected */
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/drivers/net/wireless/hostap/hostap_ap.c
|
--- a/drivers/net/wireless/hostap/hostap_ap.c
|
||||||
+++ b/drivers/net/wireless/hostap/hostap_ap.c
|
+++ b/drivers/net/wireless/hostap/hostap_ap.c
|
||||||
@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t
|
@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t
|
||||||
addr[count].sa_family = ARPHRD_ETHER;
|
addr[count].sa_family = ARPHRD_ETHER;
|
||||||
memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
|
memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
|
||||||
if (sta->last_rx_silence == 0)
|
if (sta->last_rx_silence == 0)
|
||||||
|
|
|
@ -829,7 +829,7 @@
|
||||||
+be done automatically.
|
+be done automatically.
|
||||||
--- a/MAINTAINERS
|
--- a/MAINTAINERS
|
||||||
+++ b/MAINTAINERS
|
+++ b/MAINTAINERS
|
||||||
@@ -2708,6 +2708,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
@@ -2723,6 +2723,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||||
S: Maintained
|
S: Maintained
|
||||||
F: drivers/media/video/gspca/
|
F: drivers/media/video/gspca/
|
||||||
|
|
||||||
|
|
|
@ -24,7 +24,7 @@
|
||||||
* All of these routines try to estimate how many bits of randomness a
|
* All of these routines try to estimate how many bits of randomness a
|
||||||
* particular randomness source. They do this by keeping track of the
|
* particular randomness source. They do this by keeping track of the
|
||||||
* first and second order deltas of the event timings.
|
* first and second order deltas of the event timings.
|
||||||
@@ -715,6 +725,61 @@ void add_disk_randomness(struct gendisk
|
@@ -715,6 +725,61 @@ void add_disk_randomness(struct gendisk
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/scripts/Makefile.lib
|
--- a/scripts/Makefile.lib
|
||||||
+++ b/scripts/Makefile.lib
|
+++ b/scripts/Makefile.lib
|
||||||
@@ -231,7 +231,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
@@ -231,7 +231,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
||||||
|
|
||||||
quiet_cmd_lzma = LZMA $@
|
quiet_cmd_lzma = LZMA $@
|
||||||
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
||||||
|
|
Loading…
Reference in a new issue