ar71xx: add missing WZR-450HP2 patch from r43026 for 3.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43175
This commit is contained in:
parent
9a2cf10c33
commit
8acf9adf28
1 changed files with 39 additions and 0 deletions
|
@ -0,0 +1,39 @@
|
||||||
|
--- a/arch/mips/ath79/Kconfig
|
||||||
|
+++ b/arch/mips/ath79/Kconfig
|
||||||
|
@@ -263,6 +263,16 @@ config ATH79_MACH_WZR_HP_G450H
|
||||||
|
select ATH79_DEV_M25P80
|
||||||
|
select ATH79_DEV_USB
|
||||||
|
|
||||||
|
+config ATH79_MACH_WZR_450HP2
|
||||||
|
+ bool "Buffalo WZR-450HP2 board support"
|
||||||
|
+ select SOC_QCA955X
|
||||||
|
+ select ATH79_DEV_ETH
|
||||||
|
+ select ATH79_DEV_GPIO_BUTTONS
|
||||||
|
+ select ATH79_DEV_LEDS_GPIO
|
||||||
|
+ select ATH79_DEV_M25P80
|
||||||
|
+ select ATH79_DEV_USB
|
||||||
|
+ select ATH79_DEV_WMAC
|
||||||
|
+
|
||||||
|
config ATH79_MACH_WP543
|
||||||
|
bool "Compex WP543/WPJ543 board support"
|
||||||
|
select SOC_AR71XX
|
||||||
|
--- a/arch/mips/ath79/Makefile
|
||||||
|
+++ b/arch/mips/ath79/Makefile
|
||||||
|
@@ -140,6 +140,7 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH) +
|
||||||
|
obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
|
||||||
|
+obj-$(CONFIG_ATH79_MACH_WZR_450HP2) += mach-wzr-450hp2.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_CARAMBOLA2) += mach-carambola2.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_NBG6716) += mach-nbg6716.o
|
||||||
|
--- a/arch/mips/ath79/machtypes.h
|
||||||
|
+++ b/arch/mips/ath79/machtypes.h
|
||||||
|
@@ -183,6 +183,7 @@ enum ath79_mach_type {
|
||||||
|
ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
|
||||||
|
ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */
|
||||||
|
ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */
|
||||||
|
+ ATH79_MACH_WZR_450HP2, /* Buffalo WZR-450HP2 */
|
||||||
|
ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */
|
||||||
|
ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
|
||||||
|
};
|
Loading…
Reference in a new issue