tools: update patch to v2.7.6
Removes a redundant patch with a fix already upstream. Build tested on apm821xx (PPC). Signed-off-by: Russell Senior <russell@personaltelco.net>
This commit is contained in:
parent
e2ec3f7550
commit
89a0fed2a2
2 changed files with 2 additions and 27 deletions
|
@ -7,11 +7,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=patch
|
PKG_NAME:=patch
|
||||||
PKG_VERSION:=2.7.5
|
PKG_VERSION:=2.7.6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/patch
|
PKG_SOURCE_URL:=@GNU/patch
|
||||||
PKG_HASH:=fd95153655d6b95567e623843a0e77b81612d502ecf78a489a4aed7867caa299
|
PKG_HASH:=ac610bda97abe0d9f6b7c963255a11dcb196c25e337c61f94e4778d632f1d8fd
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL := 1
|
HOST_BUILD_PARALLEL := 1
|
||||||
|
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
--- a/lib/vasnprintf.c
|
|
||||||
+++ b/lib/vasnprintf.c
|
|
||||||
@@ -4858,7 +4858,11 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *
|
|
||||||
#endif
|
|
||||||
*fbp = dp->conversion;
|
|
||||||
#if USE_SNPRINTF
|
|
||||||
-# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
|
|
||||||
+# if ! (((__GLIBC__ > 2 \
|
|
||||||
+ || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) \
|
|
||||||
+ && !defined __UCLIBC__) \
|
|
||||||
+ || (defined __APPLE__ && defined __MACH__) \
|
|
||||||
+ || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
|
|
||||||
fbp[1] = '%';
|
|
||||||
fbp[2] = 'n';
|
|
||||||
fbp[3] = '\0';
|
|
||||||
@@ -4872,6 +4876,9 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *
|
|
||||||
in format strings in writable memory may crash the program
|
|
||||||
(if compiled with _FORTIFY_SOURCE=2), so we should avoid it
|
|
||||||
in this situation. */
|
|
||||||
+ /* macOS 10.13 High Sierra behaves like glibc with
|
|
||||||
+ _FORTIFY_SOURCE=2, and older macOS releases
|
|
||||||
+ presumably do not need %n. */
|
|
||||||
/* On native Windows systems (such as mingw), we can avoid using
|
|
||||||
%n because:
|
|
||||||
- Although the gl_SNPRINTF_TRUNCATION_C99 test fails,
|
|
Loading…
Reference in a new issue