network/utils/curl: Update to 7.54.0
Update curl to 7.54.0 Update and fresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
4b0a2ca9a4
commit
89807b627f
3 changed files with 16 additions and 16 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=curl
|
||||
PKG_VERSION:=7.53.1
|
||||
PKG_VERSION:=7.54.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
|||
http://curl.mirror.anstey.ca/ \
|
||||
http://curl.askapache.com/download/ \
|
||||
https://curl.haxx.se/download/
|
||||
PKG_HASH:=1c7207c06d75e9136a944a2e0528337ce76f15b9ec9ae4bb30d703b59bf530e8
|
||||
PKG_HASH:=f50ebaf43c507fa7cc32be4b8108fa8bbd0f5022e90794388f3c7694a302ff06
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -152,7 +152,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
||||
@@ -154,8 +154,8 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
||||
|
||||
bin_SCRIPTS = curl-config
|
||||
|
||||
SUBDIRS = lib src include
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
|
||||
-SUBDIRS = lib docs src include
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests packages scripts
|
||||
+SUBDIRS = lib src include
|
||||
+DIST_SUBDIRS = $(SUBDIRS) packages
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libcurl.pc
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -612,7 +612,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
||||
@@ -272,7 +272,7 @@ cygwinbin:
|
||||
# We extend the standard install with a custom hook:
|
||||
install-data-hook:
|
||||
cd include && $(MAKE) install
|
||||
- cd docs && $(MAKE) install
|
||||
+# cd docs && $(MAKE) install
|
||||
|
||||
bin_SCRIPTS = curl-config
|
||||
SUBDIRS = lib src include
|
||||
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
|
||||
+DIST_SUBDIRS = $(SUBDIRS) packages
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libcurl.pc
|
||||
LIB_VAUTH_CFILES = vauth/vauth.c vauth/cleartext.c vauth/cram.c \
|
||||
# We extend the standard uninstall with a custom hook:
|
||||
uninstall-hook:
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/vtls/mbedtls.c
|
||||
+++ b/lib/vtls/mbedtls.c
|
||||
@@ -729,7 +729,7 @@ void Curl_mbedtls_session_free(void *ptr
|
||||
@@ -791,7 +791,7 @@ void Curl_mbedtls_session_free(void *ptr
|
||||
|
||||
size_t Curl_mbedtls_version(char *buffer, size_t size)
|
||||
{
|
||||
|
|
Loading…
Reference in a new issue