brcm63xx: Add DT support for RG100A
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43360
This commit is contained in:
parent
13d6fa0081
commit
89000dea4c
4 changed files with 50 additions and 13 deletions
30
target/linux/brcm63xx/dts/rg100a.dts
Normal file
30
target/linux/brcm63xx/dts/rg100a.dts
Normal file
|
@ -0,0 +1,30 @@
|
|||
/dts-v1/;
|
||||
|
||||
/include/ "bcm6358.dtsi"
|
||||
|
||||
/ {
|
||||
model = "Alcatel RG100A";
|
||||
compatible = "alcatel,rg100a", "brcm,bcm6358";
|
||||
};
|
||||
|
||||
&pflash {
|
||||
status = "ok";
|
||||
|
||||
linux,part-probe = "bcm63xxpart";
|
||||
|
||||
cfe@0 {
|
||||
label = "CFE";
|
||||
reg = <0x000000 0x020000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
linux@20000 {
|
||||
label = "linux";
|
||||
reg = <0x020000 0xfc0000>;
|
||||
};
|
||||
|
||||
nvram@fe0000 {
|
||||
label = "nvram";
|
||||
reg = <0xfe0000 0x020000>;
|
||||
};
|
||||
};
|
|
@ -71,15 +71,6 @@ define Image/Build/ZYXCFEDTB
|
|||
rm -f $(BIN_DIR)/openwrt-$(5)-$(1).tmp
|
||||
endef
|
||||
|
||||
define Image/Build/RG100A
|
||||
# Generate the tagged image
|
||||
$(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
|
||||
--output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
|
||||
--boardid $(2) --chipid $(3) --entry $(LOADADDR) \
|
||||
--load-addr $(LOADADDR) --block-size 0x20000 \
|
||||
--image-offset $(4) --info1 "-$(call Image/LimitName16,$(5))" --info2 $(1)
|
||||
endef
|
||||
|
||||
define Image/Build/RedBoot
|
||||
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(1)-vmlinux.elf
|
||||
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
|
||||
|
@ -279,9 +270,6 @@ define Image/Build
|
|||
# Inventel Livebox
|
||||
$(call Image/Build/RedBoot,livebox)
|
||||
|
||||
# RG100A,DB120 etc.
|
||||
$(call Image/Build/RG100A,$(1),96358VW2,6358,0x20000,RG100A_DB120)
|
||||
|
||||
# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
|
||||
$(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
|
||||
|
||||
|
@ -336,6 +324,8 @@ $(eval $(call CfeImageDTB,96368MVWG,bcm96368MVWG,96368MVWG,6368,96368MVWG-generi
|
|||
$(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
|
||||
# ADB P.DG A4001N1
|
||||
$(eval $(call CfeImageDTB,A4001N1,a4001n1,963281T_TEF,6328,A4001N1,,--pad 8))
|
||||
# Alcatel RG100A
|
||||
$(eval $(call CfeImageDTB,RG100A,rg100a,96358VW2,6358,RG100A,,--block-size 0x20000 --image-offset 0x20000))
|
||||
# Asmax AR 1004g
|
||||
$(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
|
||||
# Comtrend AR-5381u
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
|
||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
@@ -736,6 +736,42 @@ static const struct board_info __initcon
|
||||
@@ -736,6 +736,43 @@ static const struct board_info __initcon
|
||||
};
|
||||
|
||||
static struct of_device_id const bcm963xx_boards_dt[] = {
|
||||
|
@ -41,6 +41,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
|
||||
+#endif
|
||||
+#ifdef CONFIG_BCM63XX_CPU_6358
|
||||
+ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
|
||||
+ { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
|
||||
+ { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
|
||||
+ { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
|
||||
|
|
16
target/linux/brcm63xx/profiles/alcatel.mk
Normal file
16
target/linux/brcm63xx/profiles/alcatel.mk
Normal file
|
@ -0,0 +1,16 @@
|
|||
#
|
||||
# Copyright (C) 2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
define Profile/RG100A
|
||||
NAME:=Alcatel RG100A
|
||||
PACKAGES:=kmod-b43 wpad-mini\
|
||||
kmod-usb2 kmod-usb-ohci
|
||||
endef
|
||||
define Profile/RG100A/Description
|
||||
Package set optimized for RG100A.
|
||||
endef
|
||||
$(eval $(call Profile,RG100A))
|
Loading…
Reference in a new issue