kernel: bump to 4.4.40

Refresh patches on all 4.4 supported platforms.
Compile & run tested: lantiq/xrx200

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
Hauke Mehrtens 2017-01-06 13:53:27 +01:00
parent b9857b21c2
commit 88ca6390ea
24 changed files with 48 additions and 153 deletions

View file

@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43 LINUX_VERSION-3.18 = .43
LINUX_VERSION-4.1 = .34 LINUX_VERSION-4.1 = .34
LINUX_VERSION-4.4 = .39 LINUX_VERSION-4.4 = .40
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
LINUX_KERNEL_HASH-4.1.34 = 412316b32b5c7a513ba3ab8e68fc443db4d9423f07b577473089def0ee7406af LINUX_KERNEL_HASH-4.1.34 = 412316b32b5c7a513ba3ab8e68fc443db4d9423f07b577473089def0ee7406af
LINUX_KERNEL_HASH-4.4.39 = 864bc186b02bf62974676efa282eda775fe12e5729a3416cfe4b17f0c59111a1 LINUX_KERNEL_HASH-4.4.40 = c4bc5ed6e73ed7393cc1b3714b822664224ab866db114eed663de1315718a4e1
ifdef KERNEL_PATCHVER ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER))) LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))

View file

@ -659,7 +659,7 @@ dwc_otg: Remove duplicate gadget probe/unregister function
} }
--- a/drivers/usb/core/hub.c --- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c +++ b/drivers/usb/core/hub.c
@@ -4972,7 +4972,7 @@ static void port_event(struct usb_hub *h @@ -4943,7 +4943,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) { if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused; u16 status = 0, unused;

View file

@ -8,11 +8,9 @@ See: https://github.com/raspberrypi/linux/issues/1054
drivers/spi/spidev.c | 1 + drivers/spi/spidev.c | 1 +
1 file changed, 1 insertion(+) 1 file changed, 1 insertion(+)
Index: linux-4.4.39/drivers/spi/spidev.c --- a/drivers/spi/spidev.c
=================================================================== +++ b/drivers/spi/spidev.c
--- linux-4.4.39.orig/drivers/spi/spidev.c 2016-12-20 13:45:27.000000000 +0100 @@ -696,6 +696,7 @@ static const struct of_device_id spidev_
+++ linux-4.4.39/drivers/spi/spidev.c 2016-12-20 13:46:06.627326840 +0100
@@ -696,6 +696,7 @@
{ .compatible = "rohm,dh2228fv" }, { .compatible = "rohm,dh2228fv" },
{ .compatible = "lineartechnology,ltc2488" }, { .compatible = "lineartechnology,ltc2488" },
{ .compatible = "siliconlabs,si3210" }, { .compatible = "siliconlabs,si3210" },

View file

@ -15,8 +15,6 @@ Tested-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
drivers/mtd/spi-nor/spi-nor.c | 7 +++++-- drivers/mtd/spi-nor/spi-nor.c | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-) 1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/mtd/spi-nor/spi-nor.c b/drivers/mtd/spi-nor/spi-nor.c
index 72d87c2..d1edafc 100644
--- a/drivers/mtd/spi-nor/spi-nor.c --- a/drivers/mtd/spi-nor/spi-nor.c
+++ b/drivers/mtd/spi-nor/spi-nor.c +++ b/drivers/mtd/spi-nor/spi-nor.c
@@ -68,6 +68,7 @@ struct flash_info { @@ -68,6 +68,7 @@ struct flash_info {

View file

@ -3,8 +3,8 @@ Several device in ramips have this binding in the dts
Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com> Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
--- ---
--- a/drivers/spi/spidev.c 2016-12-11 09:43:30.502270523 +0100 --- a/drivers/spi/spidev.c
+++ b/drivers/spi/spidev.c 2016-12-11 09:45:54.688430012 +0100 +++ b/drivers/spi/spidev.c
@@ -695,6 +695,7 @@ static struct class *spidev_class; @@ -695,6 +695,7 @@ static struct class *spidev_class;
static const struct of_device_id spidev_dt_ids[] = { static const struct of_device_id spidev_dt_ids[] = {
{ .compatible = "rohm,dh2228fv" }, { .compatible = "rohm,dh2228fv" },

View file

@ -9,8 +9,6 @@ Acked-by: Marek Vasut <marek.vasut@gmail.com>
drivers/mtd/spi-nor/spi-nor.c | 2 +- drivers/mtd/spi-nor/spi-nor.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/mtd/spi-nor/spi-nor.c b/drivers/mtd/spi-nor/spi-nor.c
index da7cd69..f325925 100644
--- a/drivers/mtd/spi-nor/spi-nor.c --- a/drivers/mtd/spi-nor/spi-nor.c
+++ b/drivers/mtd/spi-nor/spi-nor.c +++ b/drivers/mtd/spi-nor/spi-nor.c
@@ -689,7 +689,7 @@ static const struct flash_info spi_nor_i @@ -689,7 +689,7 @@ static const struct flash_info spi_nor_i

View file

@ -21,15 +21,15 @@
partition@100000 { partition@100000 {
- label = "zImage"; - label = "zImage";
- reg = <0x100000 0x300000>; - reg = <0x100000 0x300000>;
- };
-
- partition@540000 {
- label = "initrd";
- reg = <0x540000 0x300000>;
+ label = "second stage u-boot"; + label = "second stage u-boot";
+ reg = <0x100000 0x200000>; + reg = <0x100000 0x200000>;
}; };
- partition@540000 {
- label = "initrd";
- reg = <0x540000 0x300000>;
- };
-
- partition@980000 { - partition@980000 {
- label = "boot"; - label = "boot";
- reg = <0x980000 0x1f400000>; - reg = <0x980000 0x1f400000>;

View file

@ -12,8 +12,6 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
arch/arm64/configs/freescale.config | 1 - arch/arm64/configs/freescale.config | 1 -
1 file changed, 1 deletion(-) 1 file changed, 1 deletion(-)
diff --git a/arch/arm64/configs/freescale.config b/arch/arm64/configs/freescale.config
index a31951c..5447d7a 100644
--- a/arch/arm64/configs/freescale.config --- a/arch/arm64/configs/freescale.config
+++ b/arch/arm64/configs/freescale.config +++ b/arch/arm64/configs/freescale.config
@@ -121,7 +121,6 @@ CONFIG_IMX2_WDT=y @@ -121,7 +121,6 @@ CONFIG_IMX2_WDT=y
@ -24,6 +22,3 @@ index a31951c..5447d7a 100644
# lpuart # lpuart
CONFIG_SERIAL_FSL_LPUART=y CONFIG_SERIAL_FSL_LPUART=y
CONFIG_SERIAL_FSL_LPUART_CONSOLE=y CONFIG_SERIAL_FSL_LPUART_CONSOLE=y
--
1.7.9.5

View file

@ -17,11 +17,9 @@ Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
drivers/mtd/maps/physmap_of.c | 46 ++++++++++++++++++++++++++++++++++++++++- drivers/mtd/maps/physmap_of.c | 46 ++++++++++++++++++++++++++++++++++++++++-
1 file changed, 45 insertions(+), 1 deletion(-) 1 file changed, 45 insertions(+), 1 deletion(-)
diff --git a/drivers/mtd/maps/physmap_of.c b/drivers/mtd/maps/physmap_of.c
index fef1d1b..e46b4e9 100644
--- a/drivers/mtd/maps/physmap_of.c --- a/drivers/mtd/maps/physmap_of.c
+++ b/drivers/mtd/maps/physmap_of.c +++ b/drivers/mtd/maps/physmap_of.c
@@ -112,9 +112,47 @@ static struct mtd_info *obsolete_probe(struct platform_device *dev, @@ -112,9 +112,47 @@ static struct mtd_info *obsolete_probe(s
static const char * const part_probe_types_def[] = { static const char * const part_probe_types_def[] = {
"cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL }; "cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL };
@ -69,7 +67,7 @@ index fef1d1b..e46b4e9 100644
const struct of_device_id *match; const struct of_device_id *match;
struct device_node *dp = dev->dev.of_node; struct device_node *dp = dev->dev.of_node;
struct resource res; struct resource res;
@@ -273,8 +311,14 @@ static int of_flash_probe(struct platform_device *dev) @@ -273,8 +311,14 @@ static int of_flash_probe(struct platfor
goto err_out; goto err_out;
ppdata.of_node = dp; ppdata.of_node = dp;
@ -85,6 +83,3 @@ index fef1d1b..e46b4e9 100644
kfree(mtd_list); kfree(mtd_list);
--
1.7.9.5

View file

@ -41,4 +41,3 @@ Integrated-by: Jiang Yutang <yutang.jiang@nxp.com>
}; };
pcie@3400000 { pcie@3400000 {

View file

@ -14,11 +14,9 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
diff --git a/arch/arm64/boot/dts/freescale/Makefile b/arch/arm64/boot/dts/freescale/Makefile
index b599645..e6c2a9f 100644
--- a/arch/arm64/boot/dts/freescale/Makefile --- a/arch/arm64/boot/dts/freescale/Makefile
+++ b/arch/arm64/boot/dts/freescale/Makefile +++ b/arch/arm64/boot/dts/freescale/Makefile
@@ -6,6 +6,8 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-rdb.dtb @@ -6,6 +6,8 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frdm.dtb dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frdm.dtb
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1046a-rdb.dtb dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1046a-rdb.dtb
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1088a-rdb.dtb dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1088a-rdb.dtb
@ -27,9 +25,6 @@ index b599645..e6c2a9f 100644
always := $(dtb-y) always := $(dtb-y)
subdir-y := $(dts-dirs) subdir-y := $(dts-dirs)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts b/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts
new file mode 100644
index 0000000..04d3726
--- /dev/null --- /dev/null
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts +++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts
@@ -0,0 +1,241 @@ @@ -0,0 +1,241 @@
@ -274,9 +269,6 @@ index 0000000..04d3726
+&dpmac12 { +&dpmac12 {
+ phy-handle = <&mdio0_phy15>; + phy-handle = <&mdio0_phy15>;
+}; +};
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts b/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts
new file mode 100644
index 0000000..ce553fb
--- /dev/null --- /dev/null
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts +++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts
@@ -0,0 +1,207 @@ @@ -0,0 +1,207 @@
@ -487,9 +479,6 @@ index 0000000..ce553fb
+&dpmac8 { +&dpmac8 {
+ phy-handle = <&mdio2_phy4>; + phy-handle = <&mdio2_phy4>;
+}; +};
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
new file mode 100644
index 0000000..bd69942
--- /dev/null --- /dev/null
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi +++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
@@ -0,0 +1,854 @@ @@ -0,0 +1,854 @@
@ -1347,6 +1336,3 @@ index 0000000..bd69942
+ /* DRAM space 1 - 2 GB DRAM */ + /* DRAM space 1 - 2 GB DRAM */
+ }; + };
+}; +};
--
1.7.9.5

View file

@ -11,9 +11,6 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
create mode 100644 kernel2088a-qds.its create mode 100644 kernel2088a-qds.its
create mode 100644 kernel2088a-rdb.its create mode 100644 kernel2088a-rdb.its
diff --git a/kernel2088a-qds.its b/kernel2088a-qds.its
new file mode 100644
index 0000000..4732954
--- /dev/null --- /dev/null
+++ b/kernel2088a-qds.its +++ b/kernel2088a-qds.its
@@ -0,0 +1,55 @@ @@ -0,0 +1,55 @@
@ -72,9 +69,6 @@ index 0000000..4732954
+ }; + };
+ }; + };
+}; +};
diff --git a/kernel2088a-rdb.its b/kernel2088a-rdb.its
new file mode 100644
index 0000000..151241f
--- /dev/null --- /dev/null
+++ b/kernel2088a-rdb.its +++ b/kernel2088a-rdb.its
@@ -0,0 +1,55 @@ @@ -0,0 +1,55 @@
@ -133,6 +127,3 @@ index 0000000..151241f
+ }; + };
+ }; + };
+}; +};
--
1.7.9.5

View file

@ -17,8 +17,6 @@ Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
drivers/memory/fsl_ifc.c | 1 + drivers/memory/fsl_ifc.c | 1 +
1 file changed, 1 insertion(+) 1 file changed, 1 insertion(+)
diff --git a/drivers/memory/fsl_ifc.c b/drivers/memory/fsl_ifc.c
index 03584dc..32c7752 100644
--- a/drivers/memory/fsl_ifc.c --- a/drivers/memory/fsl_ifc.c
+++ b/drivers/memory/fsl_ifc.c +++ b/drivers/memory/fsl_ifc.c
@@ -35,6 +35,7 @@ @@ -35,6 +35,7 @@
@ -29,6 +27,3 @@ index 03584dc..32c7752 100644
struct fsl_ifc_ctrl *fsl_ifc_ctrl_dev; struct fsl_ifc_ctrl *fsl_ifc_ctrl_dev;
EXPORT_SYMBOL(fsl_ifc_ctrl_dev); EXPORT_SYMBOL(fsl_ifc_ctrl_dev);
--
1.7.9.5

View file

@ -129,7 +129,7 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
static bool ls_pcie_is_bridge(struct ls_pcie *pcie) static bool ls_pcie_is_bridge(struct ls_pcie *pcie)
{ {
u32 header_type; u32 header_type;
@@ -276,10 +301,28 @@ static int __init ls_pcie_probe(struct p @@ -284,10 +309,28 @@ static int __init ls_pcie_probe(struct p
pcie->drvdata = match->data; pcie->drvdata = match->data;
pcie->lut = pcie->dbi + pcie->drvdata->lut_offset; pcie->lut = pcie->dbi + pcie->drvdata->lut_offset;

View file

@ -8,11 +8,9 @@ Subject: [PATCH 229/238] drivers: clk: qoriq: Add ls2088a key to chipinfo
drivers/clk/clk-qoriq.c | 11 +++++++++++ drivers/clk/clk-qoriq.c | 11 +++++++++++
1 file changed, 11 insertions(+) 1 file changed, 11 insertions(+)
diff --git a/drivers/clk/clk-qoriq.c b/drivers/clk/clk-qoriq.c
index 164ac41..6185d6a 100644
--- a/drivers/clk/clk-qoriq.c --- a/drivers/clk/clk-qoriq.c
+++ b/drivers/clk/clk-qoriq.c +++ b/drivers/clk/clk-qoriq.c
@@ -559,6 +559,17 @@ static const struct clockgen_chipinfo chipinfo[] = { @@ -559,6 +559,17 @@ static const struct clockgen_chipinfo ch
.flags = CG_VER3 | CG_LITTLE_ENDIAN, .flags = CG_VER3 | CG_LITTLE_ENDIAN,
}, },
{ {
@ -30,6 +28,3 @@ index 164ac41..6185d6a 100644
.compat = "fsl,p2041-clockgen", .compat = "fsl,p2041-clockgen",
.guts_compat = "fsl,qoriq-device-config-1.0", .guts_compat = "fsl,qoriq-device-config-1.0",
.init_periph = p2041_init_periph, .init_periph = p2041_init_periph,
--
1.7.9.5

View file

@ -12,31 +12,26 @@ Integrated-by: Zhao Qiang <qiang.zhao@nxp.com>
drivers/pci/host/pci-layerscape.c | 13 +++++++++---- drivers/pci/host/pci-layerscape.c | 13 +++++++++----
1 file changed, 9 insertions(+), 4 deletions(-) 1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/drivers/pci/host/pci-layerscape.c b/drivers/pci/host/pci-layerscape.c
index 00feabf..f85ebcf 100644
--- a/drivers/pci/host/pci-layerscape.c --- a/drivers/pci/host/pci-layerscape.c
+++ b/drivers/pci/host/pci-layerscape.c +++ b/drivers/pci/host/pci-layerscape.c
@@ -158,11 +158,16 @@ static void ls1021_pcie_host_init(struct pcie_port *pp) @@ -158,11 +158,16 @@ static void ls1021_pcie_host_init(struct
static int ls_pcie_link_up(struct pcie_port *pp) static int ls_pcie_link_up(struct pcie_port *pp)
{ {
struct ls_pcie *pcie = to_ls_pcie(pp); struct ls_pcie *pcie = to_ls_pcie(pp);
- u32 state; - u32 state;
+ u32 state, offset; + u32 state, offset;
+
+ if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
+ offset = 0x407fc;
+ else
+ offset = PCIE_LUT_DBG;
- state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >> - state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >>
- pcie->drvdata->ltssm_shift) & - pcie->drvdata->ltssm_shift) &
- LTSSM_STATE_MASK; - LTSSM_STATE_MASK;
+ if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
+ offset = 0x407fc;
+ else
+ offset = PCIE_LUT_DBG;
+
+ state = (ioread32(pcie->lut + offset) >> + state = (ioread32(pcie->lut + offset) >>
+ pcie->drvdata->ltssm_shift) & + pcie->drvdata->ltssm_shift) &
+ LTSSM_STATE_MASK; + LTSSM_STATE_MASK;
if (state < LTSSM_PCIE_L0) if (state < LTSSM_PCIE_L0)
return 0; return 0;
--
1.7.9.5

View file

@ -8,11 +8,9 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>wq
drivers/clk/clk-qoriq.c | 1 + drivers/clk/clk-qoriq.c | 1 +
1 file changed, 1 insertion(+) 1 file changed, 1 insertion(+)
diff --git a/drivers/clk/clk-qoriq.c b/drivers/clk/clk-qoriq.c
index 6185d6a..efaa9c1 100644
--- a/drivers/clk/clk-qoriq.c --- a/drivers/clk/clk-qoriq.c
+++ b/drivers/clk/clk-qoriq.c +++ b/drivers/clk/clk-qoriq.c
@@ -1339,6 +1339,7 @@ CLK_OF_DECLARE(qoriq_clockgen_ls1043a, "fsl,ls1043a-clockgen", clockgen_init); @@ -1346,6 +1346,7 @@ CLK_OF_DECLARE(qoriq_clockgen_ls1043a, "
CLK_OF_DECLARE(qoriq_clockgen_ls1046a, "fsl,ls1046a-clockgen", clockgen_init); CLK_OF_DECLARE(qoriq_clockgen_ls1046a, "fsl,ls1046a-clockgen", clockgen_init);
CLK_OF_DECLARE(qoriq_clockgen_ls2080a, "fsl,ls2080a-clockgen", clockgen_init); CLK_OF_DECLARE(qoriq_clockgen_ls2080a, "fsl,ls2080a-clockgen", clockgen_init);
CLK_OF_DECLARE(qoriq_clockgen_ls1012a, "fsl,ls1012a-clockgen", clockgen_init); CLK_OF_DECLARE(qoriq_clockgen_ls1012a, "fsl,ls1012a-clockgen", clockgen_init);
@ -20,6 +18,3 @@ index 6185d6a..efaa9c1 100644
/* Legacy nodes */ /* Legacy nodes */
CLK_OF_DECLARE(qoriq_sysclk_1, "fsl,qoriq-sysclk-1.0", sysclk_init); CLK_OF_DECLARE(qoriq_sysclk_1, "fsl,qoriq-sysclk-1.0", sysclk_init);
--
1.7.9.5

View file

@ -21,8 +21,6 @@ Signed-off-by: Priyanka Jain <Priyanka.Jain@freescale.com>
drivers/i2c/muxes/i2c-mux-pca954x.c | 38 +++++++++++++++++++++++++++++++++++ drivers/i2c/muxes/i2c-mux-pca954x.c | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+) 1 file changed, 38 insertions(+)
diff --git a/drivers/i2c/muxes/i2c-mux-pca954x.c b/drivers/i2c/muxes/i2c-mux-pca954x.c
index acfcef3..386f86f 100644
--- a/drivers/i2c/muxes/i2c-mux-pca954x.c --- a/drivers/i2c/muxes/i2c-mux-pca954x.c
+++ b/drivers/i2c/muxes/i2c-mux-pca954x.c +++ b/drivers/i2c/muxes/i2c-mux-pca954x.c
@@ -63,6 +63,7 @@ struct pca954x { @@ -63,6 +63,7 @@ struct pca954x {
@ -33,7 +31,7 @@ index acfcef3..386f86f 100644
}; };
struct chip_desc { struct chip_desc {
@@ -174,6 +175,13 @@ static int pca954x_deselect_mux(struct i2c_adapter *adap, @@ -174,6 +175,13 @@ static int pca954x_deselect_mux(struct i
{ {
struct pca954x *data = i2c_get_clientdata(client); struct pca954x *data = i2c_get_clientdata(client);
@ -47,7 +45,7 @@ index acfcef3..386f86f 100644
/* Deselect active channel */ /* Deselect active channel */
data->last_chan = 0; data->last_chan = 0;
return pca954x_reg_write(adap, client, data->last_chan); return pca954x_reg_write(adap, client, data->last_chan);
@@ -201,6 +209,23 @@ static int pca954x_probe(struct i2c_client *client, @@ -201,6 +209,23 @@ static int pca954x_probe(struct i2c_clie
if (!data) if (!data)
return -ENOMEM; return -ENOMEM;
@ -71,7 +69,7 @@ index acfcef3..386f86f 100644
i2c_set_clientdata(client, data); i2c_set_clientdata(client, data);
/* Get the mux out of reset if a reset GPIO is specified. */ /* Get the mux out of reset if a reset GPIO is specified. */
@@ -212,13 +237,19 @@ static int pca954x_probe(struct i2c_client *client, @@ -212,13 +237,19 @@ static int pca954x_probe(struct i2c_clie
* that the mux is in fact present. This also * that the mux is in fact present. This also
* initializes the mux to disconnected state. * initializes the mux to disconnected state.
*/ */
@ -91,7 +89,7 @@ index acfcef3..386f86f 100644
idle_disconnect_dt = of_node && idle_disconnect_dt = of_node &&
of_property_read_bool(of_node, "i2c-mux-idle-disconnect"); of_property_read_bool(of_node, "i2c-mux-idle-disconnect");
@@ -289,6 +320,13 @@ static int pca954x_resume(struct device *dev) @@ -289,6 +320,13 @@ static int pca954x_resume(struct device
struct i2c_client *client = to_i2c_client(dev); struct i2c_client *client = to_i2c_client(dev);
struct pca954x *data = i2c_get_clientdata(client); struct pca954x *data = i2c_get_clientdata(client);
@ -105,6 +103,3 @@ index acfcef3..386f86f 100644
data->last_chan = 0; data->last_chan = 0;
return i2c_smbus_write_byte(client, 0); return i2c_smbus_write_byte(client, 0);
} }
--
1.7.9.5

View file

@ -8,22 +8,20 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
drivers/pci/host/pci-layerscape.c | 13 ++++--------- drivers/pci/host/pci-layerscape.c | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-) 1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/drivers/pci/host/pci-layerscape.c b/drivers/pci/host/pci-layerscape.c
index f85ebcf..00feabf 100644
--- a/drivers/pci/host/pci-layerscape.c --- a/drivers/pci/host/pci-layerscape.c
+++ b/drivers/pci/host/pci-layerscape.c +++ b/drivers/pci/host/pci-layerscape.c
@@ -158,16 +158,11 @@ static void ls1021_pcie_host_init(struct pcie_port *pp) @@ -158,16 +158,11 @@ static void ls1021_pcie_host_init(struct
static int ls_pcie_link_up(struct pcie_port *pp) static int ls_pcie_link_up(struct pcie_port *pp)
{ {
struct ls_pcie *pcie = to_ls_pcie(pp); struct ls_pcie *pcie = to_ls_pcie(pp);
- u32 state, offset; - u32 state, offset;
- + u32 state;
- if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL)) - if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
- offset = 0x407fc; - offset = 0x407fc;
- else - else
- offset = PCIE_LUT_DBG; - offset = PCIE_LUT_DBG;
+ u32 state; -
- state = (ioread32(pcie->lut + offset) >> - state = (ioread32(pcie->lut + offset) >>
- pcie->drvdata->ltssm_shift) & - pcie->drvdata->ltssm_shift) &
- LTSSM_STATE_MASK; - LTSSM_STATE_MASK;
@ -33,6 +31,3 @@ index f85ebcf..00feabf 100644
if (state < LTSSM_PCIE_L0) if (state < LTSSM_PCIE_L0)
return 0; return 0;
--
1.7.9.5

View file

@ -10,11 +10,9 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
include/linux/clk.h | 9 +++++++++ include/linux/clk.h | 9 +++++++++
3 files changed, 29 insertions(+) 3 files changed, 29 insertions(+)
diff --git a/drivers/clk/clk.c b/drivers/clk/clk.c
index f13c3f4..0f6bcf5 100644
--- a/drivers/clk/clk.c --- a/drivers/clk/clk.c
+++ b/drivers/clk/clk.c +++ b/drivers/clk/clk.c
@@ -359,6 +359,19 @@ static struct clk_core *clk_core_get_parent_by_index(struct clk_core *core, @@ -359,6 +359,19 @@ static struct clk_core *clk_core_get_par
return core->parents[index]; return core->parents[index];
} }
@ -34,7 +32,7 @@ index f13c3f4..0f6bcf5 100644
struct clk_hw * struct clk_hw *
clk_hw_get_parent_by_index(const struct clk_hw *hw, unsigned int index) clk_hw_get_parent_by_index(const struct clk_hw *hw, unsigned int index)
{ {
@@ -2033,6 +2046,12 @@ static const struct file_operations clk_summary_fops = { @@ -2033,6 +2046,12 @@ static const struct file_operations clk_
.release = single_release, .release = single_release,
}; };
@ -47,11 +45,9 @@ index f13c3f4..0f6bcf5 100644
static void clk_dump_one(struct seq_file *s, struct clk_core *c, int level) static void clk_dump_one(struct seq_file *s, struct clk_core *c, int level)
{ {
if (!c) if (!c)
diff --git a/include/linux/clk-provider.h b/include/linux/clk-provider.h
index 7cd0171..77dfd61 100644
--- a/include/linux/clk-provider.h --- a/include/linux/clk-provider.h
+++ b/include/linux/clk-provider.h +++ b/include/linux/clk-provider.h
@@ -650,6 +650,7 @@ unsigned int clk_hw_get_num_parents(const struct clk_hw *hw); @@ -656,6 +656,7 @@ unsigned int clk_hw_get_num_parents(cons
struct clk_hw *clk_hw_get_parent(const struct clk_hw *hw); struct clk_hw *clk_hw_get_parent(const struct clk_hw *hw);
struct clk_hw *clk_hw_get_parent_by_index(const struct clk_hw *hw, struct clk_hw *clk_hw_get_parent_by_index(const struct clk_hw *hw,
unsigned int index); unsigned int index);
@ -59,11 +55,9 @@ index 7cd0171..77dfd61 100644
unsigned int __clk_get_enable_count(struct clk *clk); unsigned int __clk_get_enable_count(struct clk *clk);
unsigned long clk_hw_get_rate(const struct clk_hw *hw); unsigned long clk_hw_get_rate(const struct clk_hw *hw);
unsigned long __clk_get_flags(struct clk *clk); unsigned long __clk_get_flags(struct clk *clk);
diff --git a/include/linux/clk.h b/include/linux/clk.h
index 0df4a51..1df90e3 100644
--- a/include/linux/clk.h --- a/include/linux/clk.h
+++ b/include/linux/clk.h +++ b/include/linux/clk.h
@@ -392,6 +392,15 @@ int clk_set_parent(struct clk *clk, struct clk *parent); @@ -392,6 +392,15 @@ int clk_set_parent(struct clk *clk, stru
struct clk *clk_get_parent(struct clk *clk); struct clk *clk_get_parent(struct clk *clk);
/** /**
@ -79,6 +73,3 @@ index 0df4a51..1df90e3 100644
* clk_get_sys - get a clock based upon the device name * clk_get_sys - get a clock based upon the device name
* @dev_id: device name * @dev_id: device name
* @con_id: connection ID * @con_id: connection ID
--
1.7.9.5

View file

@ -15,8 +15,6 @@ Signed-off-by: Shengzhou Liu <Shengzhou.Liu@nxp.com>
drivers/pci/host/pci-layerscape.c | 13 ++++++++----- drivers/pci/host/pci-layerscape.c | 13 ++++++++-----
2 files changed, 12 insertions(+), 13 deletions(-) 2 files changed, 12 insertions(+), 13 deletions(-)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
index bd69942..07c917b 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi --- a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi +++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
@@ -513,8 +513,7 @@ @@ -513,8 +513,7 @@
@ -59,28 +57,26 @@ index bd69942..07c917b 100644
reg = <0x00 0x03700000 0x0 0x00100000 /* controller registers */ reg = <0x00 0x03700000 0x0 0x00100000 /* controller registers */
0x38 0x00000000 0x0 0x00002000>; /* configuration space */ 0x38 0x00000000 0x0 0x00002000>; /* configuration space */
reg-names = "regs", "config"; reg-names = "regs", "config";
diff --git a/drivers/pci/host/pci-layerscape.c b/drivers/pci/host/pci-layerscape.c
index 00feabf..3e2100d 100644
--- a/drivers/pci/host/pci-layerscape.c --- a/drivers/pci/host/pci-layerscape.c
+++ b/drivers/pci/host/pci-layerscape.c +++ b/drivers/pci/host/pci-layerscape.c
@@ -158,9 +158,14 @@ static void ls1021_pcie_host_init(struct pcie_port *pp) @@ -158,9 +158,14 @@ static void ls1021_pcie_host_init(struct
static int ls_pcie_link_up(struct pcie_port *pp) static int ls_pcie_link_up(struct pcie_port *pp)
{ {
struct ls_pcie *pcie = to_ls_pcie(pp); struct ls_pcie *pcie = to_ls_pcie(pp);
- u32 state; - u32 state;
+ u32 state, offset; + u32 state, offset;
+
- state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >>
+ if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL)) + if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
+ offset = 0x407fc; + offset = 0x407fc;
+ else + else
+ offset = pcie->drvdata->lut_dbg; + offset = pcie->drvdata->lut_dbg;
+
- state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >>
+ state = (ioread32(pcie->lut + offset) >> + state = (ioread32(pcie->lut + offset) >>
pcie->drvdata->ltssm_shift) & pcie->drvdata->ltssm_shift) &
LTSSM_STATE_MASK; LTSSM_STATE_MASK;
@@ -261,7 +266,6 @@ static const struct of_device_id ls_pcie_of_match[] = { @@ -261,7 +266,6 @@ static const struct of_device_id ls_pcie
{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata }, { .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
{ .compatible = "fsl,ls1088a-pcie", .data = &ls1088_drvdata }, { .compatible = "fsl,ls1088a-pcie", .data = &ls1088_drvdata },
{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata }, { .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
@ -88,7 +84,7 @@ index 00feabf..3e2100d 100644
{ }, { },
}; };
MODULE_DEVICE_TABLE(of, ls_pcie_of_match); MODULE_DEVICE_TABLE(of, ls_pcie_of_match);
@@ -315,8 +319,7 @@ static int __init ls_pcie_probe(struct platform_device *pdev) @@ -315,8 +319,7 @@ static int __init ls_pcie_probe(struct p
if (!ls_pcie_is_bridge(pcie)) if (!ls_pcie_is_bridge(pcie))
return -ENODEV; return -ENODEV;
@ -98,6 +94,3 @@ index 00feabf..3e2100d 100644
of_device_is_compatible(pdev->dev.of_node, "fsl,ls1088a-pcie")) { of_device_is_compatible(pdev->dev.of_node, "fsl,ls1088a-pcie")) {
int len; int len;
const u32 *prop; const u32 *prop;
--
1.7.9.5

View file

@ -1,8 +1,8 @@
--- a/drivers/mtd/nand/Kconfig --- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig +++ b/drivers/mtd/nand/Kconfig
@@ -546,4 +546,11 @@ config MTD_NAND_HISI504 @@ -563,4 +563,11 @@ config MTD_NAND_QCOM
help Enables support for NAND flash chips on SoCs containing the EBI2 NAND
Enables support for NAND controller on Hisilicon SoC Hip04. controller. This controller is found on IPQ806x SoC.
+config MTD_NAND_OXNAS +config MTD_NAND_OXNAS
+ tristate "Support for NAND on Plxtech NAS782X SoC" + tristate "Support for NAND on Plxtech NAS782X SoC"

View file

@ -1,14 +0,0 @@
Adding registration for 3G modem DWM-158 in usb-serial-option
Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
--- a/drivers/usb/serial/option.c
+++ b/drivers/usb/serial/option.c
@@ -1989,6 +1989,7 @@ static const struct usb_device_id option
{ USB_DEVICE_AND_INTERFACE_INFO(0x2001, 0x7d02, 0xff, 0x00, 0x00) },
{ USB_DEVICE_AND_INTERFACE_INFO(0x2001, 0x7d03, 0xff, 0x02, 0x01) },
{ USB_DEVICE_AND_INTERFACE_INFO(0x2001, 0x7d03, 0xff, 0x00, 0x00) },
+ { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d04, 0xff) }, /* D-Link DWM-158 */
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7e19, 0xff), /* D-Link DWM-221 B1 */
.driver_info = (kernel_ulong_t)&net_intf4_blacklist },
{ USB_DEVICE_AND_INTERFACE_INFO(0x07d1, 0x3e01, 0xff, 0xff, 0xff) }, /* D-Link DWM-152/C1 */

View file

@ -19,11 +19,9 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
drivers/net/ethernet/korina.c | 8 ++++---- drivers/net/ethernet/korina.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-) 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/net/ethernet/korina.c b/drivers/net/ethernet/korina.c
index cbeea915f026..8037426ec50f 100644
--- a/drivers/net/ethernet/korina.c --- a/drivers/net/ethernet/korina.c
+++ b/drivers/net/ethernet/korina.c +++ b/drivers/net/ethernet/korina.c
@@ -900,10 +900,10 @@ static void korina_restart_task(struct work_struct *work) @@ -900,10 +900,10 @@ static void korina_restart_task(struct w
DMA_STAT_DONE | DMA_STAT_HALT | DMA_STAT_ERR, DMA_STAT_DONE | DMA_STAT_HALT | DMA_STAT_ERR,
&lp->rx_dma_regs->dmasm); &lp->rx_dma_regs->dmasm);
@ -36,7 +34,7 @@ index cbeea915f026..8037426ec50f 100644
if (korina_init(dev) < 0) { if (korina_init(dev) < 0) {
printk(KERN_ERR "%s: cannot restart device\n", dev->name); printk(KERN_ERR "%s: cannot restart device\n", dev->name);
return; return;
@@ -1064,12 +1064,12 @@ static int korina_close(struct net_device *dev) @@ -1064,12 +1064,12 @@ static int korina_close(struct net_devic
tmp = tmp | DMA_STAT_DONE | DMA_STAT_HALT | DMA_STAT_ERR; tmp = tmp | DMA_STAT_DONE | DMA_STAT_HALT | DMA_STAT_ERR;
writel(tmp, &lp->rx_dma_regs->dmasm); writel(tmp, &lp->rx_dma_regs->dmasm);
@ -51,6 +49,3 @@ index cbeea915f026..8037426ec50f 100644
free_irq(lp->rx_irq, dev); free_irq(lp->rx_irq, dev);
free_irq(lp->tx_irq, dev); free_irq(lp->tx_irq, dev);
free_irq(lp->ovr_irq, dev); free_irq(lp->ovr_irq, dev);
--
2.9.3