parent
52231f694d
commit
84dd37d930
3 changed files with 51 additions and 53 deletions
|
@ -1,8 +1,6 @@
|
||||||
Index: linux-2.6.32.10/arch/mips/bcm63xx/cpu.c
|
--- a/arch/mips/bcm63xx/cpu.c
|
||||||
===================================================================
|
+++ b/arch/mips/bcm63xx/cpu.c
|
||||||
--- linux-2.6.32.10.orig/arch/mips/bcm63xx/cpu.c 2010-03-15 16:52:04.000000000 +0100
|
@@ -55,6 +55,7 @@ static const unsigned long bcm96338_regs
|
||||||
+++ linux-2.6.32.10/arch/mips/bcm63xx/cpu.c 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -55,6 +55,7 @@
|
|
||||||
|
|
||||||
static const int bcm96338_irqs[] = {
|
static const int bcm96338_irqs[] = {
|
||||||
[IRQ_TIMER] = BCM_6338_TIMER_IRQ,
|
[IRQ_TIMER] = BCM_6338_TIMER_IRQ,
|
||||||
|
@ -10,7 +8,7 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/cpu.c
|
||||||
[IRQ_UART0] = BCM_6338_UART0_IRQ,
|
[IRQ_UART0] = BCM_6338_UART0_IRQ,
|
||||||
[IRQ_DSL] = BCM_6338_DSL_IRQ,
|
[IRQ_DSL] = BCM_6338_DSL_IRQ,
|
||||||
[IRQ_ENET0] = BCM_6338_ENET0_IRQ,
|
[IRQ_ENET0] = BCM_6338_ENET0_IRQ,
|
||||||
@@ -127,6 +128,7 @@
|
@@ -127,6 +128,7 @@ static const unsigned long bcm96348_regs
|
||||||
|
|
||||||
static const int bcm96348_irqs[] = {
|
static const int bcm96348_irqs[] = {
|
||||||
[IRQ_TIMER] = BCM_6348_TIMER_IRQ,
|
[IRQ_TIMER] = BCM_6348_TIMER_IRQ,
|
||||||
|
@ -18,7 +16,7 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/cpu.c
|
||||||
[IRQ_UART0] = BCM_6348_UART0_IRQ,
|
[IRQ_UART0] = BCM_6348_UART0_IRQ,
|
||||||
[IRQ_DSL] = BCM_6348_DSL_IRQ,
|
[IRQ_DSL] = BCM_6348_DSL_IRQ,
|
||||||
[IRQ_ENET0] = BCM_6348_ENET0_IRQ,
|
[IRQ_ENET0] = BCM_6348_ENET0_IRQ,
|
||||||
@@ -169,6 +171,7 @@
|
@@ -169,6 +171,7 @@ static const unsigned long bcm96358_regs
|
||||||
|
|
||||||
static const int bcm96358_irqs[] = {
|
static const int bcm96358_irqs[] = {
|
||||||
[IRQ_TIMER] = BCM_6358_TIMER_IRQ,
|
[IRQ_TIMER] = BCM_6358_TIMER_IRQ,
|
||||||
|
@ -26,10 +24,8 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/cpu.c
|
||||||
[IRQ_UART0] = BCM_6358_UART0_IRQ,
|
[IRQ_UART0] = BCM_6358_UART0_IRQ,
|
||||||
[IRQ_DSL] = BCM_6358_DSL_IRQ,
|
[IRQ_DSL] = BCM_6358_DSL_IRQ,
|
||||||
[IRQ_ENET0] = BCM_6358_ENET0_IRQ,
|
[IRQ_ENET0] = BCM_6358_ENET0_IRQ,
|
||||||
Index: linux-2.6.32.10/arch/mips/bcm63xx/dev-spi.c
|
--- /dev/null
|
||||||
===================================================================
|
+++ b/arch/mips/bcm63xx/dev-spi.c
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ linux-2.6.32.10/arch/mips/bcm63xx/dev-spi.c 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -0,0 +1,60 @@
|
@@ -0,0 +1,60 @@
|
||||||
+/*
|
+/*
|
||||||
+ * This file is subject to the terms and conditions of the GNU General Public
|
+ * This file is subject to the terms and conditions of the GNU General Public
|
||||||
|
@ -91,11 +87,9 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/dev-spi.c
|
||||||
+
|
+
|
||||||
+ return platform_device_register(&bcm63xx_spi_device);
|
+ return platform_device_register(&bcm63xx_spi_device);
|
||||||
+}
|
+}
|
||||||
Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
--- a/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
||||||
===================================================================
|
+++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
||||||
--- linux-2.6.32.10.orig/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h 2010-04-22 17:35:21.000000000 +0200
|
@@ -108,6 +108,7 @@ enum bcm63xx_regs_set {
|
||||||
+++ linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h 2010-04-22 17:43:33.000000000 +0200
|
|
||||||
@@ -108,6 +108,7 @@
|
|
||||||
#define RSET_WDT_SIZE 12
|
#define RSET_WDT_SIZE 12
|
||||||
#define RSET_ENET_SIZE 2048
|
#define RSET_ENET_SIZE 2048
|
||||||
#define RSET_ENETDMA_SIZE 2048
|
#define RSET_ENETDMA_SIZE 2048
|
||||||
|
@ -103,7 +97,16 @@ Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
||||||
#define RSET_UART_SIZE 24
|
#define RSET_UART_SIZE 24
|
||||||
#define RSET_UDC_SIZE 256
|
#define RSET_UDC_SIZE 256
|
||||||
#define RSET_OHCI_SIZE 256
|
#define RSET_OHCI_SIZE 256
|
||||||
@@ -428,6 +429,7 @@
|
@@ -209,7 +210,7 @@ enum bcm63xx_regs_set {
|
||||||
|
#define BCM_6358_WDT_BASE (0xfffe005c)
|
||||||
|
#define BCM_6358_UART0_BASE (0xfffe0100)
|
||||||
|
#define BCM_6358_GPIO_BASE (0xfffe0080)
|
||||||
|
-#define BCM_6358_SPI_BASE (0xdeadbeef)
|
||||||
|
+#define BCM_6358_SPI_BASE (0xfffe0800)
|
||||||
|
#define BCM_6358_UDC0_BASE (0xfffe0400)
|
||||||
|
#define BCM_6358_OHCI0_BASE (0xfffe1400)
|
||||||
|
#define BCM_6358_OHCI_PRIV_BASE (0xdeadbeef)
|
||||||
|
@@ -428,6 +429,7 @@ static inline unsigned long bcm63xx_regs
|
||||||
*/
|
*/
|
||||||
enum bcm63xx_irq {
|
enum bcm63xx_irq {
|
||||||
IRQ_TIMER = 0,
|
IRQ_TIMER = 0,
|
||||||
|
@ -111,7 +114,7 @@ Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
||||||
IRQ_UART0,
|
IRQ_UART0,
|
||||||
IRQ_DSL,
|
IRQ_DSL,
|
||||||
IRQ_UDC0,
|
IRQ_UDC0,
|
||||||
@@ -493,6 +495,7 @@
|
@@ -493,6 +495,7 @@ enum bcm63xx_irq {
|
||||||
* 6348 irqs
|
* 6348 irqs
|
||||||
*/
|
*/
|
||||||
#define BCM_6348_TIMER_IRQ (IRQ_INTERNAL_BASE + 0)
|
#define BCM_6348_TIMER_IRQ (IRQ_INTERNAL_BASE + 0)
|
||||||
|
@ -119,7 +122,7 @@ Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
||||||
#define BCM_6348_UART0_IRQ (IRQ_INTERNAL_BASE + 2)
|
#define BCM_6348_UART0_IRQ (IRQ_INTERNAL_BASE + 2)
|
||||||
#define BCM_6348_DSL_IRQ (IRQ_INTERNAL_BASE + 4)
|
#define BCM_6348_DSL_IRQ (IRQ_INTERNAL_BASE + 4)
|
||||||
#define BCM_6348_UDC0_IRQ (IRQ_INTERNAL_BASE + 6)
|
#define BCM_6348_UDC0_IRQ (IRQ_INTERNAL_BASE + 6)
|
||||||
@@ -517,6 +520,7 @@
|
@@ -517,6 +520,7 @@ enum bcm63xx_irq {
|
||||||
* 6358 irqs
|
* 6358 irqs
|
||||||
*/
|
*/
|
||||||
#define BCM_6358_TIMER_IRQ (IRQ_INTERNAL_BASE + 0)
|
#define BCM_6358_TIMER_IRQ (IRQ_INTERNAL_BASE + 0)
|
||||||
|
@ -127,10 +130,8 @@ Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_cpu.h
|
||||||
#define BCM_6358_UART0_IRQ (IRQ_INTERNAL_BASE + 2)
|
#define BCM_6358_UART0_IRQ (IRQ_INTERNAL_BASE + 2)
|
||||||
#define BCM_6358_OHCI0_IRQ (IRQ_INTERNAL_BASE + 5)
|
#define BCM_6358_OHCI0_IRQ (IRQ_INTERNAL_BASE + 5)
|
||||||
#define BCM_6358_ENET1_IRQ (IRQ_INTERNAL_BASE + 6)
|
#define BCM_6358_ENET1_IRQ (IRQ_INTERNAL_BASE + 6)
|
||||||
Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_regs.h
|
--- a/arch/mips/include/asm/mach-bcm63xx/bcm63xx_regs.h
|
||||||
===================================================================
|
+++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_regs.h
|
||||||
--- linux-2.6.32.10.orig/arch/mips/include/asm/mach-bcm63xx/bcm63xx_regs.h 2010-03-15 16:52:04.000000000 +0100
|
|
||||||
+++ linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_regs.h 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -769,5 +769,117 @@
|
@@ -769,5 +769,117 @@
|
||||||
#define DMIPSPLLCFG_N2_SHIFT 29
|
#define DMIPSPLLCFG_N2_SHIFT 29
|
||||||
#define DMIPSPLLCFG_N2_MASK (0x7 << DMIPSPLLCFG_N2_SHIFT)
|
#define DMIPSPLLCFG_N2_MASK (0x7 << DMIPSPLLCFG_N2_SHIFT)
|
||||||
|
@ -249,10 +250,8 @@ Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_regs.h
|
||||||
+
|
+
|
||||||
#endif /* BCM63XX_REGS_H_ */
|
#endif /* BCM63XX_REGS_H_ */
|
||||||
|
|
||||||
Index: linux-2.6.32.10/drivers/spi/bcm63xx_spi.c
|
--- /dev/null
|
||||||
===================================================================
|
+++ b/drivers/spi/bcm63xx_spi.c
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ linux-2.6.32.10/drivers/spi/bcm63xx_spi.c 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -0,0 +1,628 @@
|
@@ -0,0 +1,628 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Broadcom BCM63xx SPI controller support
|
+ * Broadcom BCM63xx SPI controller support
|
||||||
|
@ -882,11 +881,9 @@ Index: linux-2.6.32.10/drivers/spi/bcm63xx_spi.c
|
||||||
+MODULE_DESCRIPTION("Broadcom BCM63xx SPI Controller driver");
|
+MODULE_DESCRIPTION("Broadcom BCM63xx SPI Controller driver");
|
||||||
+MODULE_LICENSE("GPL");
|
+MODULE_LICENSE("GPL");
|
||||||
+MODULE_VERSION(DRV_VER);
|
+MODULE_VERSION(DRV_VER);
|
||||||
Index: linux-2.6.32.10/drivers/spi/Kconfig
|
--- a/drivers/spi/Kconfig
|
||||||
===================================================================
|
+++ b/drivers/spi/Kconfig
|
||||||
--- linux-2.6.32.10.orig/drivers/spi/Kconfig 2010-04-22 17:35:20.000000000 +0200
|
@@ -60,6 +60,13 @@ config SPI_ATMEL
|
||||||
+++ linux-2.6.32.10/drivers/spi/Kconfig 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -60,6 +60,13 @@
|
|
||||||
This selects a driver for the Atmel SPI Controller, present on
|
This selects a driver for the Atmel SPI Controller, present on
|
||||||
many AT32 (AVR32) and AT91 (ARM) chips.
|
many AT32 (AVR32) and AT91 (ARM) chips.
|
||||||
|
|
||||||
|
@ -900,11 +897,9 @@ Index: linux-2.6.32.10/drivers/spi/Kconfig
|
||||||
config SPI_BFIN
|
config SPI_BFIN
|
||||||
tristate "SPI controller driver for ADI Blackfin5xx"
|
tristate "SPI controller driver for ADI Blackfin5xx"
|
||||||
depends on BLACKFIN
|
depends on BLACKFIN
|
||||||
Index: linux-2.6.32.10/drivers/spi/Makefile
|
--- a/drivers/spi/Makefile
|
||||||
===================================================================
|
+++ b/drivers/spi/Makefile
|
||||||
--- linux-2.6.32.10.orig/drivers/spi/Makefile 2010-04-22 17:35:20.000000000 +0200
|
@@ -34,6 +34,7 @@ obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
|
||||||
+++ linux-2.6.32.10/drivers/spi/Makefile 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -34,6 +34,7 @@
|
|
||||||
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
|
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
|
||||||
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
|
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
|
||||||
obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
|
obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
|
||||||
|
@ -912,10 +907,8 @@ Index: linux-2.6.32.10/drivers/spi/Makefile
|
||||||
# ... add above this line ...
|
# ... add above this line ...
|
||||||
|
|
||||||
# SPI protocol drivers (device/link on bus)
|
# SPI protocol drivers (device/link on bus)
|
||||||
Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_spi.h
|
--- /dev/null
|
||||||
===================================================================
|
+++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_spi.h
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_spi.h 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -0,0 +1,15 @@
|
@@ -0,0 +1,15 @@
|
||||||
+#ifndef BCM63XX_DEV_SPI_H
|
+#ifndef BCM63XX_DEV_SPI_H
|
||||||
+#define BCM63XX_DEV_SPI_H
|
+#define BCM63XX_DEV_SPI_H
|
||||||
|
@ -932,10 +925,8 @@ Index: linux-2.6.32.10/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_spi.h
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
+#endif /* BCM63XX_DEV_SPI_H */
|
+#endif /* BCM63XX_DEV_SPI_H */
|
||||||
Index: linux-2.6.32.10/arch/mips/bcm63xx/Makefile
|
--- a/arch/mips/bcm63xx/Makefile
|
||||||
===================================================================
|
+++ b/arch/mips/bcm63xx/Makefile
|
||||||
--- linux-2.6.32.10.orig/arch/mips/bcm63xx/Makefile 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
+++ linux-2.6.32.10/arch/mips/bcm63xx/Makefile 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
obj-y += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
|
obj-y += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
|
||||||
dev-dsp.o dev-enet.o dev-pcmcia.o dev-uart.o dev-wdt.o \
|
dev-dsp.o dev-enet.o dev-pcmcia.o dev-uart.o dev-wdt.o \
|
||||||
|
@ -944,10 +935,8 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/Makefile
|
||||||
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
||||||
|
|
||||||
obj-y += boards/
|
obj-y += boards/
|
||||||
Index: linux-2.6.32.10/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
===================================================================
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
--- linux-2.6.32.10.orig/arch/mips/bcm63xx/boards/board_bcm963xx.c 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
+++ linux-2.6.32.10/arch/mips/bcm63xx/boards/board_bcm963xx.c 2010-04-22 17:35:21.000000000 +0200
|
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
#include <bcm63xx_dev_usb_ohci.h>
|
#include <bcm63xx_dev_usb_ohci.h>
|
||||||
#include <bcm63xx_dev_usb_ehci.h>
|
#include <bcm63xx_dev_usb_ehci.h>
|
||||||
|
@ -956,7 +945,7 @@ Index: linux-2.6.32.10/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
#include <board_bcm963xx.h>
|
#include <board_bcm963xx.h>
|
||||||
|
|
||||||
#define PFX "board_bcm963xx: "
|
#define PFX "board_bcm963xx: "
|
||||||
@@ -998,6 +999,9 @@
|
@@ -998,6 +999,9 @@ int __init board_register_devices(void)
|
||||||
if (board.has_udc0)
|
if (board.has_udc0)
|
||||||
bcm63xx_udc_register();
|
bcm63xx_udc_register();
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
||||||
|
|
||||||
--- a/drivers/mtd/maps/Kconfig
|
--- a/drivers/mtd/maps/Kconfig
|
||||||
+++ b/drivers/mtd/maps/Kconfig
|
+++ b/drivers/mtd/maps/Kconfig
|
||||||
@@ -259,6 +259,13 @@ config MTD_ALCHEMY
|
@@ -257,6 +257,13 @@ config MTD_ALCHEMY
|
||||||
help
|
help
|
||||||
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
|
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
|
||||||
|
|
||||||
|
@ -342,7 +342,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
||||||
+MODULE_AUTHOR("Mike Albon <malbon@openwrt.org>");
|
+MODULE_AUTHOR("Mike Albon <malbon@openwrt.org>");
|
||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -722,20 +722,6 @@ static int board_get_mac_address(u8 *mac
|
@@ -721,20 +721,6 @@ static int board_get_mac_address(u8 *mac
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -363,7 +363,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
||||||
static struct resource mtd_resources[] = {
|
static struct resource mtd_resources[] = {
|
||||||
{
|
{
|
||||||
.start = 0, /* filled at runtime */
|
.start = 0, /* filled at runtime */
|
||||||
@@ -745,12 +731,9 @@ static struct resource mtd_resources[] =
|
@@ -744,12 +730,9 @@ static struct resource mtd_resources[] =
|
||||||
};
|
};
|
||||||
|
|
||||||
static struct platform_device mtd_dev = {
|
static struct platform_device mtd_dev = {
|
||||||
|
|
|
@ -97,6 +97,15 @@
|
||||||
#define RSET_UART_SIZE 24
|
#define RSET_UART_SIZE 24
|
||||||
#define RSET_UDC_SIZE 256
|
#define RSET_UDC_SIZE 256
|
||||||
#define RSET_OHCI_SIZE 256
|
#define RSET_OHCI_SIZE 256
|
||||||
|
@@ -209,7 +210,7 @@ enum bcm63xx_regs_set {
|
||||||
|
#define BCM_6358_WDT_BASE (0xfffe005c)
|
||||||
|
#define BCM_6358_UART0_BASE (0xfffe0100)
|
||||||
|
#define BCM_6358_GPIO_BASE (0xfffe0080)
|
||||||
|
-#define BCM_6358_SPI_BASE (0xdeadbeef)
|
||||||
|
+#define BCM_6358_SPI_BASE (0xfffe0800)
|
||||||
|
#define BCM_6358_UDC0_BASE (0xfffe0400)
|
||||||
|
#define BCM_6358_OHCI0_BASE (0xfffe1400)
|
||||||
|
#define BCM_6358_OHCI_PRIV_BASE (0xdeadbeef)
|
||||||
@@ -428,6 +429,7 @@ static inline unsigned long bcm63xx_regs
|
@@ -428,6 +429,7 @@ static inline unsigned long bcm63xx_regs
|
||||||
*/
|
*/
|
||||||
enum bcm63xx_irq {
|
enum bcm63xx_irq {
|
||||||
|
|
Loading…
Reference in a new issue