fix ppp compile on osx
SVN-Revision: 4869
This commit is contained in:
parent
a74bc9bd1f
commit
829c5acdd1
2 changed files with 29 additions and 0 deletions
|
@ -23,6 +23,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|||
PKG_BUILDDEP:=libpcap linux-atm
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
define Package/ppp/Default
|
||||
SECTION:=net
|
||||
|
@ -91,6 +92,14 @@ define Package/pppstats
|
|||
This package contains an utility to report PPP statistics.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,, \
|
||||
UNAME_S="Linux" \
|
||||
UNAME_R="$(LINUX_VERSION)" \
|
||||
UNAME_M="$(ARCH)" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr
|
||||
|
|
|
@ -0,0 +1,20 @@
|
|||
|
||||
Use values exported from $(TOPDIR)/rules.mk for determining
|
||||
the target system instead of the host configuration
|
||||
|
||||
--- ppp-2.4.3/configure.orig Sat Nov 6 11:36:32 2004
|
||||
+++ ppp-2.4.3/configure Sun Jun 18 23:40:46 2006
|
||||
@@ -8,9 +8,9 @@ SYSCONF=/etc
|
||||
# if [ -d /NextApps ]; then
|
||||
# system="NeXTStep"
|
||||
# else
|
||||
- system=`uname -s`
|
||||
- release=`uname -r`
|
||||
- arch=`uname -m`
|
||||
+ system=${UNAME_S:-`uname -s`}
|
||||
+ release=${UNAME_R:-`uname -r`}
|
||||
+ arch=${UNAME_M:-`uname -m`}
|
||||
# fi
|
||||
state="unknown"
|
||||
|
||||
|
Loading…
Reference in a new issue