tools: remove obsolete yaffs tool
This was added a long time ago and was apparently never used Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
a9232ba1ed
commit
828a471e8d
4 changed files with 1 additions and 176 deletions
|
@ -24,7 +24,7 @@ endif
|
||||||
tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf expat
|
tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf expat
|
||||||
tools-y += m4 libtool autoconf automake flex bison pkg-config mklibs
|
tools-y += m4 libtool autoconf automake flex bison pkg-config mklibs
|
||||||
tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
|
tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
|
||||||
tools-y += firmware-utils patch-image quilt yaffs2 padjffs2
|
tools-y += firmware-utils patch-image quilt padjffs2
|
||||||
tools-y += mm-macros missing-macros cmake scons bc findutils gengetopt patchelf
|
tools-y += mm-macros missing-macros cmake scons bc findutils gengetopt patchelf
|
||||||
tools-y += mtools dosfstools libressl
|
tools-y += mtools dosfstools libressl
|
||||||
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
|
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2008-2012 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=yaffs2_android
|
|
||||||
|
|
||||||
PKG_SOURCE_URL:=https://android.googlesource.com/platform/external/yaffs2
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_DATE:=2008-12-18
|
|
||||||
PKG_SOURCE_VERSION:=d333fc232d7e5ae3370080d5d6f7d88ea9c6b3a1
|
|
||||||
PKG_MIRROR_HASH:=232ceeed180fb1b7c1c28d12e756c253246f2b5e8cd4c7efa6d884c5c18baf90
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
|
||||||
|
|
||||||
define Host/Compile
|
|
||||||
$(MAKE) -C $(HOST_BUILD_DIR)/yaffs2/utils \
|
|
||||||
CC="$(HOSTCC)" \
|
|
||||||
CFLAGS="$(HOST_CFLAGS) -include endian.h" \
|
|
||||||
mkyaffs2image
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Host/Install
|
|
||||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
|
|
||||||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/yaffs2/utils/mkyaffs2image $(STAGING_DIR_HOST)/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Host/Clean
|
|
||||||
rm -f $(STAGING_DIR_HOST)/bin/mkyaffs2image
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call HostBuild))
|
|
|
@ -1,125 +0,0 @@
|
||||||
--- a/yaffs2/utils/Makefile
|
|
||||||
+++ b/yaffs2/utils/Makefile
|
|
||||||
@@ -16,12 +16,11 @@
|
|
||||||
|
|
||||||
#KERNELDIR = /usr/src/kernel-headers-2.4.18
|
|
||||||
|
|
||||||
-CFLAGS = -I/usr/include -I.. -O2 -Wall -DCONFIG_YAFFS_UTIL
|
|
||||||
-CFLAGS+= -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Wmissing-declarations
|
|
||||||
-CFLAGS+= -Wmissing-prototypes -Wredundant-decls -Wnested-externs -Winline
|
|
||||||
+CPPFLAGS = -I.. -DCONFIG_YAFFS_UTIL
|
|
||||||
+CFLAGS = -O2
|
|
||||||
|
|
||||||
## Change if you are using a cross-compiler
|
|
||||||
-MAKETOOLS =
|
|
||||||
+MAKETOOLS =
|
|
||||||
|
|
||||||
CC=$(MAKETOOLS)gcc
|
|
||||||
|
|
||||||
@@ -41,7 +40,7 @@ $(COMMONLINKS) $(MKYAFFSLINKS) $(MKYAFFS
|
|
||||||
ln -s ../$@ $@
|
|
||||||
|
|
||||||
$(COMMONOBJS) $(MKYAFFSIMAGEOBJS) $(MKYAFFS2IMAGEOBJS) : %.o: %.c
|
|
||||||
- $(CC) -c $(CFLAGS) $< -o $@
|
|
||||||
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) $< -o $@
|
|
||||||
|
|
||||||
mkyaffsimage: $(COMMONOBJS) $(MKYAFFSIMAGEOBJS)
|
|
||||||
$(CC) -o $@ $(COMMONOBJS) $(MKYAFFSIMAGEOBJS)
|
|
||||||
--- a/yaffs2/utils/mkyaffs2image.c
|
|
||||||
+++ b/yaffs2/utils/mkyaffs2image.c
|
|
||||||
@@ -32,8 +32,6 @@
|
|
||||||
#include <string.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
|
|
||||||
-#include <private/android_filesystem_config.h>
|
|
||||||
-
|
|
||||||
#include "yaffs_ecc.h"
|
|
||||||
#include "yaffs_guts.h"
|
|
||||||
|
|
||||||
@@ -69,10 +67,12 @@ static int outFile;
|
|
||||||
|
|
||||||
static int error;
|
|
||||||
|
|
||||||
-#ifdef HAVE_BIG_ENDIAN
|
|
||||||
+#if BYTE_ORDER == BIG_ENDIAN
|
|
||||||
static int convert_endian = 1;
|
|
||||||
-#elif defined(HAVE_LITTLE_ENDIAN)
|
|
||||||
+#elif BYTE_ORDER == LITTLE_ENDIAN
|
|
||||||
static int convert_endian = 0;
|
|
||||||
+#else
|
|
||||||
+#error Unknown endian type
|
|
||||||
#endif
|
|
||||||
|
|
||||||
static int obj_compare(const void *a, const void * b)
|
|
||||||
@@ -298,8 +298,8 @@ static int write_object_header(int objId
|
|
||||||
|
|
||||||
static void fix_stat(const char *path, struct stat *s)
|
|
||||||
{
|
|
||||||
- path += source_path_len;
|
|
||||||
- fs_config(path, S_ISDIR(s->st_mode), &s->st_uid, &s->st_gid, &s->st_mode);
|
|
||||||
+ s->st_uid = 0;
|
|
||||||
+ s->st_gid = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
static int process_directory(int parent, const char *path, int fixstats)
|
|
||||||
@@ -342,9 +342,8 @@ static int process_directory(int parent,
|
|
||||||
newObj = obj_id++;
|
|
||||||
nObjects++;
|
|
||||||
|
|
||||||
- if (fixstats) {
|
|
||||||
+ if (fixstats)
|
|
||||||
fix_stat(full_name, &stats);
|
|
||||||
- }
|
|
||||||
|
|
||||||
//printf("Object %d, %s is a ",newObj,full_name);
|
|
||||||
|
|
||||||
@@ -473,13 +472,13 @@ int main(int argc, char *argv[])
|
|
||||||
fprintf(stderr," -f fix file stat (mods, user, group) for device\n");
|
|
||||||
fprintf(stderr," dir the directory tree to be converted\n");
|
|
||||||
fprintf(stderr," image_file the output file to hold the image\n");
|
|
||||||
- fprintf(stderr," 'convert' produce a big-endian image from a little-endian machine\n");
|
|
||||||
+ fprintf(stderr," 'convert' produce a big-endian image\n");
|
|
||||||
exit(1);
|
|
||||||
}
|
|
||||||
|
|
||||||
if ((argc == 4) && (!strncmp(argv[3], "convert", strlen("convert"))))
|
|
||||||
{
|
|
||||||
- convert_endian = 1;
|
|
||||||
+ convert_endian = !convert_endian;
|
|
||||||
}
|
|
||||||
|
|
||||||
if(stat(argv[1],&stats) < 0)
|
|
||||||
@@ -503,20 +502,9 @@ int main(int argc, char *argv[])
|
|
||||||
exit(1);
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (fixstats) {
|
|
||||||
- int len = strlen(argv[1]);
|
|
||||||
-
|
|
||||||
- if((len >= 4) && (!strcmp(argv[1] + len - 4, "data"))) {
|
|
||||||
- source_path_len = len - 4;
|
|
||||||
- } else if((len >= 7) && (!strcmp(argv[1] + len - 6, "system"))) {
|
|
||||||
- source_path_len = len - 6;
|
|
||||||
- } else {
|
|
||||||
- fprintf(stderr,"Fixstats (-f) option requested but filesystem is not data or android!\n");
|
|
||||||
- exit(1);
|
|
||||||
- }
|
|
||||||
+ if (fixstats)
|
|
||||||
fix_stat(argv[1], &stats);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
+
|
|
||||||
//printf("Processing directory %s into image file %s\n",argv[1],argv[2]);
|
|
||||||
error = write_object_header(1, YAFFS_OBJECT_TYPE_DIRECTORY, &stats, 1,"", -1, NULL);
|
|
||||||
if(error)
|
|
||||||
--- a/yaffs2/devextras.h
|
|
||||||
+++ b/yaffs2/devextras.h
|
|
||||||
@@ -37,7 +37,7 @@ typedef unsigned char __u8;
|
|
||||||
typedef unsigned short __u16;
|
|
||||||
typedef unsigned __u32;
|
|
||||||
|
|
||||||
-#if defined(__APPLE__)
|
|
||||||
+#if defined(__APPLE__) || defined(__FreeBSD__)
|
|
||||||
typedef long long loff_t;
|
|
||||||
#endif
|
|
||||||
|
|
|
@ -1,14 +0,0 @@
|
||||||
diff -Nur yaffs2_android.orig/yaffs2/yaffs_guts.h yaffs2_android/yaffs2/yaffs_guts.h
|
|
||||||
--- yaffs2_android.orig/yaffs2/yaffs_guts.h Sun Feb 15 16:23:50 2009
|
|
||||||
+++ yaffs2_android/yaffs2/yaffs_guts.h Tue Mar 5 15:45:21 2013
|
|
||||||
@@ -823,6 +823,10 @@
|
|
||||||
int yaffs_SetAttributes(yaffs_Object * obj, struct iattr *attr);
|
|
||||||
int yaffs_GetAttributes(yaffs_Object * obj, struct iattr *attr);
|
|
||||||
|
|
||||||
+#if defined(__OpenBSD__)
|
|
||||||
+#define loff_t off_t
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/* File operations */
|
|
||||||
int yaffs_ReadDataFromFile(yaffs_Object * obj, __u8 * buffer, loff_t offset,
|
|
||||||
int nBytes);
|
|
Loading…
Reference in a new issue