update to 2.6.26.5 and 2.6.25.17

SVN-Revision: 12718
This commit is contained in:
Gabor Juhos 2008-09-26 18:46:53 +00:00
parent 6f98e7cf01
commit 821170133f
44 changed files with 99 additions and 162 deletions

View file

@ -22,11 +22,11 @@ endif
ifeq ($(LINUX_VERSION),2.6.24.7) ifeq ($(LINUX_VERSION),2.6.24.7)
LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4 LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
endif endif
ifeq ($(LINUX_VERSION),2.6.25.16) ifeq ($(LINUX_VERSION),2.6.25.17)
LINUX_KERNEL_MD5SUM:=fdb0e08f0e5a2b4fe6dc711ca35f430e LINUX_KERNEL_MD5SUM:=30618bff93fd4fd048e20a9a6aab8e5d
endif endif
ifeq ($(LINUX_VERSION),2.6.26.3) ifeq ($(LINUX_VERSION),2.6.26.5)
LINUX_KERNEL_MD5SUM:=90fe36b18dbac6e2f79374e2df60ac67 LINUX_KERNEL_MD5SUM:=98261b39a558cf0739703ffea7db9f43
endif endif
# disable the md5sum check for unknown kernel versions # disable the md5sum check for unknown kernel versions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120 BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120 BOARDNAME:=Infineon/ADMtek ADM5120
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
SUBTARGETS:=router_le router_be SUBTARGETS:=router_le router_be
INITRAMFS_EXTRA_FILES:= INITRAMFS_EXTRA_FILES:=

View file

@ -22,7 +22,7 @@
config MACH_ALCHEMY config MACH_ALCHEMY
bool "Alchemy processor based machines" bool "Alchemy processor based machines"
@@ -687,6 +701,7 @@ @@ -687,6 +702,7 @@
endchoice endchoice

View file

@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7 BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm FEATURES:=squashfs jffs2 atm
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -26,7 +26,7 @@
--- a/arch/mips/kernel/traps.c --- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c +++ b/arch/mips/kernel/traps.c
@@ -1112,9 +1112,22 @@ @@ -1188,9 +1188,22 @@
exception_handlers[n] = handler; exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) { if (n == 0 && cpu_has_divec) {

View file

@ -1,6 +1,5 @@
diff -ruN linux-2.6.26.3.orig/drivers/mtd/Kconfig linux-2.6.26.3/drivers/mtd/Kconfig --- a/drivers/mtd/Kconfig
--- linux-2.6.26.3.orig/drivers/mtd/Kconfig 2008-08-27 19:37:48.000000000 -0700 +++ b/drivers/mtd/Kconfig
+++ linux-2.6.26.3/drivers/mtd/Kconfig 2008-08-27 19:39:14.000000000 -0700
@@ -174,6 +174,12 @@ @@ -174,6 +174,12 @@
---help--- ---help---
TI AR7 partitioning support TI AR7 partitioning support
@ -14,9 +13,8 @@ diff -ruN linux-2.6.26.3.orig/drivers/mtd/Kconfig linux-2.6.26.3/drivers/mtd/Kco
comment "User Modules And Translation Layers" comment "User Modules And Translation Layers"
config MTD_CHAR config MTD_CHAR
diff -ruN linux-2.6.26.3.orig/drivers/mtd/Makefile linux-2.6.26.3/drivers/mtd/Makefile --- a/drivers/mtd/Makefile
--- linux-2.6.26.3.orig/drivers/mtd/Makefile 2008-08-27 19:37:48.000000000 -0700 +++ b/drivers/mtd/Makefile
+++ linux-2.6.26.3/drivers/mtd/Makefile 2008-08-27 19:39:14.000000000 -0700
@@ -13,6 +13,7 @@ @@ -13,6 +13,7 @@
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
@ -25,9 +23,8 @@ diff -ruN linux-2.6.26.3.orig/drivers/mtd/Makefile linux-2.6.26.3/drivers/mtd/Ma
# 'Users' - code which presents functionality to userspace. # 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o obj-$(CONFIG_MTD_CHAR) += mtdchar.o
diff -ruN linux-2.6.26.3.orig/drivers/mtd/maps/physmap.c linux-2.6.26.3/drivers/mtd/maps/physmap.c --- a/drivers/mtd/maps/physmap.c
--- linux-2.6.26.3.orig/drivers/mtd/maps/physmap.c 2008-08-27 19:37:48.000000000 -0700 +++ b/drivers/mtd/maps/physmap.c
+++ linux-2.6.26.3/drivers/mtd/maps/physmap.c 2008-08-27 19:39:14.000000000 -0700
@@ -87,7 +87,8 @@ @@ -87,7 +87,8 @@
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL }; static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };

View file

@ -1,6 +1,6 @@
--- a/drivers/char/Kconfig --- a/drivers/char/Kconfig
+++ b/drivers/char/Kconfig +++ b/drivers/char/Kconfig
@@ -913,6 +913,15 @@ @@ -960,6 +960,15 @@
To compile this driver as a module, choose M here: the To compile this driver as a module, choose M here: the
module will be called mwave. module will be called mwave.
@ -18,7 +18,7 @@
depends on SCx200 depends on SCx200
--- a/drivers/char/Makefile --- a/drivers/char/Makefile
+++ b/drivers/char/Makefile +++ b/drivers/char/Makefile
@@ -90,6 +90,7 @@ @@ -91,6 +91,7 @@
obj-$(CONFIG_PPDEV) += ppdev.o obj-$(CONFIG_PPDEV) += ppdev.o
obj-$(CONFIG_NWBUTTON) += nwbutton.o obj-$(CONFIG_NWBUTTON) += nwbutton.o
obj-$(CONFIG_NWFLASH) += nwflash.o obj-$(CONFIG_NWFLASH) += nwflash.o

View file

@ -1,7 +1,5 @@
Index: linux-2.6.26/drivers/Kconfig --- a/drivers/Kconfig
=================================================================== +++ b/drivers/Kconfig
--- linux-2.6.26.orig/drivers/Kconfig 2008-07-13 23:51:29.000000000 +0200
+++ linux-2.6.26/drivers/Kconfig 2008-07-14 12:28:00.186793402 +0200
@@ -100,5 +100,7 @@ @@ -100,5 +100,7 @@
source "drivers/uio/Kconfig" source "drivers/uio/Kconfig"
@ -10,10 +8,8 @@ Index: linux-2.6.26/drivers/Kconfig
+ +
source "drivers/xen/Kconfig" source "drivers/xen/Kconfig"
endmenu endmenu
Index: linux-2.6.26/drivers/Makefile --- a/drivers/Makefile
=================================================================== +++ b/drivers/Makefile
--- linux-2.6.26.orig/drivers/Makefile 2008-07-13 23:51:29.000000000 +0200
+++ linux-2.6.26/drivers/Makefile 2008-07-14 12:27:34.362789842 +0200
@@ -92,5 +92,6 @@ @@ -92,5 +92,6 @@
obj-$(CONFIG_HID) += hid/ obj-$(CONFIG_HID) += hid/
obj-$(CONFIG_PPC_PS3) += ps3/ obj-$(CONFIG_PPC_PS3) += ps3/

View file

@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig --- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig +++ b/drivers/net/Kconfig
@@ -1874,7 +1874,7 @@ @@ -1867,7 +1867,7 @@
config CPMAC config CPMAC
tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)" tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"

View file

@ -1,6 +1,6 @@
--- a/drivers/serial/8250.c --- a/drivers/serial/8250.c
+++ b/drivers/serial/8250.c +++ b/drivers/serial/8250.c
@@ -267,6 +267,13 @@ @@ -266,6 +266,13 @@
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10, .fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO, .flags = UART_CAP_FIFO,
}, },
@ -14,7 +14,7 @@
}; };
#if defined (CONFIG_SERIAL_8250_AU1X00) #if defined (CONFIG_SERIAL_8250_AU1X00)
@@ -2455,7 +2462,11 @@ @@ -2524,7 +2531,11 @@
{ {
struct uart_8250_port *up = (struct uart_8250_port *)port; struct uart_8250_port *up = (struct uart_8250_port *)port;

View file

@ -17,8 +17,8 @@ because other drivers do it in the same way.
Signed-off-by: Stefan Weil <weil@mail.berlios.de> Signed-off-by: Stefan Weil <weil@mail.berlios.de>
--- a/drivers/net/cpmac.c 2008-07-13 23:51:29.000000000 +0200 --- a/drivers/net/cpmac.c
+++ b/drivers/net/cpmac.c 2008-08-14 20:48:49.000000000 +0200 +++ b/drivers/net/cpmac.c
@@ -627,7 +627,7 @@ @@ -627,7 +627,7 @@
dev_kfree_skb_irq(desc->skb); dev_kfree_skb_irq(desc->skb);
desc->skb = NULL; desc->skb = NULL;

View file

@ -1,6 +1,6 @@
--- a/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
+++ b/drivers/net/cpmac.c +++ b/drivers/net/cpmac.c
@@ -936,7 +936,8 @@ @@ -948,7 +948,8 @@
int new_state = 0; int new_state = 0;
spin_lock(&priv->lock); spin_lock(&priv->lock);
@ -10,7 +10,7 @@
netif_start_queue(dev); netif_start_queue(dev);
if (priv->phy->duplex != priv->oldduplex) { if (priv->phy->duplex != priv->oldduplex) {
new_state = 1; new_state = 1;
@@ -948,11 +949,11 @@ @@ -960,11 +961,11 @@
priv->oldspeed = priv->phy->speed; priv->oldspeed = priv->phy->speed;
} }

View file

@ -11,7 +11,7 @@ BOARD:=ar71xx
BOARDNAME:=Atheros AR71xx BOARDNAME:=Atheros AR71xx
FEATURES:=squashfs tgz broken FEATURES:=squashfs tgz broken
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -131,7 +131,7 @@
source "arch/mips/au1000/Kconfig" source "arch/mips/au1000/Kconfig"
source "arch/mips/basler/excite/Kconfig" source "arch/mips/basler/excite/Kconfig"
source "arch/mips/jazz/Kconfig" source "arch/mips/jazz/Kconfig"
@@ -876,6 +877,9 @@ @@ -879,6 +880,9 @@
config SYNC_R4K config SYNC_R4K
bool bool

View file

@ -11,7 +11,7 @@ BOARD:=at91
BOARDNAME:=Atmel AT91 BOARDNAME:=Atmel AT91
FEATURES:=squashfs usb FEATURES:=squashfs usb
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -11,7 +11,7 @@ BOARD:=atheros
BOARDNAME:=Atheros 231x/5312 BOARDNAME:=Atheros 231x/5312
FEATURES:=squashfs jffs2 FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00 BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci FEATURES:=jffs2 usb pci
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += yamonenv DEFAULT_PACKAGES += yamonenv

View file

@ -1,5 +1,5 @@
--- linux-2.6.25.16/arch/mips/au1000/common/gpio.c.org 2008-09-04 22:32:12.000000000 +0200 --- a/arch/mips/au1000/common/gpio.c
+++ linux-2.6.25.16/arch/mips/au1000/common/gpio.c 2008-09-04 23:10:18.000000000 +0200 +++ b/arch/mips/au1000/common/gpio.c
@@ -66,7 +66,8 @@ @@ -66,7 +66,8 @@
static int au1xxx_gpio2_direction_output(unsigned gpio, int value) static int au1xxx_gpio2_direction_output(unsigned gpio, int value)
{ {

View file

@ -10,7 +10,7 @@ ARCH:=avr32
BOARD:=avr32 BOARD:=avr32
BOARDNAME:=Atmel AVR32 BOARDNAME:=Atmel AVR32
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb FEATURES:=squashfs usb
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-switch kmod-diag DEFAULT_PACKAGES += kmod-switch kmod-diag

View file

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM963xx BOARDNAME:=Broadcom BCM963xx
FEATURES:=squashfs jffs2 broken usb atm FEATURES:=squashfs jffs2 broken usb atm
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -10,7 +10,7 @@ ARCH:=cris
BOARD:=etrax BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX) BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2 broken FEATURES:=squashfs jffs2 broken
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -1,6 +1,5 @@
diff -urN linux-2.6.25.7/arch/cris/Makefile linux-2.6.25.7.cris/arch/cris/Makefile --- a/arch/cris/Makefile
--- linux-2.6.25.7/arch/cris/Makefile 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/Makefile
+++ linux-2.6.25.7.cris/arch/cris/Makefile 2008-06-24 13:22:48.000000000 +0200
@@ -33,7 +33,7 @@ @@ -33,7 +33,7 @@
LD = $(CROSS_COMPILE)ld -mcrislinux LD = $(CROSS_COMPILE)ld -mcrislinux
@ -10,9 +9,8 @@ diff -urN linux-2.6.25.7/arch/cris/Makefile linux-2.6.25.7.cris/arch/cris/Makefi
CPPFLAGS_vmlinux.lds = -DDRAM_VIRTUAL_BASE=0x$(CONFIG_ETRAX_DRAM_VIRTUAL_BASE) CPPFLAGS_vmlinux.lds = -DDRAM_VIRTUAL_BASE=0x$(CONFIG_ETRAX_DRAM_VIRTUAL_BASE)
diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/Makefile linux-2.6.25.7.cris/arch/cris/arch-v10/boot/Makefile --- a/arch/cris/arch-v10/boot/Makefile
--- linux-2.6.25.7/arch/cris/arch-v10/boot/Makefile 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/arch-v10/boot/Makefile
+++ linux-2.6.25.7.cris/arch/cris/arch-v10/boot/Makefile 2008-06-24 13:23:03.000000000 +0200
@@ -2,9 +2,6 @@ @@ -2,9 +2,6 @@
# arch/cris/arch-v10/boot/Makefile # arch/cris/arch-v10/boot/Makefile
# #
@ -31,9 +29,8 @@ diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/Makefile linux-2.6.25.7.cris/ar
$(obj)/zImage: $(obj)/compressed/vmlinux $(obj)/zImage: $(obj)/compressed/vmlinux
@cp $< $@ @cp $< $@
diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/Makefile linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/Makefile --- a/arch/cris/arch-v10/boot/compressed/Makefile
--- linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/Makefile 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/arch-v10/boot/compressed/Makefile
+++ linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/Makefile 2008-06-24 13:23:14.000000000 +0200
@@ -2,13 +2,9 @@ @@ -2,13 +2,9 @@
# arch/cris/arch-v10/boot/compressed/Makefile # arch/cris/arch-v10/boot/compressed/Makefile
# #
@ -61,18 +58,16 @@ diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/Makefile linux-2.6.2
$(obj)/vmlinux: $(obj)/piggy.gz $(obj)/decompress.bin FORCE $(obj)/vmlinux: $(obj)/piggy.gz $(obj)/decompress.bin FORCE
$(call if_changed,image) $(call if_changed,image)
diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/decompress.ld linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/decompress.ld --- a/arch/cris/arch-v10/boot/compressed/decompress.ld
--- linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/decompress.ld 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/arch-v10/boot/compressed/decompress.ld
+++ linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/decompress.ld 2008-06-24 12:57:25.000000000 +0200
@@ -1,4 +1,4 @@ @@ -1,4 +1,4 @@
-OUTPUT_FORMAT(elf32-us-cris) -OUTPUT_FORMAT(elf32-us-cris)
+OUTPUT_FORMAT(elf32-cris) +OUTPUT_FORMAT(elf32-cris)
MEMORY MEMORY
{ {
diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/head.S linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/head.S --- a/arch/cris/arch-v10/boot/compressed/head.S
--- linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/head.S 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/arch-v10/boot/compressed/head.S
+++ linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/head.S 2008-06-24 13:24:50.000000000 +0200
@@ -10,13 +10,14 @@ @@ -10,13 +10,14 @@
#define ASSEMBLER_MACROS_ONLY #define ASSEMBLER_MACROS_ONLY
@ -227,9 +222,8 @@ diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/head.S linux-2.6.25.
+cmd_line_addr: +cmd_line_addr:
.dword 0 .dword 0
#include "../../lib/hw_settings.S" #include "../../lib/hw_settings.S"
diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/misc.c linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/misc.c --- a/arch/cris/arch-v10/boot/compressed/misc.c
--- linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/misc.c 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/arch-v10/boot/compressed/misc.c
+++ linux-2.6.25.7.cris/arch/cris/arch-v10/boot/compressed/misc.c 2008-06-24 12:57:25.000000000 +0200
@@ -5,7 +5,7 @@ @@ -5,7 +5,7 @@
* adapted for Linux. * adapted for Linux.
* *
@ -294,9 +288,8 @@ diff -urN linux-2.6.25.7/arch/cris/arch-v10/boot/compressed/misc.c linux-2.6.25.
- puts("Done. Now booting the kernel.\n"); - puts("Done. Now booting the kernel.\n");
+ putstr("Done. Now booting the kernel.\n"); + putstr("Done. Now booting the kernel.\n");
} }
diff -urN linux-2.6.25.7/arch/cris/arch-v10/mm/init.c linux-2.6.25.7.cris/arch/cris/arch-v10/mm/init.c --- a/arch/cris/arch-v10/mm/init.c
--- linux-2.6.25.7/arch/cris/arch-v10/mm/init.c 2008-06-16 22:24:36.000000000 +0200 +++ b/arch/cris/arch-v10/mm/init.c
+++ linux-2.6.25.7.cris/arch/cris/arch-v10/mm/init.c 2008-06-24 12:57:25.000000000 +0200
@@ -184,6 +184,9 @@ @@ -184,6 +184,9 @@
free_area_init_node(0, &contig_page_data, zones_size, PAGE_OFFSET >> PAGE_SHIFT, 0); free_area_init_node(0, &contig_page_data, zones_size, PAGE_OFFSET >> PAGE_SHIFT, 0);

View file

@ -1,5 +1,5 @@
--- linux-2.6.25.7/drivers/net/cris/eth_v10.c.orig 2008-06-24 13:37:48.000000000 +0200 --- a/drivers/net/cris/eth_v10.c
+++ linux-2.6.25.7/drivers/net/cris/eth_v10.c 2008-06-24 13:37:58.000000000 +0200 +++ b/drivers/net/cris/eth_v10.c
@@ -1707,7 +1707,7 @@ @@ -1707,7 +1707,7 @@
static void static void
e100_netpoll(struct net_device* netdev) e100_netpoll(struct net_device* netdev)

View file

@ -1,5 +1,5 @@
--- linux-2.6.25.7/include/asm-cris/Kbuild.orig 2008-06-23 12:24:03.000000000 +0200 --- a/include/asm-cris/Kbuild
+++ linux-2.6.25.7/include/asm-cris/Kbuild 2008-06-23 12:24:23.000000000 +0200 +++ b/include/asm-cris/Kbuild
@@ -1,7 +1,6 @@ @@ -1,7 +1,6 @@
include include/asm-generic/Kbuild.asm include include/asm-generic/Kbuild.asm

View file

@ -1,12 +0,0 @@
--- a/drivers/usb/class/cdc-acm.c
+++ b/drivers/usb/class/cdc-acm.c
@@ -531,8 +531,8 @@
tasklet_schedule(&acm->urb_task);
done:
-err_out:
mutex_unlock(&acm->mutex);
+err_out:
mutex_unlock(&open_mutex);
return rv;

View file

@ -833,7 +833,7 @@
+MODULE_ALIAS("ipt_portscan"); +MODULE_ALIAS("ipt_portscan");
--- a/drivers/char/random.c --- a/drivers/char/random.c
+++ b/drivers/char/random.c +++ b/drivers/char/random.c
@@ -1553,6 +1553,8 @@ @@ -1554,6 +1554,8 @@
return seq; return seq;
} }

View file

@ -1,11 +0,0 @@
--- a/include/linux/pim.h
+++ b/include/linux/pim.h
@@ -9,7 +9,7 @@
__u8 pim_type:4, /* PIM message type */
pim_ver:4; /* PIM version */
#elif defined(__BIG_ENDIAN_BITFIELD)
- __u8 pim_ver:4; /* PIM version */
+ __u8 pim_ver:4, /* PIM version */
pim_type:4; /* PIM message type */
#endif
__u8 pim_rsv; /* Reserved */

View file

@ -44,7 +44,7 @@
* All of these routines try to estimate how many bits of randomness a * All of these routines try to estimate how many bits of randomness a
* particular randomness source. They do this by keeping track of the * particular randomness source. They do this by keeping track of the
* first and second order deltas of the event timings. * first and second order deltas of the event timings.
@@ -666,6 +676,61 @@ @@ -667,6 +677,61 @@
} }
#endif #endif

View file

@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=ifxmips BOARD:=ifxmips
BOARDNAME:=Infineon Mips BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2 FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.26.2 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=uboot-ifxmips DEFAULT_PACKAGES+=uboot-ifxmips

View file

@ -22,7 +22,7 @@
config MACH_DECSTATION config MACH_DECSTATION
bool "DECstations" bool "DECstations"
select BOOT_ELF32 select BOOT_ELF32
@@ -693,6 +708,7 @@ @@ -697,6 +712,7 @@
source "arch/mips/tx4927/Kconfig" source "arch/mips/tx4927/Kconfig"
source "arch/mips/tx4938/Kconfig" source "arch/mips/tx4938/Kconfig"
source "arch/mips/vr41xx/Kconfig" source "arch/mips/vr41xx/Kconfig"
@ -63,7 +63,7 @@
extern char *system_type; extern char *system_type;
--- a/arch/mips/kernel/traps.c --- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c +++ b/arch/mips/kernel/traps.c
@@ -1379,6 +1379,7 @@ @@ -1464,6 +1464,7 @@
*/ */
if (cpu_has_mips_r2) { if (cpu_has_mips_r2) {
cp0_compare_irq = (read_c0_intctl() >> 29) & 7; cp0_compare_irq = (read_c0_intctl() >> 29) & 7;

View file

@ -1,7 +1,5 @@
Index: linux-2.6.26.2/drivers/char/Makefile --- a/drivers/char/Makefile
=================================================================== +++ b/drivers/char/Makefile
--- linux-2.6.26.2.orig/drivers/char/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/char/Makefile 2008-09-09 01:45:41.000000000 +0200
@@ -114,6 +114,10 @@ @@ -114,6 +114,10 @@
obj-$(CONFIG_JS_RTC) += js-rtc.o obj-$(CONFIG_JS_RTC) += js-rtc.o
js-rtc-y = rtc.o js-rtc-y = rtc.o
@ -13,19 +11,15 @@ Index: linux-2.6.26.2/drivers/char/Makefile
# Files generated that shall be removed upon make clean # Files generated that shall be removed upon make clean
clean-files := consolemap_deftbl.c defkeymap.c clean-files := consolemap_deftbl.c defkeymap.c
Index: linux-2.6.26.2/drivers/mtd/maps/Makefile --- a/drivers/mtd/maps/Makefile
=================================================================== +++ b/drivers/mtd/maps/Makefile
--- linux-2.6.26.2.orig/drivers/mtd/maps/Makefile 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/mtd/maps/Makefile 2008-09-09 01:45:41.000000000 +0200
@@ -67,3 +67,4 @@ @@ -67,3 +67,4 @@
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o +obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
Index: linux-2.6.26.2/drivers/net/Kconfig --- a/drivers/net/Kconfig
=================================================================== +++ b/drivers/net/Kconfig
--- linux-2.6.26.2.orig/drivers/net/Kconfig 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/net/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -351,6 +351,12 @@ @@ -351,6 +351,12 @@
source "drivers/net/arm/Kconfig" source "drivers/net/arm/Kconfig"
@ -39,10 +33,8 @@ Index: linux-2.6.26.2/drivers/net/Kconfig
config AX88796 config AX88796
tristate "ASIX AX88796 NE2000 clone support" tristate "ASIX AX88796 NE2000 clone support"
depends on ARM || MIPS || SUPERH depends on ARM || MIPS || SUPERH
Index: linux-2.6.26.2/drivers/serial/Kconfig --- a/drivers/serial/Kconfig
=================================================================== +++ b/drivers/serial/Kconfig
--- linux-2.6.26.2.orig/drivers/serial/Kconfig 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/serial/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -1334,6 +1334,14 @@ @@ -1334,6 +1334,14 @@
Currently, only 8250 compatible ports are supported, but Currently, only 8250 compatible ports are supported, but
others can easily be added. others can easily be added.
@ -58,19 +50,15 @@ Index: linux-2.6.26.2/drivers/serial/Kconfig
config SERIAL_QE config SERIAL_QE
tristate "Freescale QUICC Engine serial port support" tristate "Freescale QUICC Engine serial port support"
depends on QUICC_ENGINE depends on QUICC_ENGINE
Index: linux-2.6.26.2/drivers/serial/Makefile --- a/drivers/serial/Makefile
=================================================================== +++ b/drivers/serial/Makefile
--- linux-2.6.26.2.orig/drivers/serial/Makefile 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/serial/Makefile 2008-09-09 01:46:23.000000000 +0200
@@ -68,3 +68,4 @@ @@ -68,3 +68,4 @@
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o +obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
Index: linux-2.6.26.2/drivers/watchdog/Makefile --- a/drivers/watchdog/Makefile
=================================================================== +++ b/drivers/watchdog/Makefile
--- linux-2.6.26.2.orig/drivers/watchdog/Makefile 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/watchdog/Makefile 2008-09-09 01:45:41.000000000 +0200
@@ -97,6 +97,7 @@ @@ -97,6 +97,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
@ -79,20 +67,16 @@ Index: linux-2.6.26.2/drivers/watchdog/Makefile
# PARISC Architecture # PARISC Architecture
Index: linux-2.6.26.2/drivers/net/Makefile --- a/drivers/net/Makefile
=================================================================== +++ b/drivers/net/Makefile
--- linux-2.6.26.2.orig/drivers/net/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/net/Makefile 2008-09-09 01:47:02.000000000 +0200
@@ -256,4 +256,4 @@ @@ -256,4 +256,4 @@
obj-$(CONFIG_NIU) += niu.o obj-$(CONFIG_NIU) += niu.o
obj-$(CONFIG_VIRTIO_NET) += virtio_net.o obj-$(CONFIG_VIRTIO_NET) += virtio_net.o
obj-$(CONFIG_SFC) += sfc/ obj-$(CONFIG_SFC) += sfc/
- -
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o +obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
Index: linux-2.6.26.2/drivers/crypto/Kconfig --- a/drivers/crypto/Kconfig
=================================================================== +++ b/drivers/crypto/Kconfig
--- linux-2.6.26.2.orig/drivers/crypto/Kconfig 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/crypto/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -9,6 +9,9 @@ @@ -9,6 +9,9 @@
If you say N, all options in this submenu will be skipped and disabled. If you say N, all options in this submenu will be skipped and disabled.
@ -103,19 +87,15 @@ Index: linux-2.6.26.2/drivers/crypto/Kconfig
config CRYPTO_DEV_PADLOCK config CRYPTO_DEV_PADLOCK
tristate "Support for VIA PadLock ACE" tristate "Support for VIA PadLock ACE"
Index: linux-2.6.26.2/drivers/crypto/Makefile --- a/drivers/crypto/Makefile
=================================================================== +++ b/drivers/crypto/Makefile
--- linux-2.6.26.2.orig/drivers/crypto/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/crypto/Makefile 2008-09-09 01:47:30.000000000 +0200
@@ -4,3 +4,4 @@ @@ -4,3 +4,4 @@
obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o
obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
+obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o +obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o
Index: linux-2.6.26.2/drivers/usb/host/Kconfig --- a/drivers/usb/host/Kconfig
=================================================================== +++ b/drivers/usb/host/Kconfig
--- linux-2.6.26.2.orig/drivers/usb/host/Kconfig 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/usb/host/Kconfig 2008-09-09 01:48:14.000000000 +0200
@@ -305,3 +305,10 @@ @@ -305,3 +305,10 @@
help help
This driver enables support for the on-chip R8A66597 in the This driver enables support for the on-chip R8A66597 in the
@ -127,10 +107,8 @@ Index: linux-2.6.26.2/drivers/usb/host/Kconfig
+ default y + default y
+ help + help
+ Danube USB Host Controller + Danube USB Host Controller
Index: linux-2.6.26.2/drivers/leds/Kconfig --- a/drivers/leds/Kconfig
=================================================================== +++ b/drivers/leds/Kconfig
--- linux-2.6.26.2.orig/drivers/leds/Kconfig 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/leds/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -153,6 +153,12 @@ @@ -153,6 +153,12 @@
To compile this driver as a module, choose M here: the To compile this driver as a module, choose M here: the
module will be called leds-clevo-mail. module will be called leds-clevo-mail.
@ -144,10 +122,8 @@ Index: linux-2.6.26.2/drivers/leds/Kconfig
comment "LED Triggers" comment "LED Triggers"
config LEDS_TRIGGERS config LEDS_TRIGGERS
Index: linux-2.6.26.2/drivers/leds/Makefile --- a/drivers/leds/Makefile
=================================================================== +++ b/drivers/leds/Makefile
--- linux-2.6.26.2.orig/drivers/leds/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/leds/Makefile 2008-09-09 01:49:25.000000000 +0200
@@ -22,6 +22,7 @@ @@ -22,6 +22,7 @@
obj-$(CONFIG_LEDS_CLEVO_MAIL) += leds-clevo-mail.o obj-$(CONFIG_LEDS_CLEVO_MAIL) += leds-clevo-mail.o
obj-$(CONFIG_LEDS_HP6XX) += leds-hp6xx.o obj-$(CONFIG_LEDS_HP6XX) += leds-hp6xx.o
@ -156,10 +132,8 @@ Index: linux-2.6.26.2/drivers/leds/Makefile
# LED Triggers # LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
Index: linux-2.6.26.2/drivers/watchdog/Kconfig --- a/drivers/watchdog/Kconfig
=================================================================== +++ b/drivers/watchdog/Kconfig
--- linux-2.6.26.2.orig/drivers/watchdog/Kconfig 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/watchdog/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -683,6 +683,12 @@ @@ -683,6 +683,12 @@
help help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs. Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c --- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -1015,7 +1015,9 @@ @@ -1041,7 +1041,9 @@
int retry_cnt = 0; int retry_cnt = 0;
adr += chip->start; adr += chip->start;

View file

@ -11,7 +11,7 @@ BOARD:=iop32x
BOARDNAME:=Intel IOP32x BOARDNAME:=Intel IOP32x
FEATURES:=squashfs jffs2 FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
FEATURES:=squashfs FEATURES:=squashfs
SUBTARGETS=generic harddisk SUBTARGETS=generic harddisk
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -11,7 +11,7 @@ BOARD:=magicbox
BOARDNAME:=Magicbox BOARDNAME:=Magicbox
FEATURES:=squashfs pci FEATURES:=squashfs pci
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
LINUX_KARCH:=ppc LINUX_KARCH:=ppc
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -11,7 +11,7 @@ BOARD:=orion
BOARDNAME:=Marvell Orion BOARDNAME:=Marvell Orion
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -1,6 +1,6 @@
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -2686,12 +2686,10 @@ @@ -2691,12 +2691,10 @@
S: Maintained S: Maintained
MARVELL MV643XX ETHERNET DRIVER MARVELL MV643XX ETHERNET DRIVER

View file

@ -11,7 +11,7 @@ BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
LINUX_KARCH:=powerpc LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs FEATURES:=squashfs
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
LINUX_KARCH:=powerpc LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -10,7 +10,7 @@ ARCH:=powerpc
BOARD:=ps3 BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console BOARDNAME:=Sony PS3 Game Console
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
KERNEL_CC:= KERNEL_CC:=

View file

@ -11,7 +11,7 @@ BOARD:=sibyte
BOARDNAME:=Broadcom/SiByte SB-1 BOARDNAME:=Broadcom/SiByte SB-1
FEATURES:=broken FEATURES:=broken
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext2 FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH) LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
LINUX_VERSION:=2.6.26.3 LINUX_VERSION:=2.6.26.5
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View file

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi FEATURES:=squashfs jffs2 ext2 vdi
SUBTARGETS=generic SUBTARGETS=generic
LINUX_VERSION:=2.6.25.16 LINUX_VERSION:=2.6.25.17
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci