tools: e2fsprogs: bump to 1.43.1
Bump e2fsprogs to v1.43.1 & refresh patches Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
This commit is contained in:
parent
636089ead6
commit
819cf75c40
5 changed files with 6 additions and 16 deletions
|
@ -8,8 +8,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=e2fsprogs
|
||||
PKG_VERSION:=1.42.13
|
||||
PKG_MD5SUM:=bc759fc62666786f5436e2075beb3265
|
||||
PKG_VERSION:=1.43.1
|
||||
PKG_MD5SUM:=1775f3f0eed9dee1c5f39e08d1964a97
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -23,6 +23,7 @@ HOST_CFLAGS += $(FPIC)
|
|||
|
||||
HOST_CONFIGURE_ARGS += \
|
||||
--disable-elf-shlibs \
|
||||
--enable-libuuid \
|
||||
--disable-tls \
|
||||
--disable-nls
|
||||
|
||||
|
|
|
@ -8,4 +8,4 @@
|
|||
+@DEFRAG_CMT@@LINUX_CMT@E4DEFRAG_PROG=
|
||||
@DEFRAG_CMT@@LINUX_CMT@E4DEFRAG_MAN= e4defrag.8
|
||||
|
||||
@IMAGER_CMT@E2IMAGE_PROG= e2image
|
||||
@LINUX_CMT@E4CRYPT_PROG = e4crypt
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/blkid/getsize.c
|
||||
+++ b/lib/blkid/getsize.c
|
||||
@@ -25,6 +25,9 @@
|
||||
@@ -29,6 +29,9 @@
|
||||
#include <fcntl.h>
|
||||
#ifdef HAVE_SYS_IOCTL_H
|
||||
#include <sys/ioctl.h>
|
||||
|
@ -10,13 +10,3 @@
|
|||
#endif
|
||||
#ifdef HAVE_LINUX_FD_H
|
||||
#include <linux/fd.h>
|
||||
--- a/lib/quota/mkquota.c
|
||||
+++ b/lib/quota/mkquota.c
|
||||
@@ -8,6 +8,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <unistd.h>
|
||||
#include <errno.h>
|
||||
+#include <stdint.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/ext2fs/tdb.c
|
||||
+++ b/lib/ext2fs/tdb.c
|
||||
@@ -56,7 +56,9 @@
|
||||
@@ -58,7 +58,9 @@ Last Changed Date: 2007-06-22 13:36:10 -
|
||||
#include <utime.h>
|
||||
#endif
|
||||
#include <sys/stat.h>
|
||||
|
|
|
@ -20,4 +20,3 @@
|
|||
#ifndef HAVE___U8
|
||||
#define HAVE___U8
|
||||
#ifdef __U8_TYPEDEF
|
||||
|
||||
|
|
Loading…
Reference in a new issue