authsae: remove package
It is no longer actively maintained and does not work well in many configurations. Fully replaced by wpad-mesh Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
644a0d5403
commit
8061c62f5d
3 changed files with 0 additions and 131 deletions
|
@ -1,46 +0,0 @@
|
|||
|
||||
# Copyright (C) 2007-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=authsae
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/cozybit/authsae.git
|
||||
PKG_SOURCE_DATE:=2014-06-09
|
||||
PKG_SOURCE_VERSION:=8531ab158910a525d4bcbb3ad02c08342f6987f2
|
||||
PKG_MIRROR_HASH:=a8fbed9eada17c552c70d834ee8f7c1e0987df59839bc113b3ec000500696715
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
CMAKE_OPTIONS += -DSYSCONF_INSTALL_DIR=/etc
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=BSD-4-Clause
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
||||
define Package/authsae
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=80211s mesh security
|
||||
DEPENDS:=+libopenssl +libconfig +libnl-tiny +@OPENSSL_WITH_EC
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -D_GNU_SOURCE
|
||||
|
||||
define Package/authsae/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
|
||||
$(INSTALL_DIR) $(1)/lib/wifi
|
||||
$(INSTALL_DATA) ./files/lib/wifi/authsae.sh $(1)/lib/wifi/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,authsae))
|
|
@ -1,65 +0,0 @@
|
|||
authsae_start_interface() {
|
||||
local mcast_rate
|
||||
local mesh_htmode
|
||||
local mesh_band
|
||||
local authsae_conf_file="/var/run/authsae-$ifname.cfg"
|
||||
local ret=1
|
||||
|
||||
json_get_vars mcast_rate mesh_id
|
||||
set_default mcast_rate "12000"
|
||||
|
||||
case "$htmode" in
|
||||
HT20|HT40+|HT40-) mesh_htmode="$htmode";;
|
||||
*) mesh_htmode="none";;
|
||||
esac
|
||||
|
||||
case "$hwmode" in
|
||||
*g*) mesh_band=11g;;
|
||||
*a*) mesh_band=11a;;
|
||||
esac
|
||||
|
||||
if [ "$mcast_rate" -gt 1000 ]; then
|
||||
# authsae only allows integers as rates and not things like 5.5
|
||||
mcval=$(($mcast_rate / 1000))
|
||||
else
|
||||
# compat: to still support mbit/s rates
|
||||
mcval="$mcast_rate"
|
||||
fi
|
||||
|
||||
cat > "$authsae_conf_file" <<EOF
|
||||
authsae:
|
||||
{
|
||||
sae:
|
||||
{
|
||||
debug = 0;
|
||||
password = "$key";
|
||||
group = [19, 26, 21, 25, 20];
|
||||
blacklist = 5;
|
||||
thresh = 5;
|
||||
lifetime = 3600;
|
||||
};
|
||||
meshd:
|
||||
{
|
||||
meshid = "$mesh_id";
|
||||
interface = "$ifname";
|
||||
passive = 0;
|
||||
debug = 0;
|
||||
mediaopt = 1;
|
||||
band = "$mesh_band";
|
||||
channel = $channel;
|
||||
htmode = "$mesh_htmode";
|
||||
mcast-rate = $mcval;
|
||||
};
|
||||
};
|
||||
EOF
|
||||
|
||||
/usr/bin/meshd-nl80211 -i "$ifname" -s "$mesh_id" -c "$authsae_conf_file" </dev/null >/dev/null 2>/dev/null &
|
||||
authsae_pid="$!"
|
||||
ret="$?"
|
||||
|
||||
echo $authsae_pid > /var/run/authsae-$ifname.pid
|
||||
wireless_add_process "$authsae_pid" "/usr/bin/meshd-nl80211" 1
|
||||
|
||||
[ "$ret" != 0 ] && wireless_setup_vif_failed AUTHSAE_FAILED
|
||||
return $ret
|
||||
}
|
|
@ -1,20 +0,0 @@
|
|||
--- a/linux/mon.c
|
||||
+++ b/linux/mon.c
|
||||
@@ -44,7 +44,6 @@
|
||||
#include <signal.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/sysctl.h>
|
||||
#include <sys/queue.h>
|
||||
#include <netinet/in.h>
|
||||
#include <net/if.h>
|
||||
--- a/linux/meshd.c
|
||||
+++ b/linux/meshd.c
|
||||
@@ -44,7 +44,6 @@
|
||||
#include <signal.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/sysctl.h>
|
||||
#include <sys/queue.h>
|
||||
#include <netinet/in.h>
|
||||
#include <net/if.h>
|
Loading…
Reference in a new issue