fix package name in template call, remove unneeded patch, don't use PKG_INSTALL_DIR since upstream does not provide a make install target, add configurable init script, add Id tag and target optimization cflags..
SVN-Revision: 2674
This commit is contained in:
parent
c7221546a1
commit
7ec285553e
7 changed files with 48 additions and 31 deletions
15
openwrt/package/vrrpd/Config.in
Executable file → Normal file
15
openwrt/package/vrrpd/Config.in
Executable file → Normal file
|
@ -3,10 +3,11 @@ config BR2_PACKAGE_VRRPD
|
||||||
tristate
|
tristate
|
||||||
default m if CONFIG_DEVEL
|
default m if CONFIG_DEVEL
|
||||||
help
|
help
|
||||||
VRRPd is an implementation of Virtual Router Redundancy
|
VRRPd is an implementation of Virtual Router Redundancy
|
||||||
Protocol as specified in rfc2338. VRRPd is interoperable with
|
Protocol as specified in rfc2338. VRRPd is interoperable with
|
||||||
other RFC-based VRRP implementations, including Cisco and
|
other RFC-based VRRP implementations, including Cisco and
|
||||||
Juniper, and is included as a standard feature on ImageStream
|
Juniper, and is included as a standard feature on ImageStream
|
||||||
routers.
|
routers.
|
||||||
|
|
||||||
http://www.sourceforge.net/projects/vrrpd
|
http://www.sourceforge.net/projects/vrrpd
|
||||||
|
|
||||||
|
|
22
openwrt/package/vrrpd/Makefile
Executable file → Normal file
22
openwrt/package/vrrpd/Makefile
Executable file → Normal file
|
@ -1,33 +1,35 @@
|
||||||
|
# $Id$
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=vrrpd
|
PKG_NAME:=vrrpd
|
||||||
PKG_VERSION:=1.0
|
PKG_VERSION:=1.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
|
PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
|
||||||
PKG_SOURCE_URL:=@SF/vrrpd
|
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=@SF/vrrpd
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
$(eval $(call PKG_template,VRRPD,VRRPD,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,VRRPD,vrrpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
$(PKG_BUILD_DIR)/.configured:
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.built:
|
$(PKG_BUILD_DIR)/.built:
|
||||||
mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
$(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
|
CC=$(TARGET_CC) \
|
||||||
install -m0755 $(PKG_BUILD_DIR)/vrrpd $(PKG_INSTALL_DIR)/usr/sbin/
|
DBG_OPT="" \
|
||||||
|
MAIN_OPT="$(TARGET_CFLAGS)" \
|
||||||
|
vrrpd
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(IPKG_VRRPD):
|
$(IPKG_VRRPD):
|
||||||
mkdir -p $(IDIR_VRRPD)
|
install -d -m0755 $(IDIR_VRRPD)/usr/sbin
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VRRPD)/
|
install -m0755 $(PKG_BUILD_DIR)/vrrpd $(IDIR_VRRPD)/usr/sbin/
|
||||||
$(RSTRIP) $(IDIR_VRRPD)
|
$(RSTRIP) $(IDIR_VRRPD)
|
||||||
$(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)
|
||||||
|
|
4
openwrt/package/vrrpd/files/vrrpd.default
Normal file
4
openwrt/package/vrrpd/files/vrrpd.default
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
ID=1
|
||||||
|
IF=vlan1
|
||||||
|
IP=10.0.0.1
|
||||||
|
OPTIONS="-i $IF -v $ID $IP"
|
21
openwrt/package/vrrpd/files/vrrpd.init
Normal file
21
openwrt/package/vrrpd/files/vrrpd.init
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
BIN=vrrpd
|
||||||
|
DEFAULT=/etc/default/$BIN
|
||||||
|
[ -f $DEFAULT ] && . $DEFAULT
|
||||||
|
RUN_D=/var/run
|
||||||
|
PID_F=$RUN_D/$BIN_${IF}_${ID}.pid
|
||||||
|
|
||||||
|
case $1 in
|
||||||
|
start)
|
||||||
|
$BIN $OPTIONS
|
||||||
|
;;
|
||||||
|
stop)
|
||||||
|
[ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
echo "usage: $0 (start|stop)"
|
||||||
|
exit 1
|
||||||
|
esac
|
||||||
|
|
||||||
|
exit $?
|
1
openwrt/package/vrrpd/ipkg/vrrpd.conffiles
Normal file
1
openwrt/package/vrrpd/ipkg/vrrpd.conffiles
Normal file
|
@ -0,0 +1 @@
|
||||||
|
/etc/default/vrrpd
|
5
openwrt/package/vrrpd/ipkg/vrrpd.control
Executable file → Normal file
5
openwrt/package/vrrpd/ipkg/vrrpd.control
Executable file → Normal file
|
@ -1,5 +1,4 @@
|
||||||
Package: vrrpd
|
Package: vrrpd
|
||||||
Section: net
|
|
||||||
Architecture: mipsel
|
|
||||||
Priority: optional
|
Priority: optional
|
||||||
Description: VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338.
|
Section: net
|
||||||
|
Description: An implementation of the Virtual Router Redundancy Protocol
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
diff -urN orig/vrrpd-1.0/Makefile vrrpd-1.0/Makefile
|
|
||||||
--- orig/vrrpd-1.0/Makefile 2002-09-09 16:51:13.000000000 +0200
|
|
||||||
+++ vrrpd-1.0/Makefile 2005-12-12 23:31:30.000000000 +0100
|
|
||||||
@@ -15,7 +15,6 @@
|
|
||||||
COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
|
|
||||||
|
|
||||||
# set to compile with GCC
|
|
||||||
-CC=gcc
|
|
||||||
CFLAGS= $(COMMON_CFLAGS) -Wall
|
|
||||||
|
|
||||||
vrrpd : $(VRRPD_OBJS)
|
|
Loading…
Reference in a new issue