grub2: Fix CVE-2015-8370
This CVE is a culmination of multiple integer overflow issues that cause multiple issues like Denial of Service and authentication bypass. More info: https://nvd.nist.gov/vuln/detail/CVE-2015-8370 Taken from Fedora. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
f9469efbfa
commit
7e73e9128f
2 changed files with 45 additions and 1 deletions
|
@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||||
PKG_NAME:=grub
|
PKG_NAME:=grub
|
||||||
PKG_CPE_ID:=cpe:/a:gnu:grub2
|
PKG_CPE_ID:=cpe:/a:gnu:grub2
|
||||||
PKG_VERSION:=2.02
|
PKG_VERSION:=2.02
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/grub
|
PKG_SOURCE_URL:=@GNU/grub
|
||||||
|
|
44
package/boot/grub2/patches/300-CVE-2015-8370.patch
Normal file
44
package/boot/grub2/patches/300-CVE-2015-8370.patch
Normal file
|
@ -0,0 +1,44 @@
|
||||||
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Hector Marco-Gisbert <hecmargi@upv.es>
|
||||||
|
Date: Fri, 13 Nov 2015 16:21:09 +0100
|
||||||
|
Subject: [PATCH] Fix security issue when reading username and password
|
||||||
|
|
||||||
|
This patch fixes two integer underflows at:
|
||||||
|
* grub-core/lib/crypto.c
|
||||||
|
* grub-core/normal/auth.c
|
||||||
|
|
||||||
|
Resolves: CVE-2015-8370
|
||||||
|
|
||||||
|
Signed-off-by: Hector Marco-Gisbert <hecmargi@upv.es>
|
||||||
|
Signed-off-by: Ismael Ripoll-Ripoll <iripoll@disca.upv.es>
|
||||||
|
---
|
||||||
|
grub-core/lib/crypto.c | 2 +-
|
||||||
|
grub-core/normal/auth.c | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/grub-core/lib/crypto.c b/grub-core/lib/crypto.c
|
||||||
|
index ca334d5a40e..e6c78d16d39 100644
|
||||||
|
--- a/grub-core/lib/crypto.c
|
||||||
|
+++ b/grub-core/lib/crypto.c
|
||||||
|
@@ -468,7 +468,7 @@ grub_password_get (char buf[], unsigned buf_size)
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (key == '\b')
|
||||||
|
+ if (key == '\b' && cur_len)
|
||||||
|
{
|
||||||
|
if (cur_len)
|
||||||
|
cur_len--;
|
||||||
|
diff --git a/grub-core/normal/auth.c b/grub-core/normal/auth.c
|
||||||
|
index 6be678c0de1..c35ce972473 100644
|
||||||
|
--- a/grub-core/normal/auth.c
|
||||||
|
+++ b/grub-core/normal/auth.c
|
||||||
|
@@ -172,7 +172,7 @@ grub_username_get (char buf[], unsigned buf_size)
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (key == GRUB_TERM_BACKSPACE)
|
||||||
|
+ if (key == GRUB_TERM_BACKSPACE && cur_len)
|
||||||
|
{
|
||||||
|
if (cur_len)
|
||||||
|
{
|
Loading…
Reference in a new issue