valgrind: update to 3.12.0
Support for MIPS toolchains without FPU support was added upstream, so remove our patch. patches/310-mips-link-tool.patch was a backport form this version of valgrind src/abort.c is not referenced anywhere Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
4e07167eff
commit
7e6c53dac9
5 changed files with 8 additions and 101 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=valgrind
|
||||
PKG_VERSION:=3.11.0
|
||||
PKG_VERSION:=3.12.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://valgrind.org/downloads/
|
||||
PKG_MD5SUM:=6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2413b42
|
||||
PKG_MD5SUM:=67ca4395b2527247780f36148b084f5743a68ab0c850cb43e4a5b4b012cf76a1
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
|
|
|
@ -1,52 +0,0 @@
|
|||
--- a/VEX/priv/guest_mips_helpers.c
|
||||
+++ b/VEX/priv/guest_mips_helpers.c
|
||||
@@ -1201,6 +1201,7 @@ extern UInt mips_dirtyhelper_calculate_F
|
||||
flt_op inst )
|
||||
{
|
||||
UInt ret = 0;
|
||||
+#ifndef __mips_soft_float
|
||||
#if defined(__mips__)
|
||||
VexGuestMIPS32State* guest_state = (VexGuestMIPS32State*)gs;
|
||||
UInt loFsVal, hiFsVal, loFtVal, hiFtVal;
|
||||
@@ -1320,6 +1321,7 @@ extern UInt mips_dirtyhelper_calculate_F
|
||||
break;
|
||||
}
|
||||
#endif
|
||||
+#endif
|
||||
return ret;
|
||||
}
|
||||
|
||||
@@ -1329,6 +1331,7 @@ extern UInt mips_dirtyhelper_calculate_F
|
||||
flt_op inst )
|
||||
{
|
||||
UInt ret = 0;
|
||||
+#ifndef __mips_soft_float
|
||||
#if defined(__mips__)
|
||||
#if defined(VGA_mips32)
|
||||
VexGuestMIPS32State* guest_state = (VexGuestMIPS32State*)gs;
|
||||
@@ -1439,6 +1442,7 @@ extern UInt mips_dirtyhelper_calculate_F
|
||||
break;
|
||||
}
|
||||
#endif
|
||||
+#endif
|
||||
return ret;
|
||||
}
|
||||
|
||||
--- a/coregrind/m_machine.c
|
||||
+++ b/coregrind/m_machine.c
|
||||
@@ -1652,6 +1652,7 @@ Bool VG_(machine_get_hwcaps)( void )
|
||||
}
|
||||
}
|
||||
|
||||
+#ifndef __mips_soft_float
|
||||
/* Check if CPU has FPU and 32 dbl. prec. FP registers */
|
||||
int FIR = 0;
|
||||
__asm__ __volatile__(
|
||||
@@ -1661,6 +1662,7 @@ Bool VG_(machine_get_hwcaps)( void )
|
||||
if (FIR & (1 << FP64)) {
|
||||
vai.hwcaps |= VEX_PRID_CPU_32FPR;
|
||||
}
|
||||
+#endif
|
||||
|
||||
VG_(convert_sigaction_fromK_to_toK)(&saved_sigill_act, &tmp_sigill_act);
|
||||
VG_(sigaction)(VKI_SIGILL, &tmp_sigill_act, NULL);
|
|
@ -1,8 +1,8 @@
|
|||
--- a/coregrind/vg_preloaded.c
|
||||
+++ b/coregrind/vg_preloaded.c
|
||||
@@ -56,7 +56,7 @@
|
||||
void VG_NOTIFY_ON_LOAD(freeres)( void );
|
||||
void VG_NOTIFY_ON_LOAD(freeres)( void )
|
||||
@@ -57,7 +57,7 @@
|
||||
void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run);
|
||||
void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run)
|
||||
{
|
||||
-# if !defined(__UCLIBC__) \
|
||||
+# if !defined(__UCLIBC__) && defined(__GLIBC__) \
|
||||
|
@ -11,7 +11,7 @@
|
|||
&& !defined(VGPV_mips32_linux_android) \
|
||||
--- a/include/pub_tool_redir.h
|
||||
+++ b/include/pub_tool_redir.h
|
||||
@@ -242,7 +242,7 @@
|
||||
@@ -243,7 +243,7 @@
|
||||
/* --- Soname of the standard C library. --- */
|
||||
|
||||
#if defined(VGO_linux) || defined(VGO_solaris)
|
||||
|
@ -20,7 +20,7 @@
|
|||
|
||||
#elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
|
||||
# define VG_Z_LIBC_SONAME libSystemZdZaZddylib // libSystem.*.dylib
|
||||
@@ -274,7 +274,11 @@
|
||||
@@ -275,7 +275,11 @@
|
||||
/* --- Soname of the pthreads library. --- */
|
||||
|
||||
#if defined(VGO_linux)
|
||||
|
@ -34,7 +34,7 @@
|
|||
#elif defined(VGO_solaris)
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1066,8 +1066,6 @@ case "${GLIBC_VERSION}" in
|
||||
@@ -1047,8 +1047,6 @@ case "${GLIBC_VERSION}" in
|
||||
;;
|
||||
2.0|2.1|*)
|
||||
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
r15754 | petarj | 2015-12-29 20:14:37 +0100 (Tue, 29 Dec 2015) | 8 lines
|
||||
|
||||
mips: remove link script exception for MIPS arch
|
||||
|
||||
Current toolchains on MIPS targets that we care about are reasonably
|
||||
modern and we do not need this link script exception for MIPS anymore.
|
||||
|
||||
This should fix issues with newer toolchain versions and .MIPS.abiflags
|
||||
section.
|
||||
|
||||
--- a/coregrind/link_tool_exe_linux.in
|
||||
+++ b/coregrind/link_tool_exe_linux.in
|
||||
@@ -69,24 +69,7 @@ shift; # Remove $ala from @ARGV
|
||||
die "Bogus alt-load address"
|
||||
if (length($ala) < 3 || index($ala, "0x") != 0);
|
||||
|
||||
-# For mips32 or mips64 we need to use "--section-start=.reginfo=$ala" or
|
||||
-# "--section-start=.MIPS.options=$ala" respectively, because "-Ttext=$ala" will
|
||||
-# not put all the sections to the specificed address ($ala).
|
||||
-my $x = `cat ../config.log 2>&1 | grep host_cpu= | sed "s/host_cpu='//g"`;
|
||||
-my $arch = substr($x, 0, index($x, "'"));
|
||||
-
|
||||
-my $extra_args;
|
||||
-if (($arch eq 'mips') || ($arch eq 'mipsel')
|
||||
- || ($arch eq 'mipsisa32r2el')) {
|
||||
- $extra_args = "-static -Wl,--section-start=.reginfo=$ala";
|
||||
-} elsif (($arch eq 'mips64') || ($arch eq 'mips64el') ||
|
||||
- ($arch eq 'mipsisa64el')) {
|
||||
- $extra_args = "-static -Wl,--section-start=.MIPS.options=$ala";
|
||||
-} else {
|
||||
- $extra_args = "-static -Wl,@FLAG_T_TEXT@=$ala";
|
||||
-}
|
||||
-
|
||||
-my $cmd = join(" ", @ARGV, $extra_args);
|
||||
+my $cmd = join(" ", @ARGV, "-static -Wl,@FLAG_T_TEXT@=$ala");
|
||||
|
||||
#print "link_tool_exe_linux: $cmd\n";
|
||||
|
|
@ -1,3 +0,0 @@
|
|||
void abort(void)
|
||||
{
|
||||
}
|
Loading…
Reference in a new issue