musl: update to version 1.1.14
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48762
This commit is contained in:
parent
b4a1bd8992
commit
796968fc0f
7 changed files with 8 additions and 17926 deletions
|
@ -3,6 +3,6 @@ if USE_MUSL
|
|||
config MUSL_VERSION
|
||||
string
|
||||
depends on USE_MUSL
|
||||
default "1.1.12"
|
||||
default "1.1.14"
|
||||
|
||||
endif
|
||||
|
|
|
@ -11,7 +11,7 @@ PKG_NAME:=musl
|
|||
PKG_VERSION:=$(call qstrip,$(CONFIG_MUSL_VERSION))
|
||||
PKG_RELEASE=1
|
||||
|
||||
PKG_MD5SUM:=42875e0c111aa1cb9d08663f8d42c799
|
||||
PKG_MD5SUM:=d529ce4a2f7f79d8c3fd4b8329417b57
|
||||
|
||||
PKG_SOURCE_URL:=http://www.musl-libc.org/releases
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -604,6 +604,10 @@ trycppif "_MIPSEL || __MIPSEL || __MIPSE
|
||||
@@ -615,6 +615,10 @@ trycppif "_MIPSEL || __MIPSEL || __MIPSE
|
||||
trycppif __mips_soft_float "$t" && SUBARCH=${SUBARCH}-sf
|
||||
fi
|
||||
|
||||
|
|
|
@ -1,55 +0,0 @@
|
|||
From: Felix Fietkau <nbd@openwrt.org>
|
||||
Date: Sat, 30 Jan 2016 19:19:08 +0100
|
||||
Subject: [PATCH] ldso: fix GDB dynamic linker info on MIPS
|
||||
|
||||
GDB is looking for a pointer to the ldso debug info in the data of the
|
||||
.rld_map section.
|
||||
|
||||
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||
---
|
||||
|
||||
--- a/arch/mips/reloc.h
|
||||
+++ b/arch/mips/reloc.h
|
||||
@@ -24,7 +24,7 @@
|
||||
#define REL_TPOFF R_MIPS_TLS_TPREL32
|
||||
|
||||
#define NEED_MIPS_GOT_RELOCS 1
|
||||
-#define DYNAMIC_IS_RO 1
|
||||
+#define DT_DEBUG_INDIRECT DT_MIPS_RLD_MAP
|
||||
#define ARCH_SYM_REJECT_UND(s) (!((s)->st_other & STO_MIPS_PLT))
|
||||
|
||||
#define CRTJMP(pc,sp) __asm__ __volatile__( \
|
||||
--- a/ldso/dynlink.c
|
||||
+++ b/ldso/dynlink.c
|
||||
@@ -1582,11 +1582,14 @@ _Noreturn void __dls3(size_t *sp)
|
||||
load_deps(&app);
|
||||
make_global(&app);
|
||||
|
||||
-#ifndef DYNAMIC_IS_RO
|
||||
- for (i=0; app.dynv[i]; i+=2)
|
||||
- if (app.dynv[i]==DT_DEBUG)
|
||||
+ for (i=0; app.dynv[i]; i+=2) {
|
||||
+ if (!DT_DEBUG_INDIRECT && app.dynv[i]==DT_DEBUG)
|
||||
app.dynv[i+1] = (size_t)&debug;
|
||||
-#endif
|
||||
+ if (DT_DEBUG_INDIRECT && app.dynv[i]==DT_DEBUG_INDIRECT) {
|
||||
+ size_t *ptr = (size_t *) app.dynv[i+1];
|
||||
+ *ptr = (size_t)&debug;
|
||||
+ }
|
||||
+ }
|
||||
|
||||
/* The main program must be relocated LAST since it may contin
|
||||
* copy relocations which depend on libraries' relocations. */
|
||||
--- a/src/internal/dynlink.h
|
||||
+++ b/src/internal/dynlink.h
|
||||
@@ -83,6 +83,10 @@ struct fdpic_dummy_loadmap {
|
||||
#define NEED_MIPS_GOT_RELOCS 0
|
||||
#endif
|
||||
|
||||
+#ifndef DT_DEBUG_INDIRECT
|
||||
+#define DT_DEBUG_INDIRECT 0
|
||||
+#endif
|
||||
+
|
||||
#define AUX_CNT 32
|
||||
#define DYN_CNT 32
|
||||
|
|
@ -12,7 +12,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -60,7 +60,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
|
||||
@@ -66,7 +66,7 @@ CRT_LIBS = $(addprefix lib/,$(notdir $(C
|
||||
STATIC_LIBS = lib/libc.a
|
||||
SHARED_LIBS = lib/libc.so
|
||||
TOOL_LIBS = lib/musl-gcc.specs
|
||||
|
@ -21,7 +21,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||
ALL_TOOLS = obj/musl-gcc
|
||||
|
||||
WRAPCC_GCC = gcc
|
||||
@@ -123,7 +123,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
|
||||
@@ -125,7 +125,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
|
||||
src/thread/__set_thread_area.c src/thread/$(ARCH)/__set_thread_area.c \
|
||||
src/string/memset.c src/string/$(ARCH)/memset.c \
|
||||
src/string/memcpy.c src/string/$(ARCH)/memcpy.c \
|
||||
|
@ -30,8 +30,8 @@ Signed-off-by: Steven Barth <steven@midlink.org>
|
|||
+ src/libssp_nonshared/__stack_chk_fail_local.c
|
||||
$(NOSSP_SRCS:%.c=obj/%.o) $(NOSSP_SRCS:%.c=obj/%.lo): CFLAGS_ALL += $(CFLAGS_NOSSP)
|
||||
|
||||
$(CRT_LIBS:lib/%=obj/crt/%): CFLAGS_ALL += -DCRT
|
||||
@@ -167,6 +168,11 @@ lib/libc.a: $(AOBJS)
|
||||
$(CRT_OBJS): CFLAGS_ALL += -DCRT
|
||||
@@ -168,6 +169,11 @@ lib/libc.a: $(AOBJS)
|
||||
$(AR) rc $@ $(AOBJS)
|
||||
$(RANLIB) $@
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -219,7 +219,7 @@ $(DESTDIR)$(includedir)/%: $(srcdir)/inc
|
||||
@@ -217,7 +217,7 @@ $(DESTDIR)$(includedir)/%: $(srcdir)/inc
|
||||
$(INSTALL) -D -m 644 $< $@
|
||||
|
||||
$(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(libdir)/libc.so
|
||||
|
|
Loading…
Reference in a new issue