packages: bump uboot-mxs to 2016.01, refresh patches
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 48374
This commit is contained in:
parent
e62802752e
commit
76b903a415
3 changed files with 7 additions and 18 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2013-2015 OpenWrt.org
|
# Copyright (C) 2013-2016 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=u-boot
|
PKG_NAME:=u-boot
|
||||||
PKG_VERSION:=2015.07
|
PKG_VERSION:=2016.01
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
http://mirror2.openwrt.org/sources \
|
http://mirror2.openwrt.org/sources \
|
||||||
ftp://ftp.denx.de/pub/u-boot
|
ftp://ftp.denx.de/pub/u-boot
|
||||||
PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
|
PKG_MD5SUM:=7d4f65fd43d4d706f5c5650e020d899d
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
||||||
PKG_LICENSE_FILES:=Licenses/README
|
PKG_LICENSE_FILES:=Licenses/README
|
||||||
|
@ -30,11 +30,11 @@ define uboot/Default
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define uboot/mx23_olinuxino
|
define uboot/mx23_olinuxino
|
||||||
TITLE:=U-Boot 2015.07 for the Olinuxino i.MX233
|
TITLE:=U-Boot 2016.01 for the Olinuxino i.MX233
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define uboot/duckbill
|
define uboot/duckbill
|
||||||
TITLE:=U-Boot 2015.07 for the I2SE Duckbill
|
TITLE:=U-Boot 2016.01 for the I2SE Duckbill
|
||||||
endef
|
endef
|
||||||
|
|
||||||
UBOOTS := \
|
UBOOTS := \
|
||||||
|
|
|
@ -40,11 +40,11 @@ Signed-off-by: Michael Heimpold <mhei@heimpold.de>
|
||||||
@@ -926,6 +931,7 @@ source "board/genesi/mx51_efikamx/Kconfi
|
@@ -926,6 +931,7 @@ source "board/genesi/mx51_efikamx/Kconfi
|
||||||
source "board/gumstix/pepper/Kconfig"
|
source "board/gumstix/pepper/Kconfig"
|
||||||
source "board/h2200/Kconfig"
|
source "board/h2200/Kconfig"
|
||||||
source "board/hale/tt01/Kconfig"
|
source "board/hisilicon/hikey/Kconfig"
|
||||||
+source "board/i2se/duckbill/Kconfig"
|
+source "board/i2se/duckbill/Kconfig"
|
||||||
source "board/icpdas/lp8x4x/Kconfig"
|
|
||||||
source "board/imx31_phycore/Kconfig"
|
source "board/imx31_phycore/Kconfig"
|
||||||
source "board/isee/igep0033/Kconfig"
|
source "board/isee/igep0033/Kconfig"
|
||||||
|
source "board/maxbcm/Kconfig"
|
||||||
--- a/arch/arm/include/asm/mach-types.h
|
--- a/arch/arm/include/asm/mach-types.h
|
||||||
+++ b/arch/arm/include/asm/mach-types.h
|
+++ b/arch/arm/include/asm/mach-types.h
|
||||||
@@ -1109,6 +1109,7 @@ extern unsigned int __machine_arch_type;
|
@@ -1109,6 +1109,7 @@ extern unsigned int __machine_arch_type;
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/arch/arm/cpu/arm926ejs/mxs/mxs.c
|
|
||||||
+++ b/arch/arm/cpu/arm926ejs/mxs/mxs.c
|
|
||||||
@@ -24,7 +24,7 @@
|
|
||||||
DECLARE_GLOBAL_DATA_PTR;
|
|
||||||
|
|
||||||
/* Lowlevel init isn't used on i.MX28, so just have a dummy here */
|
|
||||||
-inline void lowlevel_init(void) {}
|
|
||||||
+void lowlevel_init(void) {}
|
|
||||||
|
|
||||||
void reset_cpu(ulong ignored) __attribute__((noreturn));
|
|
||||||
|
|
Loading…
Reference in a new issue