change fixup method and fix CFLAGS handling
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39151
This commit is contained in:
parent
41cbd0a389
commit
72f00c8de4
3 changed files with 14 additions and 3 deletions
|
@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=cyassl
|
PKG_NAME:=cyassl
|
||||||
PKG_VERSION:=2.8.0
|
PKG_VERSION:=2.8.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
||||||
PKG_SOURCE_URL:=http://www.yassl.com/
|
PKG_SOURCE_URL:=http://www.yassl.com/
|
||||||
PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
|
PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
|
||||||
|
|
||||||
PKG_FIXUP:=patch-libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
|
|
11
package/libs/cyassl/patches/100-respect_cflags.patch
Normal file
11
package/libs/cyassl/patches/100-respect_cflags.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -42,7 +42,7 @@ AC_SUBST([CYASSL_LIBRARY_VERSION])
|
||||||
|
|
||||||
|
# capture user C_EXTRA_FLAGS from ./configure line, CFLAGS may hold -g -O2 even
|
||||||
|
# if user doesn't override, no way to tell
|
||||||
|
-USER_C_EXTRA_FLAGS="$C_EXTRA_FLAGS"
|
||||||
|
+USER_C_EXTRA_FLAGS="$CFLAGS"
|
||||||
|
|
||||||
|
LT_PREREQ([2.2])
|
||||||
|
LT_INIT([disable-static],[win32-dll])
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/internal.c
|
--- a/src/internal.c
|
||||||
+++ b/src/internal.c
|
+++ b/src/internal.c
|
||||||
@@ -4622,6 +4622,10 @@
|
@@ -4622,6 +4622,10 @@ int ProcessReply(CYASSL* ssl)
|
||||||
b1 =
|
b1 =
|
||||||
ssl->buffers.inputBuffer.buffer[ssl->buffers.inputBuffer.idx++];
|
ssl->buffers.inputBuffer.buffer[ssl->buffers.inputBuffer.idx++];
|
||||||
ssl->curSize = ((b0 & 0x7f) << 8) | b1;
|
ssl->curSize = ((b0 & 0x7f) << 8) | b1;
|
||||||
|
|
Loading…
Reference in a new issue