fuse: update to 2.9.0
SVN-Revision: 32396
This commit is contained in:
parent
50958f5e03
commit
70d9295138
3 changed files with 3 additions and 49 deletions
|
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=fuse
|
PKG_NAME:=fuse
|
||||||
PKG_VERSION:=2.8.5
|
PKG_VERSION:=2.9.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||||
PKG_MD5SUM:=8aa2fd689de00b73963620483084ae3b
|
PKG_MD5SUM:=894ee11674f89a915ae87524aed55bc4
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/util/Makefile.in
|
--- a/util/Makefile.in
|
||||||
+++ b/util/Makefile.in
|
+++ b/util/Makefile.in
|
||||||
@@ -584,7 +584,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
@@ -641,7 +641,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
|
||||||
|
|
||||||
install-exec-hook:
|
install-exec-hook:
|
||||||
-chmod u+s $(DESTDIR)$(bindir)/fusermount
|
-chmod u+s $(DESTDIR)$(bindir)/fusermount
|
||||||
|
|
|
@ -1,46 +0,0 @@
|
||||||
--- a/lib/helper.c
|
|
||||||
+++ b/lib/helper.c
|
|
||||||
@@ -180,13 +180,41 @@ err:
|
|
||||||
int fuse_daemonize(int foreground)
|
|
||||||
{
|
|
||||||
int res;
|
|
||||||
+ int fd;
|
|
||||||
|
|
||||||
if (!foreground) {
|
|
||||||
- res = daemon(0, 0);
|
|
||||||
+ /* uClibc daemon() has problems with pthread and friends */
|
|
||||||
+ /* workaround from http://www.mail-archive.com/uclibc@uclibc.org/msg01073.html */
|
|
||||||
+ /* res = daemon(0, 0); */
|
|
||||||
+ switch (res = fork()) {
|
|
||||||
+ case -1:
|
|
||||||
+ return(-1);
|
|
||||||
+ case 0:
|
|
||||||
+ break;
|
|
||||||
+ default:
|
|
||||||
+ _exit(0);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if (res == -1) {
|
|
||||||
- perror("fuse: failed to daemonize program\n");
|
|
||||||
+ perror("fuse: failed to fork()\n");
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ res=setsid();
|
|
||||||
+
|
|
||||||
+ if (res == -1) {
|
|
||||||
+ perror("fuse: failed to setsid()\n");
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ chdir("/");
|
|
||||||
+
|
|
||||||
+ if (fd = open("/dev/null", O_RDWR, 0) != -1) {
|
|
||||||
+ dup2(fd, STDIN_FILENO);
|
|
||||||
+ dup2(fd, STDOUT_FILENO);
|
|
||||||
+ dup2(fd, STDERR_FILENO);
|
|
||||||
+ if (fd > 2)
|
|
||||||
+ close(fd);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
return 0;
|
|
||||||
}
|
|
Loading…
Reference in a new issue