iproute2: update to 3.11
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38313
This commit is contained in:
parent
64c2bc256c
commit
702936f4c9
5 changed files with 6 additions and 18 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=3.10.0
|
||||
PKG_VERSION:=3.11.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
|
||||
PKG_MD5SUM:=45fb5427fc723a0001c72b92c931ba02
|
||||
PKG_MD5SUM:=d7ffb27bc9f0d80577b1f3fb9d1a7689
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -30,8 +30,7 @@ CC = gcc
|
||||
HOSTCC = gcc
|
||||
DEFINES += -D_GNU_SOURCE
|
||||
CCOPTS = -O2
|
||||
-WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
|
||||
-WFLAGS += -Wmissing-declarations -Wold-style-definition
|
||||
+WFLAGS := -Wall -Wstrict-prototypes
|
||||
|
||||
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
|
||||
YACCFLAGS = -d -t -v
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -35,7 +35,7 @@ WFLAGS := -Wall -Wstrict-prototypes
|
||||
@@ -36,7 +36,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
|
||||
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
|
||||
YACCFLAGS = -d -t -v
|
||||
|
||||
|
|
|
@ -6,6 +6,6 @@
|
|||
DEFINES += -D_GNU_SOURCE
|
||||
-CCOPTS = -O2
|
||||
+CCOPTS = -O2 $(EXTRA_CCOPTS)
|
||||
WFLAGS := -Wall -Wstrict-prototypes
|
||||
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
||||
WFLAGS += -Wmissing-declarations -Wold-style-definition
|
||||
|
||||
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
|
||||
|
|
|
@ -10,7 +10,7 @@
|
|||
TCMODULES += q_tbf.o
|
||||
--- a/include/linux/pkt_sched.h
|
||||
+++ b/include/linux/pkt_sched.h
|
||||
@@ -214,6 +214,33 @@ struct tc_sfq_xstats {
|
||||
@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
|
||||
__s32 allot;
|
||||
};
|
||||
|
||||
|
|
Loading…
Reference in a new issue