mkimage: update to 2011.12
Signed-off-by: Luka Perkov <openwrt@lukaperkov.net> SVN-Revision: 31171
This commit is contained in:
parent
fe44af36ae
commit
6d4358aed0
3 changed files with 12 additions and 34 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
# Copyright (C) 2006-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,11 +7,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mkimage
|
PKG_NAME:=mkimage
|
||||||
PKG_VERSION:=2011.06
|
PKG_VERSION:=2011.12
|
||||||
|
|
||||||
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
|
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
|
||||||
PKG_MD5SUM:=0cc5026aad02f218a9b9ac56b301c97a
|
PKG_MD5SUM:=7f29b9f6da44d6e46e988e7561fd1d5f
|
||||||
PKG_CAT:=bzcat
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/tools/os_support.h
|
|
||||||
+++ b/tools/os_support.h
|
|
||||||
@@ -28,7 +28,7 @@
|
|
||||||
#include "mingw_support.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#ifdef __APPLE__
|
|
||||||
+#if defined(__APPLE__) && __DARWIN_C_LEVEL < 200809L
|
|
||||||
#include "getline.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
--- a/tools/os_support.c
|
|
||||||
+++ b/tools/os_support.c
|
|
||||||
@@ -23,6 +23,7 @@
|
|
||||||
#ifdef __MINGW32__
|
|
||||||
#include "mingw_support.c"
|
|
||||||
#endif
|
|
||||||
-#ifdef __APPLE__
|
|
||||||
+
|
|
||||||
+#if defined(__APPLE__) && __DARWIN_C_LEVEL < 200809L
|
|
||||||
#include "getline.c"
|
|
||||||
#endif
|
|
|
@ -8,7 +8,7 @@
|
||||||
.dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
|
.dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
|
||||||
.imagename = "",
|
.imagename = "",
|
||||||
};
|
};
|
||||||
@@ -180,6 +181,16 @@ main (int argc, char **argv)
|
@@ -186,6 +187,16 @@ main (int argc, char **argv)
|
||||||
genimg_get_comp_id (*++argv)) < 0)
|
genimg_get_comp_id (*++argv)) < 0)
|
||||||
usage ();
|
usage ();
|
||||||
goto NXTARG;
|
goto NXTARG;
|
||||||
|
@ -25,7 +25,7 @@
|
||||||
case 'D':
|
case 'D':
|
||||||
if (--argc <= 0)
|
if (--argc <= 0)
|
||||||
usage ();
|
usage ();
|
||||||
@@ -580,12 +591,13 @@ usage ()
|
@@ -595,12 +606,13 @@ usage ()
|
||||||
fprintf (stderr, "Usage: %s -l image\n"
|
fprintf (stderr, "Usage: %s -l image\n"
|
||||||
" -l ==> list image header information\n",
|
" -l ==> list image header information\n",
|
||||||
params.cmdname);
|
params.cmdname);
|
||||||
|
@ -42,7 +42,7 @@
|
||||||
" -n ==> set image name to 'name'\n"
|
" -n ==> set image name to 'name'\n"
|
||||||
--- a/tools/mkimage.h
|
--- a/tools/mkimage.h
|
||||||
+++ b/tools/mkimage.h
|
+++ b/tools/mkimage.h
|
||||||
@@ -64,6 +64,7 @@ struct mkimage_params {
|
@@ -65,6 +65,7 @@ struct mkimage_params {
|
||||||
int arch;
|
int arch;
|
||||||
int type;
|
int type;
|
||||||
int comp;
|
int comp;
|
||||||
|
@ -52,12 +52,12 @@
|
||||||
unsigned int ep;
|
unsigned int ep;
|
||||||
--- a/tools/default_image.c
|
--- a/tools/default_image.c
|
||||||
+++ b/tools/default_image.c
|
+++ b/tools/default_image.c
|
||||||
@@ -110,7 +110,7 @@ static void image_set_header (void *ptr,
|
@@ -111,7 +111,7 @@ static void image_set_header(void *ptr,
|
||||||
sbuf->st_size - sizeof(image_header_t));
|
sbuf->st_size - sizeof(image_header_t));
|
||||||
|
|
||||||
/* Build new header */
|
/* Build new header */
|
||||||
- image_set_magic (hdr, IH_MAGIC);
|
- image_set_magic(hdr, IH_MAGIC);
|
||||||
+ image_set_magic (hdr, params->magic);
|
+ image_set_magic(hdr, params->magic);
|
||||||
image_set_time (hdr, sbuf->st_mtime);
|
image_set_time(hdr, sbuf->st_mtime);
|
||||||
image_set_size (hdr, sbuf->st_size - sizeof(image_header_t));
|
image_set_size(hdr, sbuf->st_size - sizeof(image_header_t));
|
||||||
image_set_load (hdr, params->addr);
|
image_set_load(hdr, params->addr);
|
||||||
|
|
Loading…
Reference in a new issue