util-linux(-ng): revert r31183, r31178 - the update introduced several regressions which need to be worked out first
SVN-Revision: 31202
This commit is contained in:
parent
8d0abd27dc
commit
6940ba2a1a
2 changed files with 71 additions and 82 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2007-2012 OpenWrt.org
|
# Copyright (C) 2007-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,42 +7,22 @@
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=util-linux
|
PKG_NAME:=util-linux-ng
|
||||||
PKG_VERSION:=2.20.1
|
PKG_VERSION:=2.13.0.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.20
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.13
|
||||||
PKG_MD5SUM:=fcd18041c5390178b1aadc2fd298bee8
|
PKG_MD5SUM:=c841dc8743905c8f0db20c9db5094f57
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
PKG_BUILD_DEPENDS=e2fsprogs libncurses
|
PKG_BUILD_DEPENDS=e2fsprogs libncurses
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/util-linux/Default
|
define Package/util-linux/Default
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
|
URL:=http://www.kernel.org/pub/linux/utils/util-linux-ng/
|
||||||
endef
|
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
|
||||||
scanf_cv_type_modifier="ms"
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--disable-nls \
|
|
||||||
--disable-tls
|
|
||||||
|
|
||||||
define Package/cfdisk
|
|
||||||
$(call Package/util-linux/Default)
|
|
||||||
SUBMENU:=disc
|
|
||||||
TITLE:=Partition table manipulation utility
|
|
||||||
DEPENDS:= +libncurses
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/cfdisk/description
|
|
||||||
This package contains a utility for managing disk partition tables.
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/fdisk
|
define Package/fdisk
|
||||||
|
@ -55,6 +35,17 @@ define Package/fdisk/description
|
||||||
This package contains a utility for managing disk partition tables.
|
This package contains a utility for managing disk partition tables.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/cfdisk
|
||||||
|
$(call Package/util-linux/Default)
|
||||||
|
SUBMENU:=disc
|
||||||
|
TITLE:=Partition table manipulation utility
|
||||||
|
DEPENDS:= +libncurses
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/cfdisk/description
|
||||||
|
This package contains a utility for managing disk partition tables.
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/sfdisk
|
define Package/sfdisk
|
||||||
$(call Package/util-linux/Default)
|
$(call Package/util-linux/Default)
|
||||||
TITLE:=Partition table manipulation utility (Command-line)
|
TITLE:=Partition table manipulation utility (Command-line)
|
||||||
|
@ -65,24 +56,6 @@ define Package/sfdisk/description
|
||||||
This package contains a utility for managing disk partition tables using command-line only.
|
This package contains a utility for managing disk partition tables using command-line only.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/getopt
|
|
||||||
$(call Package/util-linux/Default)
|
|
||||||
TITLE:=Tool for parsing command parameters
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/getopt/description
|
|
||||||
getopt is a program to help shell scripts parse command-line parameters.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/hwclock
|
|
||||||
$(call Package/util-linux/Default)
|
|
||||||
TITLE:=Utilities for managing the hardware clock
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/hwclock/description
|
|
||||||
This package contains a utility for managing the hardware clock.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/losetup
|
define Package/losetup
|
||||||
$(call Package/util-linux/Default)
|
$(call Package/util-linux/Default)
|
||||||
TITLE:=Loopback devices setup and control utility
|
TITLE:=Loopback devices setup and control utility
|
||||||
|
@ -92,6 +65,16 @@ define Package/losetup/description
|
||||||
This package contains a utility for managing loopback devices.
|
This package contains a utility for managing loopback devices.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/mount-utils
|
||||||
|
$(call Package/util-linux/Default)
|
||||||
|
TITLE:=Devices mount/unmounting utilities
|
||||||
|
DEPENDS+= +libblkid +libuuid
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/mount-utils/description
|
||||||
|
This package contains utilities to mount/unmount devices.
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/swap-utils
|
define Package/swap-utils
|
||||||
$(call Package/util-linux/Default)
|
$(call Package/util-linux/Default)
|
||||||
SUBMENU:=disc
|
SUBMENU:=disc
|
||||||
|
@ -106,14 +89,13 @@ define Package/swap-utils/description
|
||||||
- swapoff
|
- swapoff
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/mount-utils
|
define Package/hwclock
|
||||||
$(call Package/util-linux/Default)
|
$(call Package/util-linux/Default)
|
||||||
TITLE:=Devices mount/unmounting utilities
|
TITLE:=Utilities for managing the hardware clock
|
||||||
DEPENDS+= +libblkid +libuuid
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/mount-utils/description
|
define Package/hwclock/description
|
||||||
This package contains utilities to mount/unmount devices.
|
This package contains a utility for managing the hardware clock.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/flock
|
define Package/flock
|
||||||
|
@ -133,7 +115,7 @@ $(call Package/util-linux/Default)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/setterm/description
|
define Package/setterm/description
|
||||||
This package contains a utility for setting terminal attributes.
|
This package contains a utility for setting terminal attributes
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/script
|
define Package/script
|
||||||
|
@ -144,26 +126,28 @@ endef
|
||||||
|
|
||||||
define Package/script/description
|
define Package/script/description
|
||||||
Script makes a typescript of everything printed on your terminal.
|
Script makes a typescript of everything printed on your terminal.
|
||||||
|
http://linux.die.net/man/1/script
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
|
$(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/fdisk cfdisk fdisk sfdisk
|
$(MAKE) -C $(PKG_BUILD_DIR)/mount swapon losetup umount mount
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/getopt getopt
|
$(MAKE) -C $(PKG_BUILD_DIR)/fdisk fdisk cfdisk sfdisk
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
|
$(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/mount losetup mount swapon umount
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/sys-utils flock
|
$(MAKE) -C $(PKG_BUILD_DIR)/sys-utils flock
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/term-utils setterm script
|
$(MAKE) -C $(PKG_BUILD_DIR)/misc-utils setterm
|
||||||
endef
|
$(MAKE) -C $(PKG_BUILD_DIR)/misc-utils script
|
||||||
|
|
||||||
define Package/cfdisk/install
|
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/.libs/cfdisk $(1)/sbin/
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/fdisk/install
|
define Package/fdisk/install
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
$(INSTALL_DIR) $(1)/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/.libs/fdisk $(1)/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/sbin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/cfdisk/install
|
||||||
|
$(INSTALL_DIR) $(1)/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/sfdisk/install
|
define Package/sfdisk/install
|
||||||
|
@ -171,31 +155,25 @@ define Package/sfdisk/install
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/sfdisk $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/sfdisk $(1)/usr/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/getopt/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/getopt/getopt $(1)/usr/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/hwclock/install
|
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/sbin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/losetup/install
|
define Package/losetup/install
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
$(INSTALL_DIR) $(1)/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/mount-utils/install
|
||||||
|
$(INSTALL_DIR) $(1)/bin/
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/{u,}mount $(1)/bin
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/swap-utils/install
|
define Package/swap-utils/install
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
$(INSTALL_DIR) $(1)/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/.libs/mkswap $(1)/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(PKG_BUILD_DIR)/mount/swapon $(1)/sbin/
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/.libs/swapon $(1)/sbin/
|
|
||||||
ln -sf swapon $(1)/sbin/swapoff
|
ln -sf swapon $(1)/sbin/swapoff
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/mount-utils/install
|
define Package/hwclock/install
|
||||||
$(INSTALL_DIR) $(1)/bin/
|
$(INSTALL_DIR) $(1)/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/.libs/{u,}mount $(1)/bin
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/flock/install
|
define Package/flock/install
|
||||||
|
@ -205,22 +183,22 @@ endef
|
||||||
|
|
||||||
define Package/setterm/install
|
define Package/setterm/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/setterm $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/setterm $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/script/install
|
define Package/script/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/term-utils/script $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/misc-utils/script $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,cfdisk))
|
|
||||||
$(eval $(call BuildPackage,fdisk))
|
$(eval $(call BuildPackage,fdisk))
|
||||||
|
$(eval $(call BuildPackage,cfdisk))
|
||||||
$(eval $(call BuildPackage,sfdisk))
|
$(eval $(call BuildPackage,sfdisk))
|
||||||
$(eval $(call BuildPackage,getopt))
|
|
||||||
$(eval $(call BuildPackage,hwclock))
|
|
||||||
$(eval $(call BuildPackage,losetup))
|
$(eval $(call BuildPackage,losetup))
|
||||||
$(eval $(call BuildPackage,swap-utils))
|
|
||||||
$(eval $(call BuildPackage,mount-utils))
|
$(eval $(call BuildPackage,mount-utils))
|
||||||
|
$(eval $(call BuildPackage,swap-utils))
|
||||||
|
$(eval $(call BuildPackage,hwclock))
|
||||||
$(eval $(call BuildPackage,flock))
|
$(eval $(call BuildPackage,flock))
|
||||||
$(eval $(call BuildPackage,setterm))
|
$(eval $(call BuildPackage,setterm))
|
||||||
$(eval $(call BuildPackage,script))
|
$(eval $(call BuildPackage,script))
|
11
package/util-linux-ng/patches/001-cris_avr32_label.patch
Normal file
11
package/util-linux-ng/patches/001-cris_avr32_label.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/fdisk/fdiskbsdlabel.h
|
||||||
|
+++ b/fdisk/fdiskbsdlabel.h
|
||||||
|
@@ -46,7 +46,7 @@
|
||||||
|
|
||||||
|
#define BSD_LINUX_BOOTDIR "/usr/ucb/mdec"
|
||||||
|
|
||||||
|
-#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__)
|
||||||
|
+#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__) || defined (__cris__) || defined(__avr32__)
|
||||||
|
#define BSD_LABELSECTOR 1
|
||||||
|
#define BSD_LABELOFFSET 0
|
||||||
|
#elif defined (__alpha__) || defined (__powerpc__) || defined (__ia64__) || defined (__hppa__)
|
Loading…
Reference in a new issue