mountd: add "-f" option to not daemonize mountd, use service wrappers in init script
SVN-Revision: 33378
This commit is contained in:
parent
95c141aaac
commit
6804bafadd
3 changed files with 24 additions and 4 deletions
|
@ -1,11 +1,11 @@
|
||||||
# Copyright (C) 2009-2011 OpenWrt.org
|
# Copyright (C) 2009-2012 OpenWrt.org
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mountd
|
PKG_NAME:=mountd
|
||||||
PKG_VERSION:=0.1
|
PKG_VERSION:=0.1
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||||
|
|
|
@ -1,12 +1,19 @@
|
||||||
#!/bin/sh /etc/rc.common
|
#!/bin/sh /etc/rc.common
|
||||||
|
|
||||||
START=80
|
START=80
|
||||||
|
|
||||||
|
SERVICE_DAEMONIZE=1
|
||||||
|
SERVICE_WRITE_PID=1
|
||||||
|
SERVICE_PID_FILE=/var/run/mountd.pid
|
||||||
|
|
||||||
|
MOUNTD_BIN=/sbin/mountd
|
||||||
|
|
||||||
start()
|
start()
|
||||||
{
|
{
|
||||||
/sbin/mountd
|
service_start $MOUNTD_BIN -f
|
||||||
}
|
}
|
||||||
|
|
||||||
stop()
|
stop()
|
||||||
{
|
{
|
||||||
killall mountd
|
service_stop $MOUNTD_BIN
|
||||||
}
|
}
|
||||||
|
|
13
package/mountd/patches/040-optional-daemonize.patch
Normal file
13
package/mountd/patches/040-optional-daemonize.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
--- a/main.c
|
||||||
|
+++ b/main.c
|
||||||
|
@@ -13,7 +13,9 @@
|
||||||
|
|
||||||
|
int main(int argc, char *argv[])
|
||||||
|
{
|
||||||
|
- daemon(0,0);
|
||||||
|
+ if ((argc < 2) || strcmp(argv[1], "-f"))
|
||||||
|
+ daemon(0,0);
|
||||||
|
+
|
||||||
|
daemonize = 1;
|
||||||
|
log_start();
|
||||||
|
log_printf("Starting OpenWrt (auto)mountd V1\n");
|
Loading…
Reference in a new issue