Add a RB1xx profile to generate RouterBoard RB1xx series image and kernel command line hack patch
SVN-Revision: 7194
This commit is contained in:
parent
16ee25b91a
commit
6674fa7803
4 changed files with 74 additions and 1 deletions
|
@ -235,7 +235,6 @@ CONFIG_SERIO_SERPORT=y
|
|||
# CONFIG_SND_USB_AUDIO is not set
|
||||
CONFIG_SOFT_WATCHDOG=m
|
||||
# CONFIG_SPARSEMEM_STATIC is not set
|
||||
CONFIG_SYN_COOKIES=y
|
||||
CONFIG_SYS_HAS_CPU_MIPS32_R1=y
|
||||
CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
|
||||
CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
|
||||
|
|
|
@ -62,6 +62,10 @@ define Image/Build/MyLoader
|
|||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).bin
|
||||
endef
|
||||
|
||||
define Image/Build/RouterBoard
|
||||
$(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
|
||||
endef
|
||||
|
||||
define Image/Build
|
||||
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
|
||||
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
|
||||
|
@ -88,6 +92,9 @@ ifneq ($(1),jffs2-128K)
|
|||
$(call Image/Build/MyLoader,$(1),wpp54g,$(patsubst jffs2-%,jffs2,$(1)),WPP54G)
|
||||
$(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)),WPP54AG)
|
||||
endif
|
||||
ifeq ($(1),tgz)
|
||||
$(call Image/Build/RouterBoard)
|
||||
endif
|
||||
endef
|
||||
|
||||
$(eval $(call BuildImage))
|
||||
|
|
50
target/linux/adm5120-2.6/patches/140-cmdline_hack.patch
Normal file
50
target/linux/adm5120-2.6/patches/140-cmdline_hack.patch
Normal file
|
@ -0,0 +1,50 @@
|
|||
diff -ur linux.old/arch/mips/kernel/head.S linux.dev/arch/mips/kernel/head.S
|
||||
--- linux.old/arch/mips/kernel/head.S 2006-12-06 17:30:27.000000000 +0100
|
||||
+++ linux.dev/arch/mips/kernel/head.S 2006-12-06 18:34:43.000000000 +0100
|
||||
@@ -129,15 +129,20 @@
|
||||
#endif
|
||||
.endm
|
||||
|
||||
-
|
||||
j kernel_entry
|
||||
nop
|
||||
-
|
||||
+ nop
|
||||
+
|
||||
/*
|
||||
* Reserved space for exception handlers.
|
||||
* Necessary for machines which link their kernels at KSEG0.
|
||||
+ * Use as temporary storage for the kernel command line, so that it
|
||||
+ * can be updated easily without having to relink the kernel.
|
||||
*/
|
||||
- .fill 0x400
|
||||
+
|
||||
+EXPORT(_image_cmdline)
|
||||
+ .ascii "CMDLINE:"
|
||||
+ .fill 0x3ec
|
||||
|
||||
EXPORT(stext) # used for profiling
|
||||
EXPORT(_stext)
|
||||
diff -ur linux.old/arch/mips/adm5120/prom.c linux.dev/arch/mips/adm5120/prom.c
|
||||
--- linux.old/arch/mips/adm5120/prom.c 2006-12-06 17:30:27.000000000 +0100
|
||||
+++ linux.dev/arch/mips/adm5120/prom.c 2006-12-06 17:41:40.000000000 +0100
|
||||
@@ -100,6 +100,7 @@
|
||||
}
|
||||
|
||||
|
||||
+extern char _image_cmdline;
|
||||
/*
|
||||
* initialize the prom module.
|
||||
*/
|
||||
@@ -112,8 +112,10 @@
|
||||
mips_machtype = adm5120_board.mach_type;
|
||||
|
||||
/* init command line, register a default kernel command line */
|
||||
- strcpy(&(arcs_cmdline[0]), CONFIG_CMDLINE);
|
||||
+ char *cmd = &_image_cmdline + 8;
|
||||
+ if( strlen(cmd) > 0) strcpy( &(arcs_cmdline[0]), cmd);
|
||||
+ else strcpy(&(arcs_cmdline[0]), CONFIG_CMDLINE);
|
||||
|
||||
/* init memory map */
|
||||
prom_meminit();
|
||||
}
|
17
target/linux/adm5120-2.6/profiles/RB1xx.mk
Normal file
17
target/linux/adm5120-2.6/profiles/RB1xx.mk
Normal file
|
@ -0,0 +1,17 @@
|
|||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
define Profile/RouterBoard
|
||||
NAME:=RouterBoard RB1xx
|
||||
PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2 patch-cmdline wget2nand
|
||||
endef
|
||||
|
||||
define Profile/RouterBoard/Description
|
||||
Package set compatible with the RouterBoard RB1xx devices. Contains USB support and RouterOS to OpenWrt\\\
|
||||
installation scripts.
|
||||
endef
|
||||
$(eval $(call Profile,RouterBoard))
|
Loading…
Reference in a new issue