tools: cmake: fix librt linking (FS#1032)
Commit 839129b864
"tools/cmake: Update to 3.9.3" improperly rebased the
librt linking patch, causing FS#381 to resurface.
Fixes FS#1032.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
5508510e74
commit
64da598c8f
1 changed files with 7 additions and 7 deletions
|
@ -20,14 +20,14 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
||||||
---
|
---
|
||||||
--- a/Utilities/cmcurl/CMakeLists.txt
|
--- a/Utilities/cmcurl/CMakeLists.txt
|
||||||
+++ b/Utilities/cmcurl/CMakeLists.txt
|
+++ b/Utilities/cmcurl/CMakeLists.txt
|
||||||
@@ -471,6 +471,10 @@ if(CMAKE_USE_OPENSSL)
|
@@ -456,6 +456,10 @@ if(CMAKE_USE_OPENSSL)
|
||||||
check_symbol_exists(RAND_status "${CURL_INCLUDES}" HAVE_RAND_STATUS)
|
set(USE_OPENSSL ON)
|
||||||
check_symbol_exists(RAND_screen "${CURL_INCLUDES}" HAVE_RAND_SCREEN)
|
set(HAVE_LIBCRYPTO ON)
|
||||||
check_symbol_exists(RAND_egd "${CURL_INCLUDES}" HAVE_RAND_EGD)
|
set(HAVE_LIBSSL ON)
|
||||||
+ check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
|
+ check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
|
||||||
+ if(HAVE_LIBRT)
|
+ if(HAVE_LIBRT)
|
||||||
+ list(APPEND OPENSSL_LIBRARIES rt)
|
+ list(APPEND OPENSSL_LIBRARIES rt)
|
||||||
+ endif()
|
+ endif()
|
||||||
|
list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
|
||||||
# Optionally build with a specific CA cert bundle.
|
include_directories(${OPENSSL_INCLUDE_DIR})
|
||||||
if(CURL_CA_BUNDLE)
|
set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
|
||||||
|
|
Loading…
Reference in a new issue