refresh 2.6.28 patches
SVN-Revision: 14198
This commit is contained in:
parent
3f3b9a86a3
commit
6400108bbb
2 changed files with 6 additions and 13 deletions
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/leds/Kconfig
|
||||
+++ b/drivers/leds/Kconfig
|
||||
@@ -223,4 +223,12 @@ config LEDS_TRIGGER_NETDEV
|
||||
@@ -234,4 +234,12 @@ config LEDS_TRIGGER_NETDEV
|
||||
This allows LEDs to be controlled by network device activity.
|
||||
If unsure, say Y.
|
||||
|
||||
|
@ -15,7 +15,7 @@
|
|||
endif # NEW_LEDS
|
||||
--- a/drivers/leds/Makefile
|
||||
+++ b/drivers/leds/Makefile
|
||||
@@ -32,3 +32,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
|
||||
@@ -33,3 +33,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
|
||||
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
||||
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
||||
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|
||||
|
|
|
@ -1,13 +1,6 @@
|
|||
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
@@ -44,12 +44,19 @@
|
||||
#define MANUFACTURER_AMD 0x0001
|
||||
#define MANUFACTURER_ATMEL 0x001F
|
||||
#define MANUFACTURER_SST 0x00BF
|
||||
+#define MANUFACTURER_MACRONIX 0x00C2
|
||||
#define SST49LF004B 0x0060
|
||||
#define SST49LF040B 0x0050
|
||||
#define SST49LF008A 0x005a
|
||||
@@ -53,6 +53,12 @@
|
||||
#define AT49BV6416 0x00d6
|
||||
#define MANUFACTURER_SAMSUNG 0x00ec
|
||||
|
||||
|
@ -20,7 +13,7 @@
|
|||
static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
|
||||
static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
|
||||
static int cfi_amdstd_write_buffers(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
|
||||
@@ -240,6 +247,41 @@ static void fixup_s29gl032n_sectors(stru
|
||||
@@ -283,6 +289,41 @@ static void fixup_s29gl032n_sectors(stru
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -62,7 +55,7 @@
|
|||
static struct cfi_fixup cfi_fixup_table[] = {
|
||||
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
|
||||
#ifdef AMD_BOOTLOC_BUG
|
||||
@@ -275,6 +317,9 @@ static struct cfi_fixup fixup_table[] =
|
||||
@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
|
||||
*/
|
||||
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_erase_chip, NULL },
|
||||
{ CFI_MFR_ATMEL, AT49BV6416, fixup_use_atmel_lock, NULL },
|
||||
|
@ -74,7 +67,7 @@
|
|||
|
||||
--- a/drivers/mtd/chips/Kconfig
|
||||
+++ b/drivers/mtd/chips/Kconfig
|
||||
@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
|
||||
@@ -198,6 +198,14 @@ config MTD_CFI_AMDSTD
|
||||
provides support for one of those command sets, used on chips
|
||||
including the AMD Am29LV320.
|
||||
|
||||
|
|
Loading…
Reference in a new issue