mountd: Rename uci_add_history to uci_add_delta (#8084)
SVN-Revision: 23474
This commit is contained in:
parent
8083a4380b
commit
6239db34b1
2 changed files with 28 additions and 1 deletions
|
@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=mountd
|
||||
PKG_VERSION:=0.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
|
|
27
package/mountd/patches/010-uci_rename_history_to_delta.patch
Normal file
27
package/mountd/patches/010-uci_rename_history_to_delta.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
---
|
||||
lib/uci.c | 2 +-
|
||||
lib/ucix.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/lib/uci.c
|
||||
+++ b/lib/uci.c
|
||||
@@ -28,7 +28,7 @@ struct uci_package *p = NULL;
|
||||
struct uci_context* uci_init(char *config_file)
|
||||
{
|
||||
struct uci_context *ctx = uci_alloc_context();
|
||||
- uci_add_history_path(ctx, "/var/state");
|
||||
+ uci_add_delta_path(ctx, "/var/state");
|
||||
if(uci_load(ctx, config_file, &p) != UCI_OK)
|
||||
{
|
||||
log_printf("/etc/config/%s is missing or corrupt\n", config_file);
|
||||
--- a/lib/ucix.c
|
||||
+++ b/lib/ucix.c
|
||||
@@ -18,7 +18,7 @@ static inline int ucix_get_ptr(struct uc
|
||||
struct uci_context* ucix_init(const char *config_file)
|
||||
{
|
||||
struct uci_context *ctx = uci_alloc_context();
|
||||
- uci_add_history_path(ctx, "/var/state");
|
||||
+ uci_add_delta_path(ctx, "/var/state");
|
||||
if(uci_load(ctx, config_file, NULL) != UCI_OK)
|
||||
{
|
||||
printf("%s/%s is missing or corrupt\n", ctx->savedir, config_file);
|
Loading…
Reference in a new issue