move files, rename defines for ifxmips
SVN-Revision: 11565
This commit is contained in:
parent
1a7f41506d
commit
5eda098fa7
6 changed files with 77 additions and 45 deletions
|
@ -20,10 +20,6 @@ config IFXMIPS_LED
|
|||
bool "IFXMips led"
|
||||
default y
|
||||
|
||||
config IFXMIPS_GPIO
|
||||
bool "IFXMips gpio"
|
||||
default y
|
||||
|
||||
config IFXMIPS_SSC
|
||||
bool "IFXMips ssc"
|
||||
default y
|
||||
|
|
|
@ -1 +1 @@
|
|||
obj-y := reset.o prom.o setup.o interrupt.o dma-core.o pmu.o board.o cgu.o gptu.o
|
||||
obj-y := reset.o prom.o setup.o interrupt.o dma-core.o pmu.o board.o cgu.o gptu.o gpio.o
|
||||
|
|
|
@ -32,33 +32,33 @@
|
|||
#include <asm/ifxmips/ifxmips.h>
|
||||
|
||||
static void
|
||||
ifxmips_machine_restart (char *command)
|
||||
ifxmips_machine_restart(char *command)
|
||||
{
|
||||
printk (KERN_NOTICE "System restart\n");
|
||||
local_irq_disable ();
|
||||
printk(KERN_NOTICE "System restart\n");
|
||||
local_irq_disable();
|
||||
|
||||
ifxmips_w32(ifxmips_r32(IFXMIPS_RCU_REQ) | IFXMIPS_RST_ALL, IFXMIPS_RCU_REQ);
|
||||
for (;;);
|
||||
ifxmips_w32(ifxmips_r32(IFXMIPS_RCU_RST) | IFXMIPS_RCU_RST_ALL, IFXMIPS_RCU_RST);
|
||||
for(;;);
|
||||
}
|
||||
|
||||
static void
|
||||
ifxmips_machine_halt (void)
|
||||
ifxmips_machine_halt(void)
|
||||
{
|
||||
printk (KERN_NOTICE "System halted.\n");
|
||||
local_irq_disable ();
|
||||
for (;;);
|
||||
printk(KERN_NOTICE "System halted.\n");
|
||||
local_irq_disable();
|
||||
for(;;);
|
||||
}
|
||||
|
||||
static void
|
||||
ifxmips_machine_power_off (void)
|
||||
ifxmips_machine_power_off(void)
|
||||
{
|
||||
printk (KERN_NOTICE "Please turn off the power now.\n");
|
||||
local_irq_disable ();
|
||||
for (;;);
|
||||
local_irq_disable();
|
||||
for(;;);
|
||||
}
|
||||
|
||||
void
|
||||
ifxmips_reboot_setup (void)
|
||||
ifxmips_reboot_setup(void)
|
||||
{
|
||||
_machine_restart = ifxmips_machine_restart;
|
||||
_machine_halt = ifxmips_machine_halt;
|
||||
|
|
|
@ -725,9 +725,9 @@ mei_fuse_prg (void)
|
|||
{
|
||||
u32 reg_data, fuse_value;
|
||||
int i = 0;
|
||||
meiLongwordRead ( IFXMIPS_RCU_REQ, ®_data);
|
||||
meiLongwordRead ( IFXMIPS_RCU_RST, ®_data);
|
||||
while ((reg_data & 0x10000000) == 0) {
|
||||
meiLongwordRead ( IFXMIPS_RCU_REQ, ®_data);
|
||||
meiLongwordRead ( IFXMIPS_RCU_RST, ®_data);
|
||||
//add a watchdog
|
||||
i++;
|
||||
/* 0x4000 translate to about 16 ms@111M, so should be enough */
|
||||
|
@ -736,8 +736,8 @@ mei_fuse_prg (void)
|
|||
}
|
||||
// STEP a: Prepare memory for external accesses
|
||||
// Write fuse_en bit24
|
||||
meiLongwordRead (IFXMIPS_RCU_REQ, ®_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_REQ, reg_data | (1 << 24));
|
||||
meiLongwordRead (IFXMIPS_RCU_RST, ®_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_RST, reg_data | (1 << 24));
|
||||
|
||||
mei_fuse_rar_init ();
|
||||
for (i = 0; i < 4; i++) {
|
||||
|
@ -795,8 +795,8 @@ mei_fuse_prg (void)
|
|||
break;
|
||||
}
|
||||
}
|
||||
meiLongwordRead (IFXMIPS_RCU_REQ, ®_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_REQ, reg_data & 0xF7FFFFFF);
|
||||
meiLongwordRead (IFXMIPS_RCU_RST, ®_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_RST, reg_data & 0xF7FFFFFF);
|
||||
}
|
||||
|
||||
/**
|
||||
|
@ -912,11 +912,11 @@ meiResetARC (void)
|
|||
|
||||
meiHaltArc ();
|
||||
|
||||
meiLongwordRead (IFXMIPS_RCU_REQ, &arc_debug_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_REQ,
|
||||
meiLongwordRead (IFXMIPS_RCU_RST, &arc_debug_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_RST,
|
||||
arc_debug_data | IFXMIPS_RCU_RST_REQ_DFE |
|
||||
IFXMIPS_RCU_RST_REQ_AFE);
|
||||
meiLongwordWrite (IFXMIPS_RCU_REQ, arc_debug_data);
|
||||
meiLongwordWrite (IFXMIPS_RCU_RST, arc_debug_data);
|
||||
// reset ARC
|
||||
meiLongwordWrite(MEI_RST_CONTROL, MEI_SOFT_RESET);
|
||||
meiLongwordWrite(MEI_RST_CONTROL, 0);
|
||||
|
@ -2769,8 +2769,8 @@ mei_ioctl (MEI_inode_t * ino, MEI_file_t * fil, unsigned int command,
|
|||
*IFXMIPS_GPIO_P0_OD = (*IFXMIPS_GPIO_P0_OD) | 0x800;
|
||||
|
||||
//enable ARC JTAG
|
||||
meiLongwordRead(IFXMIPS_RCU_REQ, ®_data);
|
||||
meiLongwordWrite(IFXMIPS_RCU_REQ, reg_data | IFXMIPS_RCU_RST_REQ_ARC_JTAG);
|
||||
meiLongwordRead(IFXMIPS_RCU_RST, ®_data);
|
||||
meiLongwordWrite(IFXMIPS_RCU_RST, reg_data | IFXMIPS_RCU_RST_REQ_ARC_JTAG);
|
||||
break;
|
||||
|
||||
case GET_ADSL_LOOP_DIAGNOSTICS_MODE:
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
--- a/drivers/char/Makefile
|
||||
+++ b/drivers/char/Makefile
|
||||
@@ -113,6 +113,12 @@
|
||||
Index: linux-2.6.25.7/drivers/char/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/char/Makefile 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/char/Makefile 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -113,6 +113,11 @@
|
||||
obj-$(CONFIG_JS_RTC) += js-rtc.o
|
||||
js-rtc-y = rtc.o
|
||||
|
||||
+obj-$(CONFIG_IFXMIPS_LED) += ifxmips_led.o
|
||||
+obj-$(CONFIG_IFXMIPS_GPIO) += ifxmips_gpio.o
|
||||
+obj-$(CONFIG_IFXMIPS_SSC) += ifxmips_ssc.o
|
||||
+obj-$(CONFIG_IFXMIPS_EEPROM) += ifxmips_eeprom.o
|
||||
+obj-$(CONFIG_IFXMIPS_MEI) += ifxmips_mei_core.o
|
||||
|
@ -13,15 +14,19 @@
|
|||
# Files generated that shall be removed upon make clean
|
||||
clean-files := consolemap_deftbl.c defkeymap.c
|
||||
|
||||
--- a/drivers/mtd/maps/Makefile
|
||||
+++ b/drivers/mtd/maps/Makefile
|
||||
Index: linux-2.6.25.7/drivers/mtd/maps/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/mtd/maps/Makefile 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/mtd/maps/Makefile 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -68,3 +68,4 @@
|
||||
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
|
||||
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
|
||||
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
|
||||
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
||||
--- a/drivers/net/Kconfig
|
||||
+++ b/drivers/net/Kconfig
|
||||
Index: linux-2.6.25.7/drivers/net/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/net/Kconfig 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/net/Kconfig 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -351,6 +351,12 @@
|
||||
|
||||
source "drivers/net/arm/Kconfig"
|
||||
|
@ -35,8 +40,10 @@
|
|||
config AX88796
|
||||
tristate "ASIX AX88796 NE2000 clone support"
|
||||
depends on ARM || MIPS || SUPERH
|
||||
--- a/drivers/serial/Kconfig
|
||||
+++ b/drivers/serial/Kconfig
|
||||
Index: linux-2.6.25.7/drivers/serial/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/serial/Kconfig 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/serial/Kconfig 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -1327,6 +1327,14 @@
|
||||
Currently, only 8250 compatible ports are supported, but
|
||||
others can easily be added.
|
||||
|
@ -52,16 +59,20 @@
|
|||
config SERIAL_QE
|
||||
tristate "Freescale QUICC Engine serial port support"
|
||||
depends on QUICC_ENGINE
|
||||
--- a/drivers/serial/Makefile
|
||||
+++ b/drivers/serial/Makefile
|
||||
Index: linux-2.6.25.7/drivers/serial/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/serial/Makefile 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/serial/Makefile 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -66,4 +66,5 @@
|
||||
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
|
||||
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
|
||||
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
||||
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
||||
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
||||
--- a/drivers/watchdog/Makefile
|
||||
+++ b/drivers/watchdog/Makefile
|
||||
Index: linux-2.6.25.7/drivers/watchdog/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/watchdog/Makefile 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/watchdog/Makefile 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -96,6 +96,7 @@
|
||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||
|
@ -70,10 +81,35 @@
|
|||
|
||||
# PARISC Architecture
|
||||
|
||||
--- a/drivers/net/Makefile
|
||||
+++ b/drivers/net/Makefile
|
||||
Index: linux-2.6.25.7/drivers/net/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/net/Makefile 2008-06-18 00:34:41.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/net/Makefile 2008-06-18 00:36:56.000000000 +0200
|
||||
@@ -254,3 +254,4 @@
|
||||
obj-$(CONFIG_NETXEN_NIC) += netxen/
|
||||
obj-$(CONFIG_NIU) += niu.o
|
||||
obj-$(CONFIG_VIRTIO_NET) += virtio_net.o
|
||||
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
|
||||
Index: linux-2.6.25.7/drivers/crypto/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/crypto/Kconfig 2008-06-18 18:10:24.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/crypto/Kconfig 2008-06-18 18:11:46.000000000 +0200
|
||||
@@ -9,6 +9,9 @@
|
||||
If you say N, all options in this submenu will be skipped and disabled.
|
||||
|
||||
if CRYPTO_HW
|
||||
+config CRYPTO_DEV_IFXMIPS
|
||||
+ tristate "Support for IFXMIPS Data Encryption Unit"
|
||||
+ depends on IFXMIPS
|
||||
|
||||
config CRYPTO_DEV_PADLOCK
|
||||
tristate "Support for VIA PadLock ACE"
|
||||
Index: linux-2.6.25.7/drivers/crypto/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.25.7.orig/drivers/crypto/Makefile 2008-06-18 18:09:30.000000000 +0200
|
||||
+++ linux-2.6.25.7/drivers/crypto/Makefile 2008-06-18 18:10:18.000000000 +0200
|
||||
@@ -2,3 +2,4 @@
|
||||
obj-$(CONFIG_CRYPTO_DEV_PADLOCK_SHA) += padlock-sha.o
|
||||
obj-$(CONFIG_CRYPTO_DEV_GEODE) += geode-aes.o
|
||||
obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o
|
||||
+obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o
|
||||
|
|
Loading…
Reference in a new issue