mac80211: fix r21990
SVN-Revision: 21992
This commit is contained in:
parent
ffa2e4eaec
commit
5c42c43638
1 changed files with 9 additions and 5 deletions
|
@ -1,11 +1,15 @@
|
|||
--- a/scripts/gen-compat-autoconf.sh
|
||||
+++ b/scripts/gen-compat-autoconf.sh
|
||||
@@ -192,7 +192,7 @@ if [ -f $KLIB_BUILD/Makefile ]; then
|
||||
@@ -191,10 +191,8 @@ if [ -f $KLIB_BUILD/Makefile ]; then
|
||||
echo CONFIG_NETDEVICES_MULTIQUEUE >> $MULT_DEP_FILE
|
||||
define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS
|
||||
rm -f $MULT_DEP_FILE
|
||||
# Kernels >= 2.6.32 can disable WEXT :D
|
||||
- # Kernels >= 2.6.32 can disable WEXT :D
|
||||
- if [ $SUBLEVEL -le 32 ]; then
|
||||
+ if [ $SUBLEVEL -le 35 ]; then
|
||||
define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
|
||||
- define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
|
||||
- fi
|
||||
+ # Up to kernel 2.6.35 we still need the following:
|
||||
+ define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
|
||||
fi
|
||||
fi
|
||||
echo "#endif /* COMPAT_AUTOCONF_INCLUDED */"
|
||||
|
|
Loading…
Reference in a new issue